summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-11-08 12:39:58 +0800
committerzxp198210052023-11-08 12:39:58 +0800
commite1989f0678148e34dd587adab6a0221f40d1c837 (patch)
tree293851ab659ceaaba9b5bcf5d321ca800fceeeff
parent29c2cd178ffbdb26e69e0fb6349c01f95b0598e2 (diff)
downloadaur-e1989f0678148e34dd587adab6a0221f40d1c837.tar.gz
fix errors
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD28
-rw-r--r--protoman.sh5
3 files changed, 32 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 20ed447a90f2..572fc0d2b80b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,17 @@
pkgbase = protoman-bin
pkgdesc = A Postman-like API client for protobuf-based messages.
pkgver = 0.4.1
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/spluxx/Protoman
arch = x86_64
license = MIT
+ makedepends = squashfuse
depends = bash
depends = electron9
+ depends = gdk-pixbuf2
+ depends = libxext
+ depends = gtk2
+ depends = libdbusmenu-glib
provides = protoman=0.4.1
conflicts = protoman
source = protoman-0.4.1.AppImage::https://github.com/spluxx/Protoman/releases/download/v0.4.1/Protoman-0.4.1.AppImage
@@ -14,6 +19,6 @@ pkgbase = protoman-bin
source = protoman.sh
sha256sums = 50934845993c2bcaaa3a659c907703fd9eef16dbf68f714aad512ff8b06445a3
sha256sums = a70b7631e4233a150ba463a503958f7e76bbb44d3da40ef36b22e4cc158742d9
- sha256sums = 23359ac62efbecec1270da119f4a87ea03dcde6c7229b747184d93a58e4d1a54
+ sha256sums = 0ef9e22d6860cca400e93d466b213f978f4ecd197da5aaf81d5109aa00fe376b
pkgname = protoman-bin
diff --git a/PKGBUILD b/PKGBUILD
index 14d5c60de8bd..d5e2db16ea4d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,28 +2,42 @@
pkgname=protoman-bin
_pkgname=Protoman
pkgver=0.4.1
-pkgrel=2
+pkgrel=3
pkgdesc="A Postman-like API client for protobuf-based messages."
arch=("x86_64")
url="https://github.com/spluxx/Protoman"
license=("MIT")
provides=("${pkgname%-bin}=${pkgver}")
conflicts=("${pkgname%-bin}")
-depends=('bash' 'electron9')
-source=("${pkgname%-bin}-${pkgver}.AppImage::${url}/releases/download/v${pkgver}/${_pkgname}-${pkgver}.AppImage"
+depends=(
+ 'bash'
+ 'electron9'
+ 'gdk-pixbuf2'
+ 'libxext'
+ 'gtk2'
+ 'libdbusmenu-glib'
+)
+makedepends=(
+ 'squashfuse'
+)
+source=(
+ "${pkgname%-bin}-${pkgver}.AppImage::${url}/releases/download/v${pkgver}/${_pkgname}-${pkgver}.AppImage"
"LICENSE.txt::https://raw.githubusercontent.com/spluxx/Protoman/v${pkgver}/LICENSE.txt"
- "${pkgname%-bin}.sh")
+ "${pkgname%-bin}.sh"
+)
sha256sums=('50934845993c2bcaaa3a659c907703fd9eef16dbf68f714aad512ff8b06445a3'
'a70b7631e4233a150ba463a503958f7e76bbb44d3da40ef36b22e4cc158742d9'
- '23359ac62efbecec1270da119f4a87ea03dcde6c7229b747184d93a58e4d1a54')
-prepare() {
+ '0ef9e22d6860cca400e93d466b213f978f4ecd197da5aaf81d5109aa00fe376b')
+build() {
chmod a+x "${srcdir}/${pkgname%-bin}-${pkgver}.AppImage"
"${srcdir}/${pkgname%-bin}-${pkgver}.AppImage" --appimage-extract > /dev/null
sed "s|AppRun|${pkgname%-bin}|g" -i "${srcdir}/squashfs-root/${pkgname%-bin}.desktop"
}
package() {
install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/usr/bin/${pkgname%-bin}"
- install -Dm644 "${srcdir}/squashfs-root/resources/app.asar" "${pkgdir}/opt/${pkgname%-bin}/${pkgname%-bin}.asar"
+ install -Dm644 "${srcdir}/squashfs-root/resources/app.asar" -t "${pkgdir}/usr/lib/${pkgname%-bin}"
+ install -Dm644 "${srcdir}/squashfs-root/swiftshader/"* -t "${pkgdir}/usr/lib/${pkgname%-bin}/swiftshader"
+ install -Dm644 "${srcdir}/squashfs-root/usr/lib/"* -t "${pkgdir}/usr/lib/${pkgname%-bin}/usr/lib"
install -Dm644 "${srcdir}/squashfs-root/${pkgname%-bin}.desktop" -t "${pkgdir}/usr/share/applications"
install -Dm644 "${srcdir}/squashfs-root/usr/share/icons/hicolor/0x0/apps/${pkgname%-bin}.png" -t "${pkgdir}/usr/share/pixmaps"
install -Dm644 "${srcdir}/LICENSE.txt" -t "${pkgdir}/usr/share/licenses/${pkgname}"
diff --git a/protoman.sh b/protoman.sh
index 75d649d901f3..4ee0e6e6ccef 100644
--- a/protoman.sh
+++ b/protoman.sh
@@ -1,6 +1,9 @@
#!/bin/bash
_ELECTRON=/usr/bin/electron9
-_ASAR="/opt/protoman/protoman.asar"
+APPDIR="/usr/lib/protoman"
+export PATH="${APPDIR}:${PATH}"
+export LD_LIBRARY_PATH="${APPDIR}/swiftshader:${APPDIR}/lib:${LD_LIBRARY_PATH}"
+_ASAR="${APPDIR}/app.asar"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
exec ${_ELECTRON} ${_ASAR} "$@"
else