summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSean Anderson2018-08-21 21:22:27 -0400
committerSean Anderson2018-08-21 21:22:27 -0400
commit39a9eb4726d95d1b2ec9ea5c2744cde4166889dc (patch)
treebbe48276d2c5c1a7f7e53e6d6ff43b77a03d39b8
downloadaur-39a9eb4726d95d1b2ec9ea5c2744cde4166889dc.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD93
2 files changed, 107 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1b5013cbf257
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = proton
+ pkgdesc = Compatibility tool for Steam Play based on Wine and additional components
+ pkgver = 3.7_20180821
+ pkgrel = 1
+ url = https://github.com/ValveSoftware/Proton/
+ arch = x86_64
+ license = BSD
+ depends = python2
+ depends = wine
+ source = https://github.com/ValveSoftware/Proton/archive/proton-3.7-20180821.tar.gz
+ md5sums = 7a14f75fcde394c3883800dc51b105a5
+
+pkgname = proton
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ce12297ccbd2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,93 @@
+# Mantainer: Sean Anderson <seanga2@gamil.com>
+pkgname=proton
+pkgver=3.7_20180821
+pkgrel=1
+epoch=
+pkgdesc="Compatibility tool for Steam Play based on Wine and additional components"
+arch=('x86_64')
+url="https://github.com/ValveSoftware/Proton/"
+license=('BSD')
+groups=()
+depends=(
+ 'python2'
+ 'wine'
+# 'openvr'
+)
+makedepends=(
+# 'vulkan-headers'
+)
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("https://github.com/ValveSoftware/Proton/archive/$pkgname-${pkgver//_/-}.tar.gz")
+noextract=()
+md5sums=('7a14f75fcde394c3883800dc51b105a5')
+
+prepare() {
+ cd "Proton-$pkgname-${pkgver//_/-}"
+ sed -i 's/openvr_v0.9.16//g' vrclient_x64/vrclient_x64/*
+}
+
+build() {
+ cd "Proton-$pkgname-${pkgver//_/-}"
+
+ export CXXFLAGS="$CXXFLAGS -Wno-attributes"
+ export WINEMAKEFLAGS="--nosource-fix --nolower-include --nodlls --nomsvcrt --dll"
+ export WINEMAKEFLAGS32="$WINEMAKEFLAGS --wine32"
+
+ # The build script provided has so much cruft that it's easier to make everything manually
+ mkdir -p build/lsteamclient.win32
+ cp -a lsteamclient/* build/lsteamclient.win32
+ cd build/lsteamclient.win32
+ winemaker $WINEMAKEFLAGS32 -DSTEAM_API_EXPORTS .
+ make
+ cd ../..
+
+ mkdir -p build/lsteamclient.win64
+ cp -a lsteamclient/* build/lsteamclient.win64
+ cd build/lsteamclient.win64
+ winemaker $WINEMAKEFLAGS -DSTEAM_API_EXPORTS .
+ make
+ cd ../..
+
+ # Currently depends on the custom bundled wine
+ # Will be re-enabled after I can make a package for it
+ #mkdir -p build/vrclient.win32
+ #cp -a vrclient_x64/* build/vrclient.win32
+ #cd build/vrclient.win32/vrclient_x64
+ #winemaker $WINEMAKEFLAGS32 .
+ #CXXFLAGS="$CXXFLAGS --std=c++0x" make
+ #winebuild --dll --fake-module -E vrclient_64.spec -o vrclient.dll.fake
+}
+
+check() {
+ cd "Proton-$pkgname-${pkgver//_/-}"
+}
+
+package() {
+ cd "Proton-$pkgname-${pkgver//_/-}"
+
+ install -d -m755 $pkgdir/usr/share/licenses/$pkgname
+ install -m644 LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
+ install -m644 LICENSE.proton $pkgdir/usr/share/licenses/$pkgname/LICENSE.proton
+ install -m644 dist.LICENSE.lin $pkgdir/usr/share/licenses/$pkgname/dist.LICENSE.lin
+
+ install -d -m755 $pkgdir/usr/share/doc/$pkgname
+ install -m644 README.md $pkgdir/usr/share/doc/$pkgname/README.md
+
+ install -d -m755 $pkgdir/usr/lib32/wine
+ install -m755 build/lsteamclient.win32/lsteamclient.dll.so $pkgdir/usr/lib32/wine/
+ #install build/vrclient.win32/vrclient.dll.so $pkgdir/usr/lib32/wine/
+
+ #install -d $pkgdir/usr/lib32/wine/fakedlls
+ #install build/vrclient.win32/vrclient.dll.fake $pkgdir/lib/wine/fakedlls/vrclient.dll
+
+ install -d -m755 $pkgdir/usr/lib/wine
+ install -m755 build/lsteamclient.win64/lsteamclient.dll.so $pkgdir/usr/lib/wine/
+}