summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcavery2021-02-11 15:14:19 -0500
committercavery2021-02-11 15:14:19 -0500
commit0ba7e62403d1360ca83190ab4b0a44bf2613bdee (patch)
tree3a4f29f3b0287aeb4030bcacaa308cc571690eb4
parent4925e06e795157d31563a8699722679553118675 (diff)
downloadaur-0ba7e62403d1360ca83190ab4b0a44bf2613bdee.tar.gz
new build system
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD13
2 files changed, 12 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bf96ba3ec2e7..aa05094f83bf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,13 @@
pkgbase = proton-caller-git
pkgdesc = Run any Windows program through Proton
- pkgver = 1.3.2.r10.g3b2fc50
+ pkgver = 2.0
pkgrel = 1
url = https://github.com/caverym/Proton-Caller/
arch = x86_64
license = GPL3
makedepends = git
+ makedepends = rust
+ makedepends = gcc
depends = steam
provides = proton-caller
conflicts = proton-caller
diff --git a/PKGBUILD b/PKGBUILD
index ef65940750f1..1856e9b1ffdd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Avery Murray <averylapine@gmail.com>
pkgname=proton-caller-git
-pkgver=1.3.2.r10.g3b2fc50
+pkgver=2.0
pkgrel=1
pkgdesc="Run any Windows program through Proton"
arch=('x86_64')
@@ -10,7 +10,7 @@ license=('GPL3')
depends=(
'steam'
)
-makedepends=('git')
+makedepends=('git' 'rust' 'gcc')
provides=(proton-caller)
conflicts=(proton-caller)
@@ -24,12 +24,17 @@ pkgver() {
build() {
cd Proton-Caller
- make
+ RUSTUP_TOOLCHAIN=${RUSTUP_TOOLCHAIN:-stable} cargo build --release --locked
+}
+
+check() {
+ cd Proton-Caller
+ RUSTUP_TOOLCHAIN=${RUSTUP_TOOLCHAIN:-stable} cargo test --release --locked
}
package() {
cd Proton-Caller
- install -Dm755 proton-call "$pkgdir"/usr/bin/proton-call
+ install -Dm755 target/release/proton-call "$pkgdir"/usr/bin/proton-call
install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
install -Dm644 manual/proton-call.6 "$pkgdir"/usr/share/man/man6/proton-call.6
}