summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStelios Tsampas2022-03-01 14:46:05 +0200
committerStelios Tsampas2022-03-01 14:46:05 +0200
commit130a607f380ab902321ad1c445c9252030e4bf89 (patch)
tree84f9406b29c964d1f695932908b301da7cde8d59
parent9bd0213d3eb7de17e7f2552590d8abd3f8058227 (diff)
downloadaur-130a607f380ab902321ad1c445c9252030e4bf89.tar.gz
Add wine patch to the repo due to checksum mismatch
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD2
-rw-r--r--wine-25946b48148784e8275c1685f6498ab88f553ca3.patch68
3 files changed, 70 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 533629745a93..701d66f12f6a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -228,7 +228,7 @@ pkgbase = proton-experimental
source = https://dl.winehq.org/wine/wine-gecko/2.47.2/wine-gecko-2.47.2-x86_64.tar.xz
source = https://github.com/madewokherd/wine-mono/releases/download/wine-mono-7.1.5/wine-mono-7.1.5-x86.tar.xz
source = dxvk-async-2c41ae8.patch::https://raw.githubusercontent.com/Sporif/dxvk-async/2c41ae8/dxvk-async.patch
- source = wine-25946b48148784e8275c1685f6498ab88f553ca3.patch::https://github.com/wine-mirror/wine/commit/25946b48148784e8275c1685f6498ab88f553ca3.patch
+ source = wine-25946b48148784e8275c1685f6498ab88f553ca3.patch
source = wine-winevulkan_fsr.patch
source = wine-more_8x5_res.patch
source = proton-sanitize_makefile.patch
diff --git a/PKGBUILD b/PKGBUILD
index 094fcedaa893..80dd2915f0f3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -125,7 +125,7 @@ source=(
https://dl.winehq.org/wine/wine-gecko/${_geckover}/wine-gecko-${_geckover}-x86{,_64}.tar.xz
https://github.com/madewokherd/wine-mono/releases/download/wine-mono-${_monover}/wine-mono-${_monover}-x86.tar.xz
dxvk-async-${_asyncver}.patch::https://raw.githubusercontent.com/Sporif/dxvk-async/${_asyncver}/dxvk-async.patch
- wine-25946b48148784e8275c1685f6498ab88f553ca3.patch::https://github.com/wine-mirror/wine/commit/25946b48148784e8275c1685f6498ab88f553ca3.patch
+ wine-25946b48148784e8275c1685f6498ab88f553ca3.patch
wine-winevulkan_fsr.patch
wine-more_8x5_res.patch
proton-sanitize_makefile.patch
diff --git a/wine-25946b48148784e8275c1685f6498ab88f553ca3.patch b/wine-25946b48148784e8275c1685f6498ab88f553ca3.patch
new file mode 100644
index 000000000000..c65a533a7d9c
--- /dev/null
+++ b/wine-25946b48148784e8275c1685f6498ab88f553ca3.patch
@@ -0,0 +1,68 @@
+From 25946b48148784e8275c1685f6498ab88f553ca3 Mon Sep 17 00:00:00 2001
+From: Eric Pouech <eric.pouech@gmail.com>
+Date: Fri, 4 Feb 2022 09:34:49 +0100
+Subject: [PATCH] wldap32: Fix compilation in 32-bit.
+
+32-bit compilation has been broken by 8db1662d749991a77b8945c752ab024d2d6b1244.
+
+Signed-off-by: Eric Pouech <eric.pouech@gmail.com>
+Signed-off-by: Hans Leidekker <hans@codeweavers.com>
+Signed-off-by: Alexandre Julliard <julliard@winehq.org>
+---
+ dlls/wldap32/libldap.c | 18 ++++++++++++++----
+ 1 file changed, 14 insertions(+), 4 deletions(-)
+
+diff --git a/dlls/wldap32/libldap.c b/dlls/wldap32/libldap.c
+index 8872421dabcd..592e526ecdc0 100644
+--- a/dlls/wldap32/libldap.c
++++ b/dlls/wldap32/libldap.c
+@@ -53,7 +53,14 @@ C_ASSERT( sizeof(LDAPSortKeyU) == sizeof(LDAPSortKey) );
+ C_ASSERT( sizeof(LDAPVLVInfoU) == sizeof(LDAPVLVInfo) );
+ C_ASSERT( sizeof(LDAPAPIInfoU) == sizeof(LDAPAPIInfo) );
+ C_ASSERT( sizeof(LDAPAPIFeatureInfoU) == sizeof(LDAPAPIFeatureInfo) );
+-C_ASSERT( sizeof(struct timevalU) == sizeof(struct timeval) );
++
++static struct timeval *convert_timeval(const struct timevalU *tvu, struct timeval *tv)
++{
++ if (!tvu) return NULL;
++ tv->tv_sec = tvu->tv_sec;
++ tv->tv_usec = tvu->tv_usec;
++ return tv;
++}
+
+ #define WLDAP32_LBER_ERROR (~0l)
+
+@@ -488,8 +495,9 @@ static NTSTATUS wrap_ldap_rename_s( void *args )
+ static NTSTATUS wrap_ldap_result( void *args )
+ {
+ struct ldap_result_params *params = args;
++ struct timeval tv;
+ return ldap_result( params->ld, params->msgid, params->all,
+- (struct timeval *)params->timeout, (LDAPMessage **)params->result );
++ convert_timeval(params->timeout, &tv), (LDAPMessage **)params->result );
+ }
+
+ static NTSTATUS wrap_ldap_sasl_bind( void *args )
+@@ -555,18 +563,20 @@ static NTSTATUS wrap_ldap_sasl_interactive_bind_s( void *args )
+ static NTSTATUS wrap_ldap_search_ext( void *args )
+ {
+ struct ldap_search_ext_params *params = args;
++ struct timeval tv;
+ return ldap_search_ext( params->ld, params->base, params->scope, params->filter, params->attrs,
+ params->attrsonly, (LDAPControl **)params->serverctrls,
+- (LDAPControl **)params->clientctrls, (struct timeval *)params->timeout,
++ (LDAPControl **)params->clientctrls, convert_timeval(params->timeout, &tv),
+ params->sizelimit, (int *)params->msg );
+ }
+
+ static NTSTATUS wrap_ldap_search_ext_s( void *args )
+ {
+ struct ldap_search_ext_s_params *params = args;
++ struct timeval tv;
+ return ldap_search_ext_s( params->ld, params->base, params->scope, params->filter, params->attrs,
+ params->attrsonly, (LDAPControl **)params->serverctrls,
+- (LDAPControl **)params->clientctrls, (struct timeval *)params->timeout,
++ (LDAPControl **)params->clientctrls, convert_timeval(params->timeout, &tv),
+ params->sizelimit, (LDAPMessage **)params->result );
+ }
+