summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStelios Tsampas2022-05-02 10:47:32 +0300
committerStelios Tsampas2022-05-02 10:47:32 +0300
commit3794f1189f7a9ebf141d378e4dcf12ff2f70ac40 (patch)
treee016b9542d4a14ccf63d680b11a3274ed664d1a4
parentaade0a32502b19349ea3dc1851e73d6875ff1f92 (diff)
downloadaur-3794f1189f7a9ebf141d378e4dcf12ff2f70ac40.tar.gz
Fix afdko call
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--proton-sanitize_makefile.patch33
3 files changed, 36 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9016c74e94a2..1b1858337168 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = proton-experimental
pkgdesc = Compatibility tool for Steam Play based on Wine and additional components, experimental branch
pkgver = 7.0.20220427c
- pkgrel = 2
+ pkgrel = 3
epoch = 1
url = https://github.com/ValveSoftware/Proton
arch = x86_64
@@ -266,7 +266,7 @@ pkgbase = proton-experimental
sha256sums = 11aa65bb6b8da1814557edf18a3cdada80135b021634236feabf93d2a194838b
sha256sums = d76b87410047f623accc846f15f849fe13275924c685ccfb95a91a8b22943e51
sha256sums = 9005d8169266ba0b93be30e1475fe9a3697464796f553886c155ec1d77d71215
- sha256sums = b024da38462b5a6da271b3e1d6212d317e69e6103ae627be4016f4c044bb58a0
+ sha256sums = 1176c3ef75516e2d0f4dad1dc6f8becb36018451a1fd7f59068d529101a046f8
sha256sums = 6ba5728332e5ea2b717855b1cd5c6e13ddc5b3ec34bfed4a78dbe3ef8e289806
sha256sums = 6126f8c93d73b7309fb22c244dae645c755c1ed8759caac3edc91d81a71e8f45
diff --git a/PKGBUILD b/PKGBUILD
index a04edecb60e9..55d33ce06a13 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ pkgver=${_srctag//-/.}
_geckover=2.47.2
_monover=7.2.0
_asyncver=1.10.1
-pkgrel=2
+pkgrel=3
epoch=1
pkgdesc="Compatibility tool for Steam Play based on Wine and additional components, experimental branch"
url="https://github.com/ValveSoftware/Proton"
@@ -408,6 +408,6 @@ sha256sums=('SKIP'
'11aa65bb6b8da1814557edf18a3cdada80135b021634236feabf93d2a194838b'
'd76b87410047f623accc846f15f849fe13275924c685ccfb95a91a8b22943e51'
'9005d8169266ba0b93be30e1475fe9a3697464796f553886c155ec1d77d71215'
- 'b024da38462b5a6da271b3e1d6212d317e69e6103ae627be4016f4c044bb58a0'
+ '1176c3ef75516e2d0f4dad1dc6f8becb36018451a1fd7f59068d529101a046f8'
'6ba5728332e5ea2b717855b1cd5c6e13ddc5b3ec34bfed4a78dbe3ef8e289806'
'6126f8c93d73b7309fb22c244dae645c755c1ed8759caac3edc91d81a71e8f45')
diff --git a/proton-sanitize_makefile.patch b/proton-sanitize_makefile.patch
index 144291d96a29..d1b154cf7ab5 100644
--- a/proton-sanitize_makefile.patch
+++ b/proton-sanitize_makefile.patch
@@ -1,5 +1,5 @@
diff --git a/Makefile.in b/Makefile.in
-index 6cfb8c3..fd90f1e 100644
+index 6cfb8c3..454da82 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -63,7 +63,6 @@ ifeq ($(ENABLE_CCACHE),1)
@@ -115,6 +115,37 @@ index 6cfb8c3..fd90f1e 100644
$(eval $(call rules-source,vkd3d-proton,$(SRCDIR)/vkd3d-proton))
$(eval $(call rules-meson,vkd3d-proton,32,CROSS))
$(eval $(call rules-meson,vkd3d-proton,64,CROSS))
+@@ -1080,14 +1102,14 @@ $(FONTS_OBJ)/source-han/%.ttf: $$(%.ttf_CIDFONT) $$(%.ttf_FEATURES) $$(%.ttf_SEQ
+ mkdir -p $(FONTS_OBJ)/source-han
+ # Do not immediately create the target file, so that make is interrupted
+ # it will restart again
+- afdko makeotfexe -f $($(notdir $@)_CIDFONT) -omitMacNames -ff $($(notdir $@)_FEATURES) \
++ makeotfexe -f $($(notdir $@)_CIDFONT) -omitMacNames -ff $($(notdir $@)_FEATURES) \
+ -lic ADOBE -mf $($(notdir $@)_MENUNAMEDB) -r -nS -cs 25 -ch $($(notdir $@)_UNISOURCE) \
+ -ci $($(notdir $@)_SEQUENCES) -o $@.tmp
+- afdko tx -cff +S -no_futile $($(notdir $@)_CIDFONT) $@.cff
++ tx -cff +S -no_futile $($(notdir $@)_CIDFONT) $@.cff
+ # sftnedit uses a hardcoded temporary file in the local directory, so we have
+ # to run it in a dedicated temporary directory to prevent concurrent instances
+ # to step onto each other's feet
+- (TEMP_DIR=`mktemp -d` && cd $$TEMP_DIR && afdko sfntedit -a CFF=$(abspath $($(notdir $@)).cff) $(abspath $@.tmp) && rm -fr $$TEMP_DIR)
++ (TEMP_DIR=`mktemp -d` && cd $$TEMP_DIR && sfntedit -a CFF=$(abspath $($(notdir $@)).cff) $(abspath $@.tmp) && rm -fr $$TEMP_DIR)
+ mv $@.tmp $@
+
+ $(FONTS_OBJ)/ume-gothic/%.ttf: $$(%.ttf_FONT) $$(%.ttf_NAMETABLE_PATCH)
+@@ -1097,10 +1119,10 @@ $(FONTS_OBJ)/ume-gothic/%.ttf: $$(%.ttf_FONT) $$(%.ttf_NAMETABLE_PATCH)
+ ttx -o $@ -m $($(notdir $@)_FONT) $(FONTS_OBJ)/ume-gothic/$(notdir $(basename $($(notdir $@)_NAMETABLE_PATCH))).ttx
+
+ $(simsun.ttc): $(simsun.ttf) $(nsimsun.ttf)
+- afdko otf2otc -o $@ $^
++ otf2otc -o $@ $^
+
+ $(msgothic.ttc): $(msgothic.ttf) $(mspgothic.ttf) $(msuigothic.ttf)
+- afdko otf2otc -o $@ $^
++ otf2otc -o $@ $^
+
+ $(micross.ttf): $(noto_sans.ttf) $(noto_sans_arabic.ttf) $(noto_sans_armenian.ttf) $(noto_sans_bengali.ttf) $(noto_sans_coptic.ttf) \
+ $(noto_sans_georgian.ttf) $(noto_sans_gujarati.ttf) $(noto_sans_hebrew.ttf) $(noto_sans_khmer.ttf) $(noto_sans_tamil.ttf) \
diff --git a/configure.sh b/configure.sh
index 337781e..0ceabc5 100755
--- a/configure.sh