summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStelios Tsampas2021-11-06 12:46:40 +0200
committerStelios Tsampas2021-11-06 12:46:40 +0200
commit7ae4cddd995aa637de57ddec17d86c2832c0c732 (patch)
tree7cfd308bd58af92acf588ee3e7d4d90e06b956b2
parent75b885957e0ea76f08c7d14b392306e646ba62b8 (diff)
downloadaur-7ae4cddd995aa637de57ddec17d86c2832c0c732.tar.gz
version: 6.3-20211106
-rw-r--r--PKGBUILD22
-rw-r--r--proton-sanitize_makefile.patch33
2 files changed, 32 insertions, 23 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8a1308c4bac6..38546a554c87 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: loathingkernel <loathingkernel _a_ gmail _d_ com>
pkgname=proton-experimental
-_srctag=6.3-20211027
+_srctag=6.3-20211106
_commit=
pkgver=${_srctag//-/.}
_geckover=2.47.2
@@ -155,14 +155,6 @@ prepare() {
[ ! -d build ] && mkdir build
cd proton
- pushd media-converter
- export RUSTUP_TOOLCHAIN=stable
- export CARGO_HOME="${srcdir}"/build/.cargo
- cargo update
- cargo fetch --locked --target "i686-unknown-linux-gnu"
- cargo fetch --locked --target "x86_64-unknown-linux-gnu"
- popd
-
_submodules=(
wine-valve::wine
dxvk-valve::dxvk
@@ -206,6 +198,14 @@ prepare() {
git submodule update external/Vulkan-Headers
popd
+ pushd media-converter
+ export RUSTUP_TOOLCHAIN=stable
+ export CARGO_HOME="${srcdir}"/build/.cargo
+ cargo update
+ cargo fetch --locked --target "i686-unknown-linux-gnu"
+ cargo fetch --locked --target "x86_64-unknown-linux-gnu"
+ popd
+
pushd wine
# Add FSR for fshack (doesn't compile)
#patch -p1 -i "$srcdir"/wine-winevulkan_fsr.patch
@@ -281,7 +281,7 @@ build() {
export RUSTUP_TOOLCHAIN=stable
export WINEESYNC=0
export WINEFSYNC=0
- export DISPLAY=""
+ export DISPLAY=
SUBJOBS=$([[ "$MAKEFLAGS" =~ -j\ *([1-9][0-9]*) ]] && echo "${BASH_REMATCH[1]}" || echo "$(nproc)") \
make -j1 dist
}
@@ -343,6 +343,6 @@ sha256sums=('SKIP'
'9212a9c42ac8c9c7b9ba7378685b27e7ea0e7a8a8aaac1f3f4d37590ada3e991'
'b4e9c0c4959fcb3f7b7f25e35e5e0577dac5d54fe18e6edb15852a2a4196f2a2'
'9005d8169266ba0b93be30e1475fe9a3697464796f553886c155ec1d77d71215'
- 'dd267386b793314b339a8b45e1335bc1820c77d4aa3c8c3946544f2017da2fce'
+ 'ef93b93fca2288dedc7e0d17ef2b5770349b295c6aaaa97a876e599af35375b7'
'12a587972a101a6d0c279a3820135277097c5f3e9f5990c5741d5fb1626dc770'
'cfe984e2b3d65b01e2875e51b8ef8b8d6f1268dd09a88d5611655f24b46cff8d')
diff --git a/proton-sanitize_makefile.patch b/proton-sanitize_makefile.patch
index 36431eb4c4d4..ecb206c22204 100644
--- a/proton-sanitize_makefile.patch
+++ b/proton-sanitize_makefile.patch
@@ -1,5 +1,5 @@
diff --git a/build/makefile_base.mak b/build/makefile_base.mak
-index 57ca0fb..6b913fe 100644
+index e07c04c..9450c6b 100644
--- a/build/makefile_base.mak
+++ b/build/makefile_base.mak
@@ -63,7 +63,6 @@ ifeq ($(ENABLE_CCACHE),1)
@@ -10,6 +10,15 @@ index 57ca0fb..6b913fe 100644
DOCKER_OPTS := $(CCACHE_ENV) -e CCACHE_DISABLE=1 $(DOCKER_OPTS)
endif
+@@ -121,7 +120,7 @@ container-build:
+ all32 $(MAKECMDGOALS32): container-build
+ all64 $(MAKECMDGOALS64): container-build
+ else
+-J = $(patsubst -j%,%,$(filter -j%,$(MAKEFLAGS)))
++J = $(patsubst -j%,%,$(SUBJOBS))
+ endif
+
+
@@ -171,7 +170,8 @@ else
endif
@@ -31,7 +40,7 @@ index 57ca0fb..6b913fe 100644
rm -rf $(abspath $(DIST_PREFIX))
python3 $(SRCDIR)/default_pfx.py $(abspath $(DIST_PREFIX)) $(abspath $(DST_DIR)) $(STEAM_RUNTIME_RUNSH)
-@@ -409,6 +409,9 @@ endif # ifeq ($(CONTAINER),)
+@@ -410,6 +410,9 @@ endif # ifeq ($(CONTAINER),)
##
GST_COMMON_MESON_ARGS := \
@@ -41,7 +50,7 @@ index 57ca0fb..6b913fe 100644
-Dexamples=disabled \
-Dtests=disabled \
-Dgtk_doc=disabled \
-@@ -421,6 +424,7 @@ GST_COMMON_MESON_ARGS := \
+@@ -422,6 +425,7 @@ GST_COMMON_MESON_ARGS := \
GST_ORC_MESON_ARGS := \
-Dorc-test=disabled \
@@ -49,7 +58,7 @@ index 57ca0fb..6b913fe 100644
$(GST_COMMON_MESON_ARGS)
$(eval $(call rules-source,gst_orc,$(SRCDIR)/gst-orc))
-@@ -437,6 +441,9 @@ GSTREAMER_MESON_ARGS := \
+@@ -438,6 +442,9 @@ GSTREAMER_MESON_ARGS := \
-Dbenchmarks=disabled \
-Dtools=disabled \
-Dbash-completion=disabled \
@@ -59,7 +68,7 @@ index 57ca0fb..6b913fe 100644
$(GST_COMMON_MESON_ARGS)
GSTREAMER_DEPENDS = gst_orc
-@@ -475,6 +482,7 @@ GST_BASE_MESON_ARGS := \
+@@ -476,6 +483,7 @@ GST_BASE_MESON_ARGS := \
-Dxshm=disabled \
-Dxvideo=disabled \
-Dtools=disabled \
@@ -67,7 +76,7 @@ index 57ca0fb..6b913fe 100644
$(GST_COMMON_MESON_ARGS)
GST_BASE_DEPENDS = gst_orc gstreamer
-@@ -536,6 +544,7 @@ GST_GOOD_MESON_ARGS := \
+@@ -537,6 +545,7 @@ GST_GOOD_MESON_ARGS := \
-Dximagesrc=disabled \
-Dy4m=disabled \
-Dtools=disabled \
@@ -75,7 +84,7 @@ index 57ca0fb..6b913fe 100644
$(GST_COMMON_MESON_ARGS)
GST_GOOD_DEPENDS = gst_orc gstreamer gst_base
-@@ -674,8 +683,14 @@ WINE_SOURCE_ARGS = \
+@@ -680,8 +689,14 @@ WINE_SOURCE_ARGS = \
--exclude include/config.h.in \
WINE_CONFIGURE_ARGS = \
@@ -90,7 +99,7 @@ index 57ca0fb..6b913fe 100644
--disable-tests
WINE_CONFIGURE_ARGS64 = --enable-win64
-@@ -804,17 +819,18 @@ VKD3D_CONFIGURE_ARGS = \
+@@ -810,17 +825,18 @@ VKD3D_CONFIGURE_ARGS = \
--disable-tests \
--disable-demos \
--without-ncurses \
@@ -110,7 +119,7 @@ index 57ca0fb..6b913fe 100644
VKD3D_LDFLAGS = -static-libgcc $(CROSSLDFLAGS)
VKD3D_LDFLAGS32 = -L$(WINE_OBJ32)/dlls/vulkan-1/
-@@ -844,7 +860,7 @@ VKD3D_PROTON_SOURCE_ARGS = \
+@@ -850,7 +866,7 @@ VKD3D_PROTON_SOURCE_ARGS = \
--exclude vkd3d_build.h.in \
--exclude vkd3d_version.h.in \
@@ -147,17 +156,17 @@ index 6567f05..cb41249 100644
endif
endef
diff --git a/make/rules-cargo.mk b/make/rules-cargo.mk
-index 5369fb4..21db917 100644
+index 36ec054..91d8cf0 100644
--- a/make/rules-cargo.mk
+++ b/make/rules-cargo.mk
@@ -14,7 +14,9 @@ $(OBJ)/.$(1)-configure$(3):
$(OBJ)/.$(1)-build$(3):
@echo ":: building $(3)bit $(1)..." >&2
cd $$($(2)_SRC) && env $$($(2)_ENV$(3)) \
-- cargo build --target "$$(ARCH$(3))-unknown-linux-gnu" --target-dir $$($(2)_OBJ$(3)) $$(CARGO_BUILD_ARG)
+- cargo build $$(filter -j%,$$(MAKEFLAGS)) --target "$$(ARCH$(3))-unknown-linux-gnu" --target-dir $$($(2)_OBJ$(3)) $$(CARGO_BUILD_ARG)
+ cargo update --offline --verbose
+ cd $$($(2)_SRC) && env $$($(2)_ENV$(3)) \
-+ cargo build --locked --offline --verbose --target "$$(ARCH$(3))-unknown-linux-gnu" --target-dir $$($(2)_OBJ$(3)) $$(CARGO_BUILD_ARG)
++ cargo build -j$$(SUBJOBS) --locked --offline --verbose --target "$$(ARCH$(3))-unknown-linux-gnu" --target-dir $$($(2)_OBJ$(3)) $$(CARGO_BUILD_ARG)
touch $$@
endif
endef