summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStelios Tsampas2024-03-05 16:17:44 +0200
committerStelios Tsampas2024-03-05 16:23:52 +0200
commit7d3d1bc2f4e13cef5cd24913a0b7e5fbbc62fcff (patch)
tree24d6dddd1ac19c4eb7005862902ed51f1b9cf9a2
parentf87c0f29f9cd41f37f741dc374cbf3dab70727bf (diff)
downloadaur-7d3d1bc2f4e13cef5cd24913a0b7e5fbbc62fcff.tar.gz
[proton-experimental] Revert changes and use mtune=generic
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD26
-rw-r--r--server-Enable-link-time-optimization.patch24
3 files changed, 8 insertions, 46 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 20e90f17ebd6..eba00cb25d23 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = proton-experimental
pkgdesc = Compatibility tool for Steam Play based on Wine and additional components, experimental branch
pkgver = 9.0.20240301
- pkgrel = 5
+ pkgrel = 6
epoch = 1
url = https://github.com/ValveSoftware/Proton
install = proton-experimental.install
@@ -144,7 +144,6 @@ pkgbase = proton-experimental
source = 0007-AUR-Enable-winewayland.patch
source = 0001-fshack-AMD-FSR-complete.patch
source = 4947.patch
- source = server-Enable-link-time-optimization.patch
sha256sums = SKIP
sha256sums = 2cfc8d5c948602e21eff8a78613e1826f2d033df9672cace87fed56e8310afb6
sha256sums = fd88fc7e537d058d7a8abf0c1ebc90c574892a466de86706a26d254710a82814
@@ -158,6 +157,5 @@ pkgbase = proton-experimental
sha256sums = b7297cabb316eb9621ec1abade892143392eba5fdbd3bd496df7992a7c9d7358
sha256sums = 3d308f8e87361669267fa52b986c24f1dea1913156a045f43ea04e02f7444b18
sha256sums = 0f9ddda17319e3ef23ee847c0a740bf74847796d4b3cf61b05feb9aa3141b7c7
- sha256sums = SKIP
pkgname = proton-experimental
diff --git a/PKGBUILD b/PKGBUILD
index 8e4ff66cc2cb..052f84621326 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ _commit=
pkgver=${_srctag//-/.}
_geckover=2.47.4
_monover=9.0.0
-pkgrel=5
+pkgrel=6
epoch=1
pkgdesc="Compatibility tool for Steam Play based on Wine and additional components, experimental branch"
url="https://github.com/ValveSoftware/Proton"
@@ -99,7 +99,6 @@ source+=(
0007-AUR-Enable-winewayland.patch
0001-fshack-AMD-FSR-complete.patch
4947.patch
- server-Enable-link-time-optimization.patch
)
noextract=(
wine-gecko-${_geckover}-{x86,x86_64}.tar.xz
@@ -177,7 +176,6 @@ prepare() {
pushd wine
patch -p1 -i "$srcdir"/0001-fshack-AMD-FSR-complete.patch
patch -p1 -i "$srcdir"/4947.patch
- patch -p1 -i "$srcdir"/server-Enable-link-time-optimization.patch
popd
}
@@ -195,24 +193,15 @@ build() {
local -A flags
for opt in "${split[@]}"; do flags["${opt%%=*}"]="${opt##*=}"; done
local march="${flags["-march"]:-nocona}"
- local mtune="${flags["-mtune"]:-core-avx2}"
+ local mtune="generic" #"${flags["-mtune"]:-core-avx2}"
- CFLAGS="-O2 -march=$march -mtune=$mtune -pipe -ftree-vectorize -fno-semantic-interposition"
- CXXFLAGS="-O2 -march=$march -mtune=$mtune -pipe -ftree-vectorize -fno-semantic-interposition"
- RUSTFLAGS="-C opt-level=2 -C target-cpu=$march"
+ CFLAGS="-O3 -march=$march -mtune=$mtune -pipe -fno-semantic-interposition"
+ CXXFLAGS="-O3 -march=$march -mtune=$mtune -pipe -fno-semantic-interposition"
+ RUSTFLAGS="-C opt-level=3 -C target-cpu=$march"
LDFLAGS="-Wl,-O1,--sort-common,--as-needed"
- # If using -march=native and the CPU supports AVX, launching a d3d9
- # game can cause an Unhandled exception. The cause seems to be the
- # combination of AVX instructions and tree vectorization (implied by O2),
- # all tested archictures from sandybridge to haswell are affected.
- # Since Wine 5.16 AVX is supported. Testing showed 32bit applications
- # crashing with AVX regardless, but 64bit applications worked just fine.
- # Relevant Wine issues
- # https://bugs.winehq.org/show_bug.cgi?id=45289
- # https://bugs.winehq.org/show_bug.cgi?id=43516
# AVX is "hard" disabled for 32bit in any case.
- # AVX2 for both 32bit and 64bit is disabled below.
+ # AVX/AVX2 for 64bit is disabled below.
#CFLAGS+=" -mno-avx2 -mno-avx"
#CXXFLAGS+=" -mno-avx2 -mno-avx"
@@ -287,5 +276,4 @@ sha256sums=('SKIP'
'89baf181f197a6156507841c018fd81c8f934f77161ba90f5ee6466677428235'
'b7297cabb316eb9621ec1abade892143392eba5fdbd3bd496df7992a7c9d7358'
'3d308f8e87361669267fa52b986c24f1dea1913156a045f43ea04e02f7444b18'
- '0f9ddda17319e3ef23ee847c0a740bf74847796d4b3cf61b05feb9aa3141b7c7'
- 'SKIP')
+ '0f9ddda17319e3ef23ee847c0a740bf74847796d4b3cf61b05feb9aa3141b7c7')
diff --git a/server-Enable-link-time-optimization.patch b/server-Enable-link-time-optimization.patch
deleted file mode 100644
index 3b7367cc1562..000000000000
--- a/server-Enable-link-time-optimization.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-From 20947fbd978f98d430c2d586806487dc41844051 Mon Sep 17 00:00:00 2001
-From: Torge Matthies <openglfreak@googlemail.com>
-Date: Tue, 7 Dec 2021 21:51:07 +0100
-Subject: [PATCH] server: Enable link-time optimization.
-
----
- server/Makefile.in | 3 ++-
- 1 file changed, 2 insertions(+), 1 deletion(-)
-
-diff --git a/server/Makefile.in b/server/Makefile.in
-index 739d0517339..2885cff4d10 100644
---- a/server/Makefile.in
-+++ b/server/Makefile.in
-@@ -49,6 +49,7 @@ MANPAGES = \
- wineserver.fr.UTF-8.man.in \
- wineserver.man.in
-
--UNIX_LIBS = $(LDEXECFLAGS) $(RT_LIBS) $(INOTIFY_LIBS) $(PROCSTAT_LIBS)
-+UNIX_LIBS = $(LDEXECFLAGS) $(RT_LIBS) $(INOTIFY_LIBS) $(PROCSTAT_LIBS) -flto=auto -flto-partition=one -fdevirtualize-at-ltrans $(CFLAGS)
-+EXTRADEFS = -flto=auto -flto-partition=one -fdevirtualize-at-ltrans
-
- unicode_EXTRADEFS = -DNLSDIR="\"${nlsdir}\"" -DBIN_TO_NLSDIR=\"`${MAKEDEP} -R ${bindir} ${nlsdir}`\"
---
-2.34.1