summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStelios Tsampas2023-03-24 19:25:24 +0200
committerStelios Tsampas2023-03-24 19:25:24 +0200
commit940e8a479a36e3d418141225c79740ff16676f3b (patch)
tree6d837b810144387590ed3899898bc9ff26ab9226
parent7b443a14286a2c870af707786a7babb48f4335a7 (diff)
downloadaur-940e8a479a36e3d418141225c79740ff16676f3b.tar.gz
[meta] switch to -O2
-rw-r--r--PKGBUILD.testing4
1 files changed, 2 insertions, 2 deletions
diff --git a/PKGBUILD.testing b/PKGBUILD.testing
index 0a5c7c33c956..6e3cce5c3573 100644
--- a/PKGBUILD.testing
+++ b/PKGBUILD.testing
@@ -280,8 +280,8 @@ build() {
# This overrides FLAGS from makepkg.conf, if you comment these you are on your own
# If you want the "best" possible optimizations for your system you can use
# `-march=native` and remove the `-mtune=core-avx2` option.
- export CFLAGS="-O2 -march=haswell -mtune=haswell -pipe -ftree-vectorize -fno-semantic-interposition"
- export CXXFLAGS="-O2 -march=haswell -mtune=haswell -pipe -ftree-vectorize -fno-semantic-interposition"
+ export CFLAGS="-O2 -march=haswell -mtune=haswell -pipe -fno-semantic-interposition"
+ export CXXFLAGS="-O2 -march=haswell -mtune=haswell -pipe -fno-semantic-interposition"
export RUSTFLAGS="-C opt-level=2 -C target-cpu=haswell"
export LDFLAGS="-Wl,-O1,--sort-common,--as-needed"