summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStelios Tsampas2022-01-07 19:50:53 +0200
committerStelios Tsampas2022-01-07 19:50:53 +0200
commit9fd2226a590dd5621e996631430f07b9cd04543c (patch)
tree0a014c40680a1ab9cc20b6fc420b190aa66d3983
parent8ae15a35f777422ff0d562c0d023c320a87c1464 (diff)
downloadaur-9fd2226a590dd5621e996631430f07b9cd04543c.tar.gz
version: 6.3-20220103
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD13
2 files changed, 11 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8decf7210921..d730fd88f564 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = proton-experimental
pkgdesc = Compatibility tool for Steam Play based on Wine and additional components, experimental branch
- pkgver = 6.3.20211221
+ pkgver = 6.3.20220103
pkgrel = 1
epoch = 1
url = https://github.com/ValveSoftware/Proton
@@ -202,7 +202,7 @@ pkgbase = proton-experimental
options = !staticlibs
options = !lto
options = emptydirs
- source = proton::git+https://github.com/ValveSoftware/Proton.git#tag=experimental-6.3-20211221
+ source = proton::git+https://github.com/ValveSoftware/Proton.git#tag=experimental-6.3-20220103
source = wine-valve::git+https://github.com/ValveSoftware/wine.git
source = dxvk-valve::git+https://github.com/ValveSoftware/dxvk.git
source = openvr::git+https://github.com/ValveSoftware/openvr.git
diff --git a/PKGBUILD b/PKGBUILD
index 940b3d770752..1415c661c7bb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: loathingkernel <loathingkernel _a_ gmail _d_ com>
pkgname=proton-experimental
-_srctag=6.3-20211221
+_srctag=6.3-20220103
_commit=
pkgver=${_srctag//-/.}
_geckover=2.47.2
@@ -138,12 +138,13 @@ noextract=(
)
_make_wrappers () {
- local _i686=(i686 "-m32" "-melf_i386")
- local _x86_64=(x86_64 "" "")
+ # _arch prefix gcc ld as
+ local _i686=( "i686" "-m32" "-melf_i386" "--32")
+ local _x86_64=("x86_64" "-m64" "-melf_x86_64" "--64")
local _opts=(_i686 _x86_64)
declare -n _opt
for _opt in "${_opts[@]}"; do
- for l in ar as ranlib nm; do
+ for l in ar ranlib nm; do
ln -s /usr/bin/$l wrappers/${_opt[0]}-pc-linux-gnu-$l
done
for t in gcc g++; do
@@ -156,6 +157,10 @@ EOF
#!/usr/bin/bash
/usr/bin/ld ${_opt[2]} "\$@"
EOF
+ install -Dm755 /dev/stdin wrappers/${_opt[0]}-pc-linux-gnu-as <<EOF
+#!/usr/bin/bash
+/usr/bin/as ${_opt[3]} "\$@"
+EOF
done
}