summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStelios Tsampas2022-02-06 20:30:08 +0200
committerStelios Tsampas2022-02-06 20:30:08 +0200
commitc3351246e32c009539cd931ce2d1f4cf76fc6d5a (patch)
tree423e0015cbfea309e617287dcfac88293b4b015a
parent9bcdbf8f06b9f2321abdee0a2e30cc9c818dff55 (diff)
downloadaur-c3351246e32c009539cd931ce2d1f4cf76fc6d5a.tar.gz
Fix submodule mess
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD12
2 files changed, 10 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2cb5f9b60f12..8aa7dc44363b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = proton-experimental
pkgdesc = Compatibility tool for Steam Play based on Wine and additional components, experimental branch
pkgver = 6.3.20220119
- pkgrel = 1
+ pkgrel = 2
epoch = 1
url = https://github.com/ValveSoftware/Proton
arch = x86_64
@@ -212,14 +212,14 @@ pkgbase = proton-experimental
source = gst-plugins-base::git+https://gitlab.freedesktop.org/gstreamer/gst-plugins-base.git
source = gst-plugins-good::git+https://gitlab.freedesktop.org/gstreamer/gst-plugins-good.git
source = gst-orc::git+https://gitlab.freedesktop.org/gstreamer/orc.git
- source = vkd3d-valve::git+https://github.com/ValveSoftware/vkd3d.git
+ source = vkd3d-proton::git+https://github.com/HansKristian-Work/vkd3d-proton.git
source = OpenXR-SDK::git+https://github.com/KhronosGroup/OpenXR-SDK.git
source = dxvk-nvapi::git+https://github.com/jp7677/dxvk-nvapi.git
- source = dxil-spirv::git+https://github.com/HansKristian-Work/dxil-spirv.git
+ source = vkd3d::git+https://github.com/ValveSoftware/vkd3d.git
source = SPIRV-Headers::git+https://github.com/KhronosGroup/SPIRV-Headers.git
source = Vulkan-Headers::git+https://github.com/KhronosGroup/Vulkan-Headers.git
source = Vulkan-Loader::git+https://github.com/KhronosGroup/Vulkan-Loader.git
- source = vkd3d-zfigura::git+https://repo.or.cz/vkd3d/zf.git
+ source = dxil-spirv::git+https://github.com/HansKristian-Work/dxil-spirv.git
source = https://dl.winehq.org/wine/wine-gecko/2.47.2/wine-gecko-2.47.2-x86.tar.xz
source = https://dl.winehq.org/wine/wine-gecko/2.47.2/wine-gecko-2.47.2-x86_64.tar.xz
source = https://github.com/madewokherd/wine-mono/releases/download/wine-mono-7.0.0/wine-mono-7.0.0-x86.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
index 72923c1c435c..8e3c231d365c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ pkgver=${_srctag//-/.}
_geckover=2.47.2
_monover=7.0.0
_asyncver=a9de5a9fc12d12a2cd50e3aeffae01e6f51ddbd4
-pkgrel=1
+pkgrel=2
epoch=1
pkgdesc="Compatibility tool for Steam Play based on Wine and additional components, experimental branch"
url="https://github.com/ValveSoftware/Proton"
@@ -115,14 +115,14 @@ source=(
gst-plugins-base::git+https://gitlab.freedesktop.org/gstreamer/gst-plugins-base.git
gst-plugins-good::git+https://gitlab.freedesktop.org/gstreamer/gst-plugins-good.git
gst-orc::git+https://gitlab.freedesktop.org/gstreamer/orc.git
- vkd3d-valve::git+https://github.com/ValveSoftware/vkd3d.git
+ vkd3d-proton::git+https://github.com/HansKristian-Work/vkd3d-proton.git
OpenXR-SDK::git+https://github.com/KhronosGroup/OpenXR-SDK.git
dxvk-nvapi::git+https://github.com/jp7677/dxvk-nvapi.git
- dxil-spirv::git+https://github.com/HansKristian-Work/dxil-spirv.git
+ vkd3d::git+https://github.com/ValveSoftware/vkd3d.git
SPIRV-Headers::git+https://github.com/KhronosGroup/SPIRV-Headers.git
Vulkan-Headers::git+https://github.com/KhronosGroup/Vulkan-Headers.git
Vulkan-Loader::git+https://github.com/KhronosGroup/Vulkan-Loader.git
- vkd3d-zfigura::git+https://repo.or.cz/vkd3d/zf.git
+ dxil-spirv::git+https://github.com/HansKristian-Work/dxil-spirv.git
https://dl.winehq.org/wine/wine-gecko/${_geckover}/wine-gecko-${_geckover}-x86{,_64}.tar.xz
https://github.com/madewokherd/wine-mono/releases/download/wine-mono-${_monover}/wine-mono-${_monover}-x86.tar.xz
dxvk-async-${_asyncver}.patch::https://raw.githubusercontent.com/Sporif/dxvk-async/${_asyncver}/dxvk-async.patch
@@ -198,13 +198,13 @@ prepare() {
gst-plugins-base
gst-plugins-good
gst-orc
- vkd3d-valve::vkd3d-proton
+ vkd3d-proton
OpenXR-SDK
dxvk-nvapi
+ vkd3d
SPIRV-Headers
Vulkan-Headers
Vulkan-Loader
- vkd3d-zfigura::vkd3d
)
for submodule in "${_submodules[@]}"; do