summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStelios Tsampas2024-03-05 12:28:51 +0200
committerStelios Tsampas2024-03-05 12:49:58 +0200
commitf87c0f29f9cd41f37f741dc374cbf3dab70727bf (patch)
tree6dfb660698e66198bf00e7ea00c42fa1eba0949e
parentd51628f662c6f7d791bf61627362da00bc853593 (diff)
downloadaur-f87c0f29f9cd41f37f741dc374cbf3dab70727bf.tar.gz
[proton-experimental] Add tree-vectorize
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD6
2 files changed, 4 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8b8b69fb03ae..20e90f17ebd6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = proton-experimental
pkgdesc = Compatibility tool for Steam Play based on Wine and additional components, experimental branch
pkgver = 9.0.20240301
- pkgrel = 4
+ pkgrel = 5
epoch = 1
url = https://github.com/ValveSoftware/Proton
install = proton-experimental.install
diff --git a/PKGBUILD b/PKGBUILD
index 82e7356b136f..8e4ff66cc2cb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ _commit=
pkgver=${_srctag//-/.}
_geckover=2.47.4
_monover=9.0.0
-pkgrel=4
+pkgrel=5
epoch=1
pkgdesc="Compatibility tool for Steam Play based on Wine and additional components, experimental branch"
url="https://github.com/ValveSoftware/Proton"
@@ -197,8 +197,8 @@ build() {
local march="${flags["-march"]:-nocona}"
local mtune="${flags["-mtune"]:-core-avx2}"
- CFLAGS="-O2 -march=$march -mtune=$mtune -pipe -fno-semantic-interposition"
- CXXFLAGS="-O2 -march=$march -mtune=$mtune -pipe -fno-semantic-interposition"
+ CFLAGS="-O2 -march=$march -mtune=$mtune -pipe -ftree-vectorize -fno-semantic-interposition"
+ CXXFLAGS="-O2 -march=$march -mtune=$mtune -pipe -ftree-vectorize -fno-semantic-interposition"
RUSTFLAGS="-C opt-level=2 -C target-cpu=$march"
LDFLAGS="-Wl,-O1,--sort-common,--as-needed"