summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStelios Tsampas2022-03-19 12:17:37 +0200
committerStelios Tsampas2022-03-19 12:17:37 +0200
commit25e608ba4c0be27771d5646a967e4613624560ed (patch)
treea3a2463e0ab8d812e6da0302fedd0bf404f49712
parentc6141310291aa2cc5c5d038a412b827b4e3d075a (diff)
downloadaur-25e608ba4c0be27771d5646a967e4613624560ed.tar.gz
Version GE-Proton7-10
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
-rw-r--r--proton-sanitize_makefile.patch39
3 files changed, 29 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4db5d857d523..cdcc53a5ca42 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = proton-ge-custom
pkgdesc = Compatibility tool for Steam Play based on Wine and additional components, GloriousEggroll's custom build
- pkgver = GE.Proton7.9
+ pkgver = GE.Proton7.10
pkgrel = 1
epoch = 2
url = https://github.com/GloriousEggroll/proton-ge-custom
@@ -205,7 +205,7 @@ pkgbase = proton-ge-custom
options = !staticlibs
options = !lto
options = emptydirs
- source = proton-ge-custom::git+https://github.com/gloriouseggroll/proton-ge-custom.git#tag=GE-Proton7-9
+ source = proton-ge-custom::git+https://github.com/gloriouseggroll/proton-ge-custom.git#tag=GE-Proton7-10
source = wine-valve::git+https://github.com/ValveSoftware/wine.git
source = dxvk::git+https://github.com/doitsujin/dxvk.git
source = openvr::git+https://github.com/ValveSoftware/openvr.git
@@ -266,7 +266,7 @@ pkgbase = proton-ge-custom
sha256sums = b4476706a4c3f23461da98bed34f355ff623c5d2bb2da1e2fa0c6a310bc33014
sha256sums = cb03854b5d868b2d0912da42e01536bb673e009ed5263f4eeb8836a2a9c36f43
sha256sums = 9005d8169266ba0b93be30e1475fe9a3697464796f553886c155ec1d77d71215
- sha256sums = 6faf03925917c3a16915a5223c48aa23d68cb02e9a7fa0a136bd28b2e3a07a5f
+ sha256sums = a5c269b4f936b497e5663d01e9cb8b6a6c5bc3b068d3c33a05c8ffb61f3957b1
sha256sums = e5cb2054a5d23e956d7cd85c2f716c03852fe78c54ad689f2946ffe68a76c56a
sha256sums = 242566c092f83a71ba06c3aefe0400af65a6fa564dd63196af54403c2c4d09e2
diff --git a/PKGBUILD b/PKGBUILD
index 25bda1d29c3d..faf8bc1568c9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: loathingkernel <loathingkernel _a_ gmail _d_ com>
pkgname=proton-ge-custom
-_srctag=GE-Proton7-9
+_srctag=GE-Proton7-10
_commit=
pkgver=${_srctag//-/.}
_geckover=2.47.2
@@ -247,7 +247,7 @@ prepare() {
for submodule in gst-plugins-rs media-converter; do
pushd $submodule
export RUSTUP_TOOLCHAIN=stable
- export CARGO_HOME="${srcdir}"/build/.cargo
+ export CARGO_HOME="${SRCDEST}"/proton-cargo
cargo update
cargo fetch --locked --target "i686-unknown-linux-gnu"
cargo fetch --locked --target "x86_64-unknown-linux-gnu"
@@ -331,8 +331,10 @@ build() {
export CFLAGS+=" -mno-avx2"
export CXXFLAGS+=" -mno-avx2"
+ # Copy cargo registry to the expected location
+ cp -r "${SRCDEST}"/proton-cargo "${srcdir}"/build/.cargo
+
export RUSTUP_TOOLCHAIN=stable
- export CARGO_HOME="${srcdir}"/build/.cargo
export WINEESYNC=0
export WINEFSYNC=0
export DISPLAY=
@@ -403,6 +405,6 @@ sha256sums=('SKIP'
'b4476706a4c3f23461da98bed34f355ff623c5d2bb2da1e2fa0c6a310bc33014'
'cb03854b5d868b2d0912da42e01536bb673e009ed5263f4eeb8836a2a9c36f43'
'9005d8169266ba0b93be30e1475fe9a3697464796f553886c155ec1d77d71215'
- '6faf03925917c3a16915a5223c48aa23d68cb02e9a7fa0a136bd28b2e3a07a5f'
+ 'a5c269b4f936b497e5663d01e9cb8b6a6c5bc3b068d3c33a05c8ffb61f3957b1'
'e5cb2054a5d23e956d7cd85c2f716c03852fe78c54ad689f2946ffe68a76c56a'
'242566c092f83a71ba06c3aefe0400af65a6fa564dd63196af54403c2c4d09e2')
diff --git a/proton-sanitize_makefile.patch b/proton-sanitize_makefile.patch
index a2af59ddabca..4b45152b86be 100644
--- a/proton-sanitize_makefile.patch
+++ b/proton-sanitize_makefile.patch
@@ -1,5 +1,5 @@
diff --git a/Makefile.in b/Makefile.in
-index c5a776d1..3ec832c8 100644
+index cc9f606b..ee01c2b9 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -63,7 +63,6 @@ ifeq ($(ENABLE_CCACHE),1)
@@ -10,7 +10,7 @@ index c5a776d1..3ec832c8 100644
override DOCKER_OPTS := $(CCACHE_ENV) -e CCACHE_DISABLE=1 $(DOCKER_OPTS)
endif
-@@ -125,7 +124,7 @@ container-build:
+@@ -121,7 +120,7 @@ container-build:
all32 $(MAKECMDGOALS32): container-build
all64 $(MAKECMDGOALS64): container-build
else
@@ -19,7 +19,7 @@ index c5a776d1..3ec832c8 100644
endif
-@@ -175,11 +174,12 @@ else
+@@ -171,11 +170,12 @@ else
endif
CROSSLDFLAGS += -Wl,--file-alignment,4096
@@ -34,7 +34,7 @@ index c5a776d1..3ec832c8 100644
CARGO_BUILD_ARG := --release
##
-@@ -370,8 +370,8 @@ ALL_TARGETS += dist
+@@ -366,8 +366,8 @@ ALL_TARGETS += dist
GOAL_TARGETS += dist
dist_prefix: wine gst_good gst_libav gst_plugins_rs
@@ -45,7 +45,7 @@ index c5a776d1..3ec832c8 100644
rm -rf $(abspath $(DIST_PREFIX))
python3 $(SRCDIR)/default_pfx.py $(abspath $(DIST_PREFIX)) $(abspath $(DST_DIR)) $(STEAM_RUNTIME_RUNSH)
-@@ -441,11 +441,15 @@ $(eval $(call rules-meson,dav1d,64))
+@@ -437,11 +437,15 @@ $(eval $(call rules-meson,dav1d,64))
##
GST_COMMON_MESON_ARGS := \
@@ -61,7 +61,7 @@ index c5a776d1..3ec832c8 100644
-Dglib-asserts=disabled \
-Dglib-checks=disabled \
-Dnls=disabled \
-@@ -469,6 +473,8 @@ GSTREAMER_MESON_ARGS := \
+@@ -465,6 +469,8 @@ GSTREAMER_MESON_ARGS := \
-Dbenchmarks=disabled \
-Dtools=disabled \
-Dbash-completion=disabled \
@@ -70,7 +70,7 @@ index c5a776d1..3ec832c8 100644
$(GST_COMMON_MESON_ARGS)
GSTREAMER_DEPENDS = gst_orc
-@@ -505,6 +511,7 @@ GST_BASE_MESON_ARGS := \
+@@ -501,6 +507,7 @@ GST_BASE_MESON_ARGS := \
-Dx11=disabled \
-Dxshm=disabled \
-Dxvideo=disabled \
@@ -78,7 +78,7 @@ index c5a776d1..3ec832c8 100644
$(GST_COMMON_MESON_ARGS)
GST_BASE_DEPENDS = gst_orc gstreamer
-@@ -568,7 +575,7 @@ GST_GOOD_MESON_ARGS := \
+@@ -564,7 +571,7 @@ GST_GOOD_MESON_ARGS := \
-Dwavenc=disabled \
-Dximagesrc=disabled \
-Dy4m=enabled \
@@ -87,7 +87,7 @@ index c5a776d1..3ec832c8 100644
$(GST_COMMON_MESON_ARGS)
GST_GOOD_DEPENDS = gst_orc gstreamer gst_base
-@@ -663,6 +670,8 @@ GST_BAD_MESON_ARGS := \
+@@ -659,6 +666,8 @@ GST_BAD_MESON_ARGS := \
-Dvoamrwbenc=disabled \
-Dnvcodec=disabled \
-Dx265=disabled \
@@ -96,7 +96,7 @@ index c5a776d1..3ec832c8 100644
$(GST_COMMON_MESON_ARGS)
GST_BAD_DEPENDS = gst_orc gstreamer gst_base
-@@ -677,6 +686,7 @@ $(eval $(call rules-meson,gst_bad,64))
+@@ -673,6 +682,7 @@ $(eval $(call rules-meson,gst_bad,64))
GST_UGLY_MESON_ARGS := \
-Ddoc='disabled' \
@@ -104,7 +104,7 @@ index c5a776d1..3ec832c8 100644
$(GST_COMMON_MESON_ARGS)
GST_UGLY_DEPENDS = gst_orc gstreamer gst_base
-@@ -808,7 +818,13 @@ WINE_SOURCE_ARGS = \
+@@ -804,7 +814,13 @@ WINE_SOURCE_ARGS = \
--exclude include/config.h.in \
WINE_CONFIGURE_ARGS = \
@@ -118,7 +118,7 @@ index c5a776d1..3ec832c8 100644
--disable-tests
WINE_CONFIGURE_ARGS64 = --enable-win64
-@@ -875,6 +891,9 @@ $(OBJ)/.vrclient-post-source:
+@@ -871,6 +887,9 @@ $(OBJ)/.vrclient-post-source:
DXVK_MESON_ARGS32 = --bindir=$(DXVK_DST32)/lib/wine/dxvk
DXVK_MESON_ARGS64 = --bindir=$(DXVK_DST64)/lib64/wine/dxvk
@@ -128,7 +128,7 @@ index c5a776d1..3ec832c8 100644
$(eval $(call rules-source,dxvk,$(SRCDIR)/dxvk))
$(eval $(call rules-meson,dxvk,32,CROSS))
$(eval $(call rules-meson,dxvk,64,CROSS))
-@@ -897,6 +916,9 @@ $(OBJ)/.dxvk-post-build32:
+@@ -893,6 +912,9 @@ $(OBJ)/.dxvk-post-build32:
DXVK_NVAPI_MESON_ARGS32 = --bindir=$(DXVK_NVAPI_DST32)/lib/wine/nvapi
DXVK_NVAPI_MESON_ARGS64 = --bindir=$(DXVK_NVAPI_DST64)/lib64/wine/nvapi
@@ -138,7 +138,7 @@ index c5a776d1..3ec832c8 100644
$(eval $(call rules-source,dxvk-nvapi,$(SRCDIR)/dxvk-nvapi))
$(eval $(call rules-meson,dxvk-nvapi,32,CROSS))
$(eval $(call rules-meson,dxvk-nvapi,64,CROSS))
-@@ -960,10 +982,13 @@ VKD3D_PROTON_SOURCE_ARGS = \
+@@ -956,10 +978,13 @@ VKD3D_PROTON_SOURCE_ARGS = \
--exclude vkd3d_build.h.in \
--exclude vkd3d_version.h.in \
@@ -222,22 +222,23 @@ index c70751a2..1096dc19 100644
endif
endef
diff --git a/make/rules-common.mk b/make/rules-common.mk
-index 78f0f61f..1ab144c1 100644
+index 9f246e69..d8bc33c1 100644
--- a/make/rules-common.mk
+++ b/make/rules-common.mk
-@@ -113,7 +113,11 @@ $(2)_LIBFLAGS$(3) = $$(foreach d,$$($(2)_DEPS$(3)),-L$$($$(d)_LIBDIR$(3))) \
+@@ -113,8 +113,12 @@ $(2)_LIBFLAGS$(3) = $$(foreach d,$$($(2)_DEPS$(3)),-L$$($$(d)_LIBDIR$(3))) \
# native version doesn't exist.
$(2)_ENV$(3) = \
+ WINEDEBUG="-all" \
+ WINEPREFIX="$$(OBJ)/pfx-wine$(3)" \
+ WINEDLLOVERRIDES="winemenubuilder=d;" \
+ CARGO_HOME=$$(OBJ)/.cargo \
CARGO_TARGET_$$(call toupper,$$(CARGO_TARGET_$(3)))_LINKER="$$(TARGET_$(4)$(3))-gcc" \
+ CARGO_TARGET_$$(call toupper,$$(CARGO_TARGET_$(3)))_RUSTFLAGS="$$(RUSTFLAGS)" \
CCACHE_BASEDIR="$$(CCACHE_BASEDIR)" \
STRIP="$$(STRIP)" \
AR="$$(TARGET_$(4)$(3))-ar" \
-@@ -127,7 +131,7 @@ $(2)_ENV$(3) = \
+@@ -128,7 +132,7 @@ $(2)_ENV$(3) = \
PATH="$$(call list-join,:,$$(foreach d,$$($(2)_DEPS$(3)),$$($$(d)_BINDIR$(3))),,:):$$(SRC)/glslang/bin:$$$$PATH" \
LD_LIBRARY_PATH="$$(call list-join,:,$$(foreach d,$$($(2)_DEPS$(3)),$$($$(d)_LIBDIR$(3))),,:)$$$$LD_LIBRARY_PATH" \
PKG_CONFIG_PATH="$$(call list-join,:,$$(foreach d,$$($(2)_DEPS$(3)),$$($$(d)_LIBDIR$(3))/pkgconfig))" \
@@ -246,7 +247,7 @@ index 78f0f61f..1ab144c1 100644
CFLAGS="$$($(2)_INCFLAGS$(3)) $$($(2)_CFLAGS) $$(COMMON_FLAGS) $$(COMMON_FLAGS$(3))" \
CPPFLAGS="$$($(2)_INCFLAGS$(3)) $$($(2)_CPPFLAGS) $$(COMMON_FLAGS) $$(COMMON_FLAGS$(3))" \
CXXFLAGS="$$($(2)_INCFLAGS$(3)) $$($(2)_CXXFLAGS) $$(COMMON_FLAGS) $$(COMMON_FLAGS$(3)) -std=c++17" \
-@@ -151,7 +155,7 @@ $(2)_ENV$(3) += \
+@@ -152,7 +156,7 @@ $(2)_ENV$(3) += \
CROSSCPPFLAGS="$$($(2)_INCFLAGS$(3)) $$($(2)_CPPFLAGS) $$(COMMON_FLAGS) $$(COMMON_FLAGS$(3))" \
CROSSCXXFLAGS="$$($(2)_INCFLAGS$(3)) $$($(2)_CXXFLAGS) $$(COMMON_FLAGS) $$(COMMON_FLAGS$(3)) -std=c++17" \
CROSSLDFLAGS="$$($(2)_LIBFLAGS$(3)) $$($(2)_LDFLAGS$(3)) $$($(2)_LDFLAGS) $$(CROSSLDFLAGS)" \
@@ -255,7 +256,7 @@ index 78f0f61f..1ab144c1 100644
endif
-@@ -164,14 +168,14 @@ else
+@@ -165,14 +169,14 @@ else
install-strip = objcopy --file-alignment=4096 --strip-debug $(1) $(2)/$(notdir $(1)) && rm -f $(2)/$(notdir $(1)).debug
endif