summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStelios Tsampas2023-07-12 12:40:55 +0300
committerStelios Tsampas2023-07-12 12:40:55 +0300
commit30a78acf6fd592c9569322bcdc7b3e1b2882e4c3 (patch)
treece22b9f5ac6503a64b57b800f1c8a1efe20e59c6
parent1e8ecaf748e7b580d41d6bde65cd5dd218ba0a51 (diff)
downloadaur-30a78acf6fd592c9569322bcdc7b3e1b2882e4c3.tar.gz
[proton-ge-custom] Also copy 64bit mingw DLLs
-rw-r--r--.SRCINFO4
-rw-r--r--0004-AUR-Copy-DLL-dependencies-of-32bit-libvkd3d-dlls-int.patch16
-rw-r--r--PKGBUILD9
-rw-r--r--PKGBUILD.testing7
4 files changed, 25 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3978ab417dae..079a5df4ba9c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = proton-ge-custom
pkgdesc = Compatibility tool for Steam Play based on Wine and additional components, GloriousEggroll's custom build
pkgver = GE.Proton8.6
- pkgrel = 6
+ pkgrel = 7
epoch = 2
url = https://github.com/GloriousEggroll/proton-ge-custom
install = proton-ge-custom.install
@@ -234,7 +234,7 @@ pkgbase = proton-ge-custom
sha256sums = ce553d398f64ba06d97396eb83b6b467945c156d5aa43dbe8ace8b0998dc388c
sha256sums = e7d35e025f596b23a550f809ec206c43f795e3aa1422d52642cfffbd7e006163
sha256sums = e9c67b73dc6aec00577ba1c7560d7b2dfb90f97585f83656788e5bd01e20f64c
- sha256sums = 5f4d6735d8517ad63bc2753045d2227c34df212c195e6858e124307b025d7731
+ sha256sums = 71a8337c43da04f50246d779c1cfdcbe88d2a74a7c02fd8953671932b234850c
sha256sums = 20824bb565fefcad4aa978c54e0f8b9d9d17b7b52fb03fc87943150de148f06f
pkgname = proton-ge-custom
diff --git a/0004-AUR-Copy-DLL-dependencies-of-32bit-libvkd3d-dlls-int.patch b/0004-AUR-Copy-DLL-dependencies-of-32bit-libvkd3d-dlls-int.patch
index ee22a0faf226..eeb65106957b 100644
--- a/0004-AUR-Copy-DLL-dependencies-of-32bit-libvkd3d-dlls-int.patch
+++ b/0004-AUR-Copy-DLL-dependencies-of-32bit-libvkd3d-dlls-int.patch
@@ -1,4 +1,4 @@
-From ac21f36388b980259efc017944c606457c8e990e Mon Sep 17 00:00:00 2001
+From 8c9dd5d0c85c862301fa3c3b69cab100cbcd8d95 Mon Sep 17 00:00:00 2001
From: Stelios Tsampas <loathingkernel@gmail.com>
Date: Wed, 12 Jul 2023 03:16:34 +0300
Subject: [PATCH 4/4] AUR Copy DLL dependencies of 32bit libvkd3d dlls into the
@@ -16,20 +16,24 @@ a runtime dependency.
6a4b4 121 __udivdi3
6a4c0 123 __umoddi3
---
- proton | 5 +++++
- 1 file changed, 5 insertions(+)
+ proton | 9 +++++++++
+ 1 file changed, 9 insertions(+)
diff --git a/proton b/proton
-index c581144f..695ea10f 100755
+index c581144f..9b6047c9 100755
--- a/proton
+++ b/proton
-@@ -1083,6 +1083,11 @@ class CompatData:
+@@ -1083,6 +1083,15 @@ class CompatData:
prefix=self.prefix_dir, track_file=tracked_files, link_debug=True)
try_copy(g_proton.lib_dir + "vkd3d/libvkd3d-shader-1.dll", "drive_c/windows/syswow64",
prefix=self.prefix_dir, track_file=tracked_files, link_debug=True)
-+ #copy the DLL dependencies for 32 bit libraries
++ #copy mingw DLL dependencies for libvkd3d
++ try_copy(g_proton.lib64_dir + "vkd3d/libgcc_s_seh-1.dll", "drive_c/windows/system32",
++ prefix=self.prefix_dir, track_file=tracked_files, link_debug=True)
+ try_copy(g_proton.lib_dir + "vkd3d/libgcc_s_dw2-1.dll", "drive_c/windows/syswow64",
+ prefix=self.prefix_dir, track_file=tracked_files, link_debug=True)
++ try_copy(g_proton.lib64_dir + "vkd3d/libwinpthread-1.dll", "drive_c/windows/system32",
++ prefix=self.prefix_dir, track_file=tracked_files, link_debug=True)
+ try_copy(g_proton.lib_dir + "vkd3d/libwinpthread-1.dll", "drive_c/windows/syswow64",
+ prefix=self.prefix_dir, track_file=tracked_files, link_debug=True)
diff --git a/PKGBUILD b/PKGBUILD
index dd236ce35f1b..14905243dbf9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ _commit=610dead69d75fe548b4349dadb3ab04e7e466095
pkgver=${_srctag//-/.}
_geckover=2.47.3
_monover=8.0.0
-pkgrel=6
+pkgrel=7
epoch=2
pkgdesc="Compatibility tool for Steam Play based on Wine and additional components, GloriousEggroll's custom build"
url="https://github.com/GloriousEggroll/proton-ge-custom"
@@ -309,6 +309,9 @@ build() {
package() {
cd build
+ # Delete the intermediate build directories to free space (mostly for my github actions)
+ rm -rf dst-* obj-* src-* pfx-*
+
local _compatdir="$pkgdir/usr/share/steam/compatibilitytools.d"
mkdir -p "$_compatdir/${pkgname}"
rsync --delete -arx dist/* "$_compatdir/${pkgname}"
@@ -320,6 +323,8 @@ package() {
# a runtime dependency.
cp /usr/i686-w64-mingw32/bin/{libgcc_s_dw2-1.dll,libwinpthread-1.dll} \
"$_compatdir/${pkgname}"/files/lib/vkd3d/
+ cp /usr/x86_64-w64-mingw32/bin/{libgcc_s_seh-1.dll,libwinpthread-1.dll} \
+ "$_compatdir/${pkgname}"/files/lib64/vkd3d/
mkdir -p "$pkgdir/usr/share/licenses/${pkgname}"
mv "$_compatdir/${pkgname}"/LICENSE{,.OFL} \
@@ -382,7 +387,7 @@ sha256sums=('SKIP'
'ce553d398f64ba06d97396eb83b6b467945c156d5aa43dbe8ace8b0998dc388c'
'e7d35e025f596b23a550f809ec206c43f795e3aa1422d52642cfffbd7e006163'
'e9c67b73dc6aec00577ba1c7560d7b2dfb90f97585f83656788e5bd01e20f64c'
- '5f4d6735d8517ad63bc2753045d2227c34df212c195e6858e124307b025d7731'
+ '71a8337c43da04f50246d779c1cfdcbe88d2a74a7c02fd8953671932b234850c'
'20824bb565fefcad4aa978c54e0f8b9d9d17b7b52fb03fc87943150de148f06f')
# Optional patches
sha256sums+=(
diff --git a/PKGBUILD.testing b/PKGBUILD.testing
index 33f72d0c6f36..b7556b168ecc 100644
--- a/PKGBUILD.testing
+++ b/PKGBUILD.testing
@@ -6,7 +6,7 @@ _commit=610dead69d75fe548b4349dadb3ab04e7e466095
pkgver=${_srctag//-/.}
_geckover=2.47.3
_monover=8.0.0
-pkgrel=6
+pkgrel=7
epoch=2
pkgdesc="Compatibility tool for Steam Play based on Wine and additional components, GloriousEggroll's custom build"
url="https://github.com/GloriousEggroll/proton-ge-custom"
@@ -309,6 +309,9 @@ build() {
package() {
cd build
+ # Delete the intermediate build directories to free space (mostly for my github actions)
+ rm -rf dst-* obj-* src-* pfx-*
+
local _compatdir="$pkgdir/usr/share/steam/compatibilitytools.d"
mkdir -p "$_compatdir/${pkgname}"
rsync --delete -arx dist/* "$_compatdir/${pkgname}"
@@ -320,6 +323,8 @@ package() {
# a runtime dependency.
cp /usr/i686-w64-mingw32/bin/{libgcc_s_dw2-1.dll,libwinpthread-1.dll} \
"$_compatdir/${pkgname}"/files/lib/vkd3d/
+ cp /usr/x86_64-w64-mingw32/bin/{libgcc_s_seh-1.dll,libwinpthread-1.dll} \
+ "$_compatdir/${pkgname}"/files/lib64/vkd3d/
mkdir -p "$pkgdir/usr/share/licenses/${pkgname}"
mv "$_compatdir/${pkgname}"/LICENSE{,.OFL} \