summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStelios Tsampas2022-05-08 16:28:54 +0300
committerStelios Tsampas2022-05-08 16:28:54 +0300
commit30ed7103b784f7a74700ea473abd2a4a6b6fcbf2 (patch)
tree0958cd8000ccd36951b74f4d2cfda2848acd482d
parent26ef098862587facf26d0eacf7aaabceb8baa64f (diff)
downloadaur-30ed7103b784f7a74700ea473abd2a4a6b6fcbf2.tar.gz
Version GE-Protont7-17
-rw-r--r--.SRCINFO12
-rw-r--r--0001-AUR-pkgbuild-changes.patch (renamed from proton-sanitize_makefile.patch)52
-rw-r--r--0002-RevertMe-Use-one-job-for-autoconf-targets-because-of.patch29
-rw-r--r--PKGBUILD14
-rw-r--r--proton-disable_lock.patch31
5 files changed, 94 insertions, 44 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 14f65b36d694..88c68f2629a9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = proton-ge-custom
pkgdesc = Compatibility tool for Steam Play based on Wine and additional components, GloriousEggroll's custom build
- pkgver = GE.Proton7.16
+ pkgver = GE.Proton7.17
pkgrel = 1
epoch = 2
url = https://github.com/GloriousEggroll/proton-ge-custom
@@ -209,7 +209,7 @@ pkgbase = proton-ge-custom
options = !staticlibs
options = !lto
options = emptydirs
- source = proton-ge-custom::git+https://github.com/gloriouseggroll/proton-ge-custom.git#tag=GE-Proton7-16
+ source = proton-ge-custom::git+https://github.com/gloriouseggroll/proton-ge-custom.git#tag=GE-Proton7-17
source = wine-valve::git+https://github.com/ValveSoftware/wine.git
source = dxvk::git+https://github.com/doitsujin/dxvk.git
source = openvr::git+https://github.com/ValveSoftware/openvr.git
@@ -238,8 +238,8 @@ pkgbase = proton-ge-custom
source = https://dl.winehq.org/wine/wine-gecko/2.47.2/wine-gecko-2.47.2-x86_64.tar.xz
source = https://github.com/madewokherd/wine-mono/releases/download/wine-mono-7.2.0/wine-mono-7.2.0-x86.tar.xz
source = wine-more_8x5_res.patch
- source = proton-sanitize_makefile.patch
- source = proton-disable_lock.patch
+ source = 0001-AUR-pkgbuild-changes.patch
+ source = 0002-RevertMe-Use-one-job-for-autoconf-targets-because-of.patch
source = proton-user_compat_data.patch
sha256sums = SKIP
sha256sums = SKIP
@@ -270,8 +270,8 @@ pkgbase = proton-ge-custom
sha256sums = b4476706a4c3f23461da98bed34f355ff623c5d2bb2da1e2fa0c6a310bc33014
sha256sums = 25a4d08fee9197be83307e65553da450b6d4446cc9188d0a85212cc2cee2660d
sha256sums = 9005d8169266ba0b93be30e1475fe9a3697464796f553886c155ec1d77d71215
- sha256sums = e15b9aee16ac73f63b1844df9332abeeef32806f601905584e25083131517a79
- sha256sums = e5cb2054a5d23e956d7cd85c2f716c03852fe78c54ad689f2946ffe68a76c56a
+ sha256sums = c6504b7b2635d5c0cac4d5f2e7490b38634d30271163baa26eaefaf789e27966
+ sha256sums = f8ff6fd8e467bd927428e7c7c959aa82e73acde9d127368e4a9300519801bdc9
sha256sums = 242566c092f83a71ba06c3aefe0400af65a6fa564dd63196af54403c2c4d09e2
pkgname = proton-ge-custom
diff --git a/proton-sanitize_makefile.patch b/0001-AUR-pkgbuild-changes.patch
index 160564f1052f..202219f8f9ef 100644
--- a/proton-sanitize_makefile.patch
+++ b/0001-AUR-pkgbuild-changes.patch
@@ -1,3 +1,21 @@
+From f8bdd56c8ed9a94a8f07bbc895d975563f711b0d Mon Sep 17 00:00:00 2001
+From: Stelios Tsampas <loathingkernel@gmail.com>
+Date: Mon, 18 Oct 2021 22:21:12 +0300
+Subject: [PATCH 1/2] AUR pkgbuild changes
+
+---
+ Makefile.in | 51 ++++++++++++++++++++++++++++++-----------
+ configure.sh | 2 ++
+ make/rules-autoconf.mk | 4 ++--
+ make/rules-cargo.mk | 4 +++-
+ make/rules-cmake.mk | 4 ++--
+ make/rules-common.mk | 18 +++++++++------
+ make/rules-configure.mk | 4 ++--
+ make/rules-meson.mk | 2 +-
+ make/rules-winemaker.mk | 2 +-
+ proton | 6 ++---
+ 10 files changed, 64 insertions(+), 33 deletions(-)
+
diff --git a/Makefile.in b/Makefile.in
index b5385130..1a7f038e 100644
--- a/Makefile.in
@@ -348,3 +366,37 @@ index 69688a03..1c0d1d3b 100644
cd "$$($(2)_OBJ$(3))" && touch "$(basename $(4)).spec" && env $$($(2)_ENV$(3)) \
winebuild --$(lastword $(subst ., ,$(4))) --fake-module -E "$(basename $(4)).spec" -o "$(4).fake"
mkdir -p $$($(2)_LIBDIR$(3))/$(LIBDIR_WINE_$(3))
+diff --git a/proton b/proton
+index fd9c27eb..371fd931 100755
+--- a/proton
++++ b/proton
+@@ -356,7 +356,6 @@ class Proton:
+ self.wine_bin = self.bin_dir + "wine"
+ self.wine64_bin = self.bin_dir + "wine64"
+ self.wineserver_bin = self.bin_dir + "wineserver"
+- self.dist_lock = FileLock(self.path("dist.lock"), timeout=-1)
+
+ def path(self, d):
+ return self.base_dir + d
+@@ -1591,8 +1590,6 @@ if __name__ == "__main__":
+
+ g_proton = Proton(os.path.dirname(sys.argv[0]))
+
+- g_proton.cleanup_legacy_dist()
+- g_proton.do_steampipe_fixups()
+
+ g_compatdata = CompatData(os.environ["STEAM_COMPAT_DATA_PATH"])
+
+@@ -1601,7 +1598,8 @@ if __name__ == "__main__":
+ g_session.init_wine()
+
+ if g_proton.missing_default_prefix():
+- g_proton.make_default_prefix()
++ log("Default prefix is missing, something is very wrong.")
++ sys.exit(1)
+
+ import protonfixes
+
+--
+2.36.1
+
diff --git a/0002-RevertMe-Use-one-job-for-autoconf-targets-because-of.patch b/0002-RevertMe-Use-one-job-for-autoconf-targets-because-of.patch
new file mode 100644
index 000000000000..428532ab7771
--- /dev/null
+++ b/0002-RevertMe-Use-one-job-for-autoconf-targets-because-of.patch
@@ -0,0 +1,29 @@
+From ef3a423e2d01f511a7af11071324ca90177ac40f Mon Sep 17 00:00:00 2001
+From: Stelios Tsampas <loathingkernel@gmail.com>
+Date: Sun, 8 May 2022 12:58:59 +0300
+Subject: [PATCH 2/2] RevertMe: Use one job for autoconf targets because of an
+ unresolved build failure in Wine
+
+---
+ make/rules-autoconf.mk | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/make/rules-autoconf.mk b/make/rules-autoconf.mk
+index 4e6d19f2..41a17e0e 100644
+--- a/make/rules-autoconf.mk
++++ b/make/rules-autoconf.mk
+@@ -31,9 +31,9 @@ $$(OBJ)/.$(1)-configure$(3): $$(OBJ)/.$(1)-pre-configure
+ $$(OBJ)/.$(1)-build$(3):
+ @echo ":: building $(3)bit $(1)..." >&2
+ cd "$$($(2)_OBJ$(3))" && env $$($(2)_ENV$(3)) \
+- $$(MAKE) -j$$(SUBJOBS)
++ $$(MAKE) -j1
+ cd "$$($(2)_OBJ$(3))" && env $$($(2)_ENV$(3)) \
+- $$(MAKE) -j$$(SUBJOBS) install
++ $$(MAKE) -j1 install
+ touch $$@
+ endif
+ endef
+--
+2.36.1
+
diff --git a/PKGBUILD b/PKGBUILD
index 2da7e68cde70..c4dc7c0e3c98 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: loathingkernel <loathingkernel _a_ gmail _d_ com>
pkgname=proton-ge-custom
-_srctag=GE-Proton7-16
+_srctag=GE-Proton7-17
_commit=
pkgver=${_srctag//-/.}
_geckover=2.47.2
@@ -130,8 +130,8 @@ source=(
https://dl.winehq.org/wine/wine-gecko/${_geckover}/wine-gecko-${_geckover}-x86{,_64}.tar.xz
https://github.com/madewokherd/wine-mono/releases/download/wine-mono-${_monover}/wine-mono-${_monover}-x86.tar.xz
wine-more_8x5_res.patch
- proton-sanitize_makefile.patch
- proton-disable_lock.patch
+ 0001-AUR-pkgbuild-changes.patch
+ 0002-RevertMe-Use-one-job-for-autoconf-targets-because-of.patch
proton-user_compat_data.patch
)
noextract=(
@@ -266,8 +266,8 @@ prepare() {
patch -p1 -i "$srcdir"/wine-more_8x5_res.patch
popd
- patch -p1 -i "$srcdir"/proton-sanitize_makefile.patch
- patch -p1 -i "$srcdir"/proton-disable_lock.patch
+ patch -p1 -i "$srcdir"/0001-AUR-pkgbuild-changes.patch
+ patch -p1 -i "$srcdir"/0002-RevertMe-Use-one-job-for-autoconf-targets-because-of.patch
patch -p1 -i "$srcdir"/proton-user_compat_data.patch
# Remove repos from srcdir to save space
@@ -404,6 +404,6 @@ sha256sums=('SKIP'
'b4476706a4c3f23461da98bed34f355ff623c5d2bb2da1e2fa0c6a310bc33014'
'25a4d08fee9197be83307e65553da450b6d4446cc9188d0a85212cc2cee2660d'
'9005d8169266ba0b93be30e1475fe9a3697464796f553886c155ec1d77d71215'
- 'e15b9aee16ac73f63b1844df9332abeeef32806f601905584e25083131517a79'
- 'e5cb2054a5d23e956d7cd85c2f716c03852fe78c54ad689f2946ffe68a76c56a'
+ 'c6504b7b2635d5c0cac4d5f2e7490b38634d30271163baa26eaefaf789e27966'
+ 'f8ff6fd8e467bd927428e7c7c959aa82e73acde9d127368e4a9300519801bdc9'
'242566c092f83a71ba06c3aefe0400af65a6fa564dd63196af54403c2c4d09e2')
diff --git a/proton-disable_lock.patch b/proton-disable_lock.patch
deleted file mode 100644
index 284e500d6147..000000000000
--- a/proton-disable_lock.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-diff --git a/proton b/proton
-index 0e8e59e7..426ef35d 100755
---- a/proton
-+++ b/proton
-@@ -345,7 +345,6 @@ class Proton:
- self.wine_bin = self.bin_dir + "wine"
- self.wine64_bin = self.bin_dir + "wine64"
- self.wineserver_bin = self.bin_dir + "wineserver"
-- self.dist_lock = FileLock(self.path("dist.lock"), timeout=-1)
-
- def path(self, d):
- return self.base_dir + d
-@@ -1538,8 +1537,6 @@ if __name__ == "__main__":
-
- g_proton = Proton(os.path.dirname(sys.argv[0]))
-
-- g_proton.cleanup_legacy_dist()
-- g_proton.do_steampipe_fixups()
-
- g_compatdata = CompatData(os.environ["STEAM_COMPAT_DATA_PATH"])
-
-@@ -1548,7 +1545,8 @@ if __name__ == "__main__":
- g_session.init_wine()
-
- if g_proton.missing_default_prefix():
-- g_proton.make_default_prefix()
-+ log("Default prefix is missing, something is very wrong.")
-+ sys.exit(1)
-
- import protonfixes
-