summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStelios Tsampas2022-05-19 07:50:03 +0300
committerStelios Tsampas2022-05-19 07:50:03 +0300
commit3bc61868ea76939ecf5e3dcb71756c0865a5dd64 (patch)
tree98ff3ca24113dd917290b208f1a423aad5175b53
parent30ed7103b784f7a74700ea473abd2a4a6b6fcbf2 (diff)
downloadaur-3bc61868ea76939ecf5e3dcb71756c0865a5dd64.tar.gz
Disable inline asm for x86 ffmpeg
-rw-r--r--.SRCINFO4
-rw-r--r--0001-AUR-pkgbuild-changes.patch53
-rw-r--r--0002-RevertMe-Use-one-job-for-autoconf-targets-because-of.patch2
-rw-r--r--PKGBUILD4
4 files changed, 41 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 88c68f2629a9..c93a5f2d96f2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -270,8 +270,8 @@ pkgbase = proton-ge-custom
sha256sums = b4476706a4c3f23461da98bed34f355ff623c5d2bb2da1e2fa0c6a310bc33014
sha256sums = 25a4d08fee9197be83307e65553da450b6d4446cc9188d0a85212cc2cee2660d
sha256sums = 9005d8169266ba0b93be30e1475fe9a3697464796f553886c155ec1d77d71215
- sha256sums = c6504b7b2635d5c0cac4d5f2e7490b38634d30271163baa26eaefaf789e27966
- sha256sums = f8ff6fd8e467bd927428e7c7c959aa82e73acde9d127368e4a9300519801bdc9
+ sha256sums = 011396ea6cb09cbf2b0cc28520a4d2d43b9ac77b1c9d7190ecc7839b3670f74e
+ sha256sums = 45f6f159cd30746cd8c2794e7a052a98332ab99a401fcebf6d338d9d21a49a42
sha256sums = 242566c092f83a71ba06c3aefe0400af65a6fa564dd63196af54403c2c4d09e2
pkgname = proton-ge-custom
diff --git a/0001-AUR-pkgbuild-changes.patch b/0001-AUR-pkgbuild-changes.patch
index 202219f8f9ef..354ccc4e504b 100644
--- a/0001-AUR-pkgbuild-changes.patch
+++ b/0001-AUR-pkgbuild-changes.patch
@@ -1,23 +1,23 @@
-From f8bdd56c8ed9a94a8f07bbc895d975563f711b0d Mon Sep 17 00:00:00 2001
+From cd339694d6d0322e9dee81898b71634da185e59e Mon Sep 17 00:00:00 2001
From: Stelios Tsampas <loathingkernel@gmail.com>
Date: Mon, 18 Oct 2021 22:21:12 +0300
Subject: [PATCH 1/2] AUR pkgbuild changes
---
- Makefile.in | 51 ++++++++++++++++++++++++++++++-----------
+ Makefile.in | 56 +++++++++++++++++++++++++++++++----------
configure.sh | 2 ++
- make/rules-autoconf.mk | 4 ++--
- make/rules-cargo.mk | 4 +++-
- make/rules-cmake.mk | 4 ++--
- make/rules-common.mk | 18 +++++++++------
- make/rules-configure.mk | 4 ++--
+ make/rules-autoconf.mk | 4 +--
+ make/rules-cargo.mk | 4 ++-
+ make/rules-cmake.mk | 4 +--
+ make/rules-common.mk | 18 +++++++------
+ make/rules-configure.mk | 4 +--
make/rules-meson.mk | 2 +-
make/rules-winemaker.mk | 2 +-
proton | 6 ++---
- 10 files changed, 64 insertions(+), 33 deletions(-)
+ 10 files changed, 69 insertions(+), 33 deletions(-)
diff --git a/Makefile.in b/Makefile.in
-index b5385130..1a7f038e 100644
+index b5385130..0addf39b 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -63,7 +63,6 @@ ifeq ($(ENABLE_CCACHE),1)
@@ -105,7 +105,26 @@ index b5385130..1a7f038e 100644
$(GST_COMMON_MESON_ARGS)
GST_GOOD_DEPENDS = gst_orc gstreamer gst_base
-@@ -664,6 +671,8 @@ GST_BAD_MESON_ARGS := \
+@@ -584,6 +591,8 @@ $(eval $(call rules-meson,gst_good,64))
+
+ FFMPEG_CONFIGURE_ARGS := \
+ --enable-shared \
++ --enable-lto \
++ --disable-optimizations \
+ --disable-static \
+ --disable-everything \
+ --disable-programs \
+@@ -599,6 +608,9 @@ FFMPEG_CONFIGURE_ARGS := \
+ --enable-decoder=h264 \
+ --enable-decoder=aac
+
++FFMPEG_CONFIGURE_ARGS64 = --optflags="$(COMMON_FLAGS) $(COMMON_FLAGS64)"
++FFMPEG_CONFIGURE_ARGS32 = --optflags="$(COMMON_FLAGS) $(COMMON_FLAGS32)" --disable-inline-asm
++
+ $(eval $(call rules-source,ffmpeg,$(SRCDIR)/FFmpeg))
+ $(eval $(call rules-configure,ffmpeg,32))
+ $(eval $(call rules-configure,ffmpeg,64))
+@@ -664,6 +676,8 @@ GST_BAD_MESON_ARGS := \
-Dvoamrwbenc=disabled \
-Dnvcodec=disabled \
-Dx265=disabled \
@@ -114,7 +133,7 @@ index b5385130..1a7f038e 100644
$(GST_COMMON_MESON_ARGS)
GST_BAD_DEPENDS = gst_orc gstreamer gst_base
-@@ -678,6 +687,7 @@ $(eval $(call rules-meson,gst_bad,64))
+@@ -678,6 +692,7 @@ $(eval $(call rules-meson,gst_bad,64))
GST_UGLY_MESON_ARGS := \
-Ddoc='disabled' \
@@ -122,7 +141,7 @@ index b5385130..1a7f038e 100644
$(GST_COMMON_MESON_ARGS)
GST_UGLY_DEPENDS = gst_orc gstreamer gst_base
-@@ -809,7 +819,13 @@ WINE_SOURCE_ARGS = \
+@@ -809,7 +824,13 @@ WINE_SOURCE_ARGS = \
--exclude include/config.h.in \
WINE_CONFIGURE_ARGS = \
@@ -136,7 +155,7 @@ index b5385130..1a7f038e 100644
--disable-tests
WINE_CONFIGURE_ARGS64 = --enable-win64
-@@ -872,6 +888,9 @@ $(OBJ)/.vrclient-post-source:
+@@ -872,6 +893,9 @@ $(OBJ)/.vrclient-post-source:
DXVK_MESON_ARGS32 = --bindir=$(DXVK_DST32)/lib/wine/dxvk
DXVK_MESON_ARGS64 = --bindir=$(DXVK_DST64)/lib64/wine/dxvk
@@ -146,7 +165,7 @@ index b5385130..1a7f038e 100644
$(eval $(call rules-source,dxvk,$(SRCDIR)/dxvk))
$(eval $(call rules-meson,dxvk,32,CROSS))
$(eval $(call rules-meson,dxvk,64,CROSS))
-@@ -894,6 +913,9 @@ $(OBJ)/.dxvk-post-build32:
+@@ -894,6 +918,9 @@ $(OBJ)/.dxvk-post-build32:
DXVK_NVAPI_MESON_ARGS32 = --bindir=$(DXVK_NVAPI_DST32)/lib/wine/nvapi
DXVK_NVAPI_MESON_ARGS64 = --bindir=$(DXVK_NVAPI_DST64)/lib64/wine/nvapi
@@ -156,7 +175,7 @@ index b5385130..1a7f038e 100644
$(eval $(call rules-source,dxvk-nvapi,$(SRCDIR)/dxvk-nvapi))
$(eval $(call rules-meson,dxvk-nvapi,32,CROSS))
$(eval $(call rules-meson,dxvk-nvapi,64,CROSS))
-@@ -957,10 +979,13 @@ VKD3D_PROTON_SOURCE_ARGS = \
+@@ -957,10 +984,13 @@ VKD3D_PROTON_SOURCE_ARGS = \
--exclude vkd3d_build.h.in \
--exclude vkd3d_version.h.in \
@@ -171,7 +190,7 @@ index b5385130..1a7f038e 100644
$(eval $(call rules-source,vkd3d-proton,$(SRCDIR)/vkd3d-proton))
$(eval $(call rules-meson,vkd3d-proton,32,CROSS))
$(eval $(call rules-meson,vkd3d-proton,64,CROSS))
-@@ -1198,14 +1223,14 @@ $(FONTS_OBJ)/source-han/%.ttf: $$(%.ttf_CIDFONT) $$(%.ttf_FEATURES) $$(%.ttf_SEQ
+@@ -1198,14 +1228,14 @@ $(FONTS_OBJ)/source-han/%.ttf: $$(%.ttf_CIDFONT) $$(%.ttf_FEATURES) $$(%.ttf_SEQ
mkdir -p $(FONTS_OBJ)/source-han
# Do not immediately create the target file, so that make is interrupted
# it will restart again
@@ -189,7 +208,7 @@ index b5385130..1a7f038e 100644
mv $@.tmp $@
$(FONTS_OBJ)/ume-gothic/%.ttf: $$(%.ttf_FONT) $$(%.ttf_NAMETABLE_PATCH)
-@@ -1215,10 +1240,10 @@ $(FONTS_OBJ)/ume-gothic/%.ttf: $$(%.ttf_FONT) $$(%.ttf_NAMETABLE_PATCH)
+@@ -1215,10 +1245,10 @@ $(FONTS_OBJ)/ume-gothic/%.ttf: $$(%.ttf_FONT) $$(%.ttf_NAMETABLE_PATCH)
ttx -o $@ -m $($(notdir $@)_FONT) $(FONTS_OBJ)/ume-gothic/$(notdir $(basename $($(notdir $@)_NAMETABLE_PATCH))).ttx
$(simsun.ttc): $(simsun.ttf) $(nsimsun.ttf)
diff --git a/0002-RevertMe-Use-one-job-for-autoconf-targets-because-of.patch b/0002-RevertMe-Use-one-job-for-autoconf-targets-because-of.patch
index 428532ab7771..8c968de95d54 100644
--- a/0002-RevertMe-Use-one-job-for-autoconf-targets-because-of.patch
+++ b/0002-RevertMe-Use-one-job-for-autoconf-targets-because-of.patch
@@ -1,4 +1,4 @@
-From ef3a423e2d01f511a7af11071324ca90177ac40f Mon Sep 17 00:00:00 2001
+From dcf8aacaca06c5d4305e81e4d7e12b37eff6e88a Mon Sep 17 00:00:00 2001
From: Stelios Tsampas <loathingkernel@gmail.com>
Date: Sun, 8 May 2022 12:58:59 +0300
Subject: [PATCH 2/2] RevertMe: Use one job for autoconf targets because of an
diff --git a/PKGBUILD b/PKGBUILD
index c4dc7c0e3c98..db2480d80204 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -404,6 +404,6 @@ sha256sums=('SKIP'
'b4476706a4c3f23461da98bed34f355ff623c5d2bb2da1e2fa0c6a310bc33014'
'25a4d08fee9197be83307e65553da450b6d4446cc9188d0a85212cc2cee2660d'
'9005d8169266ba0b93be30e1475fe9a3697464796f553886c155ec1d77d71215'
- 'c6504b7b2635d5c0cac4d5f2e7490b38634d30271163baa26eaefaf789e27966'
- 'f8ff6fd8e467bd927428e7c7c959aa82e73acde9d127368e4a9300519801bdc9'
+ '011396ea6cb09cbf2b0cc28520a4d2d43b9ac77b1c9d7190ecc7839b3670f74e'
+ '45f6f159cd30746cd8c2794e7a052a98332ab99a401fcebf6d338d9d21a49a42'
'242566c092f83a71ba06c3aefe0400af65a6fa564dd63196af54403c2c4d09e2')