summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStelios Tsampas2024-01-26 18:33:09 +0200
committerStelios Tsampas2024-01-26 18:33:09 +0200
commitf1e9f313adc3e43a2c20fbb82f4c33d15768a242 (patch)
tree0137ef8138fca3d08245ce095fd6ca442ee77923
parentd4812e43992170347ecbdcf0b0749f72812a8a6e (diff)
downloadaur-f1e9f313adc3e43a2c20fbb82f4c33d15768a242.tar.gz
[proton-ge-custom] Update and re-enable march and mtune, disable AVX for x64 too
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD12
2 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dad77820f6eb..85c77be60aba 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = proton-ge-custom
pkgdesc = Compatibility tool for Steam Play based on Wine and additional components, GloriousEggroll's custom build
pkgver = GE.Proton8.27
- pkgrel = 3
+ pkgrel = 4
epoch = 2
url = https://github.com/GloriousEggroll/proton-ge-custom
install = proton-ge-custom.install
diff --git a/PKGBUILD b/PKGBUILD
index 17d60b1ef1f7..e9b89e0a9bac 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ _commit=989b502c4aed6efd8b210b785c163e9c6c6e233e
pkgver=${_srctag//-/.}
_geckover=2.47.3
_monover=8.1.0
-pkgrel=3
+pkgrel=4
epoch=2
pkgdesc="Compatibility tool for Steam Play based on Wine and additional components, GloriousEggroll's custom build"
url="https://github.com/GloriousEggroll/proton-ge-custom"
@@ -180,9 +180,9 @@ build() {
--proton-sdk-image="" \
--build-name="${pkgname}"
-# local -a split=($CFLAGS)
-# local -A flags
-# for opt in "${split[@]}"; do flags["${opt%%=*}"]="${opt##*=}"; done
+ local -a split=($CFLAGS)
+ local -A flags
+ for opt in "${split[@]}"; do flags["${opt%%=*}"]="${opt##*=}"; done
local march="${flags["-march"]:-nocona}"
local mtune="${flags["-mtune"]:-core-avx2}"
@@ -202,8 +202,8 @@ build() {
# https://bugs.winehq.org/show_bug.cgi?id=43516
# AVX is "hard" disabled for 32bit in any case.
# AVX2 for both 32bit and 64bit is disabled below.
- CFLAGS+=" -mno-avx2"
- CXXFLAGS+=" -mno-avx2"
+ CFLAGS+=" -mno-avx2 -mno-avx"
+ CXXFLAGS+=" -mno-avx2 -mno-avx"
export CFLAGS CXXFLAGS RUSTFLAGS LDFLAGS