summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStelios Tsampas2021-06-03 19:13:33 +0300
committerStelios Tsampas2021-06-03 19:13:33 +0300
commitf304e64fbdfa77c7c0dfa414929b3b9ee3a7a341 (patch)
treee8b9717edcac9085d81a5a9a160693058669b780
parent4bada51ad2a2a222c87555b915b9f94fb652ef03 (diff)
downloadaur-f304e64fbdfa.tar.gz
Fix compilation error due to missing <optional> include
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD21
-rw-r--r--dxvk-1582_missing_optional.patch19
-rw-r--r--proton-unfuck_makefile.patch34
4 files changed, 51 insertions, 34 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3e8d6ef04109..fab2e4785a89 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,12 @@
pkgbase = proton-ge-custom
pkgdesc = Compatibility tool for Steam Play based on Wine and additional components. GloriousEggroll's custom build
pkgver = 6.9.GE.2
- pkgrel = 3
+ pkgrel = 4
epoch = 1
url = https://github.com/GloriousEggroll/proton-ge-custom
arch = x86_64
license = custom
makedepends = autoconf
- makedepends = ncurses
makedepends = bison
makedepends = perl
makedepends = fontforge
@@ -172,8 +171,6 @@ pkgbase = proton-ge-custom
optdepends = lib32-libxcomposite
optdepends = libxinerama
optdepends = lib32-libxinerama
- optdepends = ncurses
- optdepends = lib32-ncurses
optdepends = opencl-icd-loader
optdepends = lib32-opencl-icd-loader
optdepends = libxslt
@@ -199,7 +196,8 @@ pkgbase = proton-ge-custom
noextract = wine-gecko-2.47.2-x86_64.tar.xz
noextract = wine-mono-6.1.2-x86.tar.xz
options = staticlibs
- source = proton-ge-custom::git+https://github.com/gloriouseggroll/proton-ge-custom.git#commit=f12fed6d53f5d9b85e8f233a8c0b7e295978b9a0
+ options = !lto
+ source = proton-ge-custom::git+https://github.com/gloriouseggroll/proton-ge-custom.git#commit=86f8171b04219db5f43598c4bc4c508ade6d344b
source = wine::git://source.winehq.org/git/wine.git
source = wine-staging::git+https://github.com/wine-staging/wine-staging.git
source = vkd3d-proton::git+https://github.com/HansKristian-Work/vkd3d-proton.git
@@ -229,6 +227,7 @@ pkgbase = proton-ge-custom
source = proton-disable_lock.patch
source = proton-user_compat_data.patch
source = patches-remove_broken.patch
+ source = dxvk-1582_missing_optional.patch
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
@@ -259,6 +258,6 @@ pkgbase = proton-ge-custom
sha256sums = 61dbdb4d14e22c2c34b136e5ddb800eac54023b5b23c19acd13a82862f94738c
sha256sums = 20f7cd3e70fad6f48d2f1a26a485906a36acf30903bf0eefbf82a7c400e248f3
sha256sums = 429de61522db02c4c87d31221a59b504eac1fb8b7b5c1a3f61aed3f21350eeb5
+ sha256sums = e7e7ebb09115998b49838a8cfac37a3ff820e1eb97c9ecea7a930892fe382890
pkgname = proton-ge-custom
-
diff --git a/PKGBUILD b/PKGBUILD
index eb1b8e83c3ce..59a8ce1acafc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,16 +2,16 @@
pkgname=proton-ge-custom
_srctag=6.9-GE-2
-_commit=f12fed6d53f5d9b85e8f233a8c0b7e295978b9a0
+_commit=86f8171b04219db5f43598c4bc4c508ade6d344b
pkgver=${_srctag//-/.}
_geckover=2.47.2
_monover=6.1.2
-pkgrel=3
+pkgrel=4
epoch=1
pkgdesc="Compatibility tool for Steam Play based on Wine and additional components. GloriousEggroll's custom build"
url="https://github.com/GloriousEggroll/proton-ge-custom"
arch=(x86_64)
-options=(staticlibs)
+options=(staticlibs !lto)
license=('custom')
depends=(
@@ -36,7 +36,7 @@ depends=(
cabextract
)
-makedepends=(autoconf ncurses bison perl fontforge flex mingw-w64-gcc
+makedepends=(autoconf bison perl fontforge flex mingw-w64-gcc
git rsync mingw-w64-tools lld nasm meson cmake python-virtualenv python-pip
glslang vulkan-headers
giflib lib32-giflib
@@ -85,7 +85,6 @@ optdepends=(
libjpeg-turbo lib32-libjpeg-turbo
libxcomposite lib32-libxcomposite
libxinerama lib32-libxinerama
- ncurses lib32-ncurses
opencl-icd-loader lib32-opencl-icd-loader
libxslt lib32-libxslt
libva lib32-libva
@@ -133,6 +132,7 @@ source=(
proton-disable_lock.patch
proton-user_compat_data.patch
patches-remove_broken.patch
+ dxvk-1582_missing_optional.patch
)
noextract=(
wine-gecko-${_geckover}-{x86,x86_64}.tar.xz
@@ -165,16 +165,12 @@ prepare() {
git config submodule.ffmpeg.url "$srcdir"/ffmpeg-meson
git submodule update ffmpeg
- for submodule in wine wine-staging; do
+ for submodule in wine wine-staging dxvk; do
git submodule init "${submodule}"
git config submodule."${submodule}".url "$srcdir"/"${submodule#*/}"
git submodule update "${submodule}"
done
- git submodule init dxvk
- git config submodule.dxvk.url "$srcdir"/dxvk
- git submodule update --remote dxvk
-
for submodule in gstreamer gst-{plugins-{base,good,bad,ugly},libav,orc}; do
git submodule init "${submodule}"
git config submodule."${submodule}".url "$srcdir"/"${submodule#*/}"
@@ -201,8 +197,8 @@ prepare() {
done
patch -p1 -i "$srcdir"/patches-remove_broken.patch
-
./patches/protonprep.sh
+ patch -p1 -i "$srcdir"/dxvk-1582_missing_optional.patch
patch -p1 -i "$srcdir"/proton-unfuck_makefile.patch
patch -p1 -i "$srcdir"/proton-disable_lock.patch
@@ -322,8 +318,9 @@ sha256sums=('SKIP'
'8fab46ea2110b2b0beed414e3ebb4e038a3da04900e7a28492ca3c3ccf9fea94'
'b4476706a4c3f23461da98bed34f355ff623c5d2bb2da1e2fa0c6a310bc33014'
'463efcae9aec82e2ae51adbafe542f2a0674e1a1d0899d732077211f5c62d182'
- '6fc5bd437b2161777f90416fa92760e73bff39c6cf507b612bc020d87909f812'
+ '4b8d2c2836606725f9daaf4b4b127a9dc074abf3ba0cb18ba05534b731d263b6'
'61dbdb4d14e22c2c34b136e5ddb800eac54023b5b23c19acd13a82862f94738c'
'20f7cd3e70fad6f48d2f1a26a485906a36acf30903bf0eefbf82a7c400e248f3'
'429de61522db02c4c87d31221a59b504eac1fb8b7b5c1a3f61aed3f21350eeb5'
+ 'e7e7ebb09115998b49838a8cfac37a3ff820e1eb97c9ecea7a930892fe382890'
)
diff --git a/dxvk-1582_missing_optional.patch b/dxvk-1582_missing_optional.patch
new file mode 100644
index 000000000000..2660fcbcaaf1
--- /dev/null
+++ b/dxvk-1582_missing_optional.patch
@@ -0,0 +1,19 @@
+diff --git a/src/spirv/spirv_module.h b/src/spirv/spirv_module.h
+index a1bd5871..67953679 100644
+--- a/dxvk/src/spirv/spirv_module.h
++++ b/dxvk/src/spirv/spirv_module.h
+@@ -1,6 +1,7 @@
+ #pragma once
+
+ #include <unordered_set>
++#include <optional>
+
+ #include "spirv_code_buffer.h"
+ #include "spirv_compression.h"
+@@ -1348,4 +1349,4 @@ namespace dxvk {
+
+ };
+
+-}
+\ No newline at end of file
++}
diff --git a/proton-unfuck_makefile.patch b/proton-unfuck_makefile.patch
index 243e3273a301..c82f6020a916 100644
--- a/proton-unfuck_makefile.patch
+++ b/proton-unfuck_makefile.patch
@@ -1,5 +1,5 @@
diff --git a/build/makefile_base.mak b/build/makefile_base.mak
-index 30fed04..343b16a 100755
+index e0f564d..6787812 100755
--- a/build/makefile_base.mak
+++ b/build/makefile_base.mak
@@ -48,7 +48,6 @@ include $(SRC)/make/rules-cargo.mk
@@ -31,16 +31,17 @@ index 30fed04..343b16a 100755
rm -rf $(abspath $(DIST_PREFIX))
python3 $(SRCDIR)/default_pfx.py $(abspath $(DIST_PREFIX)) $(abspath $(DST_DIR)) $(STEAM_RUNTIME_RUNSH)
-@@ -371,6 +371,8 @@ endif # ifeq ($(CONTAINER),)
+@@ -371,6 +371,9 @@ endif # ifeq ($(CONTAINER),)
##
GST_COMMON_MESON_ARGS := \
+ -Db_lto=true \
+ -Db_pie=true \
++ -Ddoc=disabled \
-Dexamples=disabled \
-Dtests=disabled \
-Dgtk_doc=disabled \
-@@ -383,6 +385,7 @@ GST_COMMON_MESON_ARGS := \
+@@ -383,6 +386,7 @@ GST_COMMON_MESON_ARGS := \
GST_ORC_MESON_ARGS := \
-Dorc-test=disabled \
@@ -48,7 +49,7 @@ index 30fed04..343b16a 100755
$(GST_COMMON_MESON_ARGS)
$(eval $(call rules-source,gst_orc,$(SRCDIR)/gst-orc))
-@@ -399,6 +402,9 @@ GSTREAMER_MESON_ARGS := \
+@@ -399,6 +403,9 @@ GSTREAMER_MESON_ARGS := \
-Dbenchmarks=disabled \
-Dtools=disabled \
-Dbash-completion=disabled \
@@ -58,7 +59,7 @@ index 30fed04..343b16a 100755
$(GST_COMMON_MESON_ARGS)
GSTREAMER_DEPENDS = gst_orc
-@@ -436,6 +442,8 @@ GST_BASE_MESON_ARGS := \
+@@ -435,6 +442,8 @@ GST_BASE_MESON_ARGS := \
-Dx11=disabled \
-Dxshm=disabled \
-Dxvideo=disabled \
@@ -67,16 +68,17 @@ index 30fed04..343b16a 100755
$(GST_COMMON_MESON_ARGS)
GST_BASE_DEPENDS = gst_orc gstreamer
-@@ -499,6 +507,8 @@ GST_GOOD_MESON_ARGS := \
+@@ -498,7 +507,8 @@ GST_GOOD_MESON_ARGS := \
-Dwavenc=disabled \
-Dximagesrc=disabled \
- -Dy4m=disabled \
+ -Dy4m=enabled \
+- -Ddoc='disabled' \
+ -Dtools=disabled \
+ -Dpackage-name="GStreamer Good Plugins (Proton)" \
$(GST_COMMON_MESON_ARGS)
GST_GOOD_DEPENDS = gst_orc gstreamer gst_base
-@@ -531,6 +541,9 @@ GST_BAD_MESON_ARGS := \
+@@ -533,6 +543,9 @@ GST_BAD_MESON_ARGS := \
-Dopencv=disabled \
-Dvoamrwbenc=disabled \
-Dx265=disabled \
@@ -86,16 +88,16 @@ index 30fed04..343b16a 100755
$(GST_COMMON_MESON_ARGS)
GST_BAD_DEPENDS = gst_orc gstreamer gst_base
-@@ -550,6 +563,8 @@ GST_UGLY_MESON_ARGS := \
- -Dglib-checks='disabled' \
- -Dglib-checks='disabled' \
+@@ -548,6 +561,8 @@ $(eval $(call rules-meson,gst_bad,64))
+
+ GST_UGLY_MESON_ARGS := \
-Ddoc='disabled' \
+ -Dtools='disabled' \
+ -Dpackage-name="GStreamer Ugly Plugins (Proton)" \
$(GST_COMMON_MESON_ARGS)
GST_UGLY_DEPENDS = gst_orc gstreamer gst_base
-@@ -565,6 +580,8 @@ $(eval $(call rules-meson,gst_ugly,64))
+@@ -563,6 +578,8 @@ $(eval $(call rules-meson,gst_ugly,64))
GST_LIBAV_MESON_ARGS := \
-Ddoc=disabled \
@@ -104,7 +106,7 @@ index 30fed04..343b16a 100755
$(GST_COMMON_MESON_ARGS)
GST_LIBAV_DEPENDS = gst_orc gstreamer gst_base
-@@ -688,7 +705,13 @@ WINE_SOURCE_ARGS = \
+@@ -686,7 +703,13 @@ WINE_SOURCE_ARGS = \
--exclude include/config.h.in \
WINE_CONFIGURE_ARGS = \
@@ -118,7 +120,7 @@ index 30fed04..343b16a 100755
--disable-tests
WINE_CONFIGURE_ARGS64 = --enable-win64
-@@ -782,7 +805,7 @@ VKD3D_PROTON_SOURCE_ARGS = \
+@@ -780,7 +803,7 @@ VKD3D_PROTON_SOURCE_ARGS = \
--exclude vkd3d_build.h.in \
--exclude vkd3d_version.h.in \
@@ -241,7 +243,7 @@ index 11d91ba..fb86161 100644
endif
endef
diff --git a/make/rules-winemaker.mk b/make/rules-winemaker.mk
-index 8a0f0ce..36a107c 100644
+index 052e1c5..3d831bc 100644
--- a/make/rules-winemaker.mk
+++ b/make/rules-winemaker.mk
@@ -29,7 +29,7 @@ $(OBJ)/.$(1)-build$(3):
@@ -252,4 +254,4 @@ index 8a0f0ce..36a107c 100644
+ $$(MAKE) -j$$(SUBJOBS) -C "$$($(2)_OBJ$(3))" LIBRARIES="$$($(2)_LDFLAGS)"
cd "$$($(2)_OBJ$(3))" && touch "$(basename $(4)).spec" && env $$($(2)_ENV$(3)) \
winebuild --dll --fake-module -E "$(basename $(4)).spec" -o "$(4).fake"
- mkdir -p $$($(2)_DST$(3))/lib$(subst 32,,$(3))/wine/fakedlls/
+ ifeq ($(3),32)