summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStelios Tsampas2022-10-26 16:35:55 +0300
committerStelios Tsampas2022-10-26 16:35:55 +0300
commitfe80d2eb55d7b50ca22b27c1ec161118abfa95fb (patch)
treee99db2fcb3ce40a2891a43eceb832bec9b34a38b
parent0349fa1b0cb025b7737da606426995e854276984 (diff)
downloadaur-fe80d2eb55d7b50ca22b27c1ec161118abfa95fb.tar.gz
Version GE-Proton7-38
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD12
2 files changed, 8 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index df8fb9f921e2..29868d6d92b9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = proton-ge-custom
pkgdesc = Compatibility tool for Steam Play based on Wine and additional components, GloriousEggroll's custom build
- pkgver = GE.Proton7.37
+ pkgver = GE.Proton7.38
pkgrel = 1
epoch = 2
url = https://github.com/GloriousEggroll/proton-ge-custom
@@ -76,8 +76,6 @@ pkgbase = proton-ge-custom
makedepends = rust
makedepends = lib32-rust-libs
makedepends = libgphoto2
- makedepends = gsm
- makedepends = lib32-gsm
makedepends = opencl-headers
makedepends = attr
makedepends = lib32-attr
@@ -483,7 +481,7 @@ pkgbase = proton-ge-custom
options = !staticlibs
options = !lto
options = emptydirs
- source = proton-ge-custom::git+https://github.com/gloriouseggroll/proton-ge-custom.git#tag=GE-Proton7-37
+ source = proton-ge-custom::git+https://github.com/gloriouseggroll/proton-ge-custom.git#tag=GE-Proton7-38
source = wine-valve::git+https://github.com/ValveSoftware/wine.git
source = dxvk::git+https://github.com/doitsujin/dxvk.git
source = openvr::git+https://github.com/ValveSoftware/openvr.git
diff --git a/PKGBUILD b/PKGBUILD
index 8d40131a93b5..fdfaf2aa159c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: loathingkernel <loathingkernel _a_ gmail _d_ com>
pkgname=proton-ge-custom
-_srctag=GE-Proton7-37
+_srctag=GE-Proton7-38
_commit=
pkgver=${_srctag//-/.}
_geckover=2.47.3
@@ -230,33 +230,33 @@ prepare() {
for submodule in "${_submodules[@]}"; do
git submodule init "${submodule#*::}"
git submodule set-url "${submodule#*::}" "$srcdir"/"${submodule%::*}"
- git submodule--helper update "${submodule#*::}"
+ git -c protocol.file.allow=always submodule update "${submodule#*::}"
done
pushd dxvk
git submodule init include/{vulkan,spirv}
git submodule set-url include/vulkan "$srcdir/Vulkan-Headers"
git submodule set-url include/spirv "$srcdir/SPIRV-Headers"
- git submodule--helper update include/{vulkan,spirv}
+ git -c protocol.file.allow=always submodule update include/{vulkan,spirv}
popd
pushd vkd3d-proton
for submodule in subprojects/{dxil-spirv,Vulkan-Headers,SPIRV-Headers}; do
git submodule init "${submodule}"
git submodule set-url "${submodule}" "$srcdir"/"${submodule#*/}"
- git submodule--helper update "${submodule}"
+ git -c protocol.file.allow=always submodule update "${submodule}"
done
pushd subprojects/dxil-spirv
git submodule init third_party/spirv-headers
git submodule set-url third_party/spirv-headers "$srcdir"/SPIRV-Headers
- git submodule--helper update third_party/spirv-headers
+ git -c protocol.file.allow=always submodule update third_party/spirv-headers
popd
popd
pushd dxvk-nvapi
git submodule init external/Vulkan-Headers
git submodule set-url external/Vulkan-Headers "$srcdir"/Vulkan-Headers
- git submodule--helper update external/Vulkan-Headers
+ git -c protocol.file.allow=always submodule update external/Vulkan-Headers
# GCC 12 build failure
git cherry-pick -n 33bf3c7a6a3dc9e330cd338bf1877b5481c655e3
popd