summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJaja2022-02-27 02:13:01 +0100
committerJaja2022-02-27 02:13:01 +0100
commit1da6aa985d0fdb814faee1d1803518a5d68287ca (patch)
tree05cff002fc399c30e3024d9fd35928a92d3256c3
parentb39cf4b6bf9e4a68502556d95234b1451fd3b181 (diff)
downloadaur-1da6aa985d0fdb814faee1d1803518a5d68287ca.tar.gz
update deps as told by namcap
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD23
2 files changed, 38 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 51a8022c359d..97552680d5d2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -11,8 +11,24 @@ pkgbase = proton-ge-custom-bin
license = MIT
license = MPL
license = custom
+ makedepends = patch
depends = python
depends = vulkan-icd-loader
+ depends = lib32-v4l-utils
+ depends = lib32-flac
+ depends = lib32-speex
+ depends = lib32-gst-plugins-base-libs
+ depends = lib32-jack2
+ depends = lib32-libgudev
+ depends = lib32-mpg123
+ depends = lib32-libtheora
+ depends = ffmpeg4.4
+ depends = lib32-sdl2
+ depends = lib32-openal
+ depends = lib32-libva
+ depends = lib32-libjpeg6-turbo
+ depends = libjpeg6-turbo
+ depends = gst-plugins-bad-libs
optdepends = kdialog: KDE splash dialog support
optdepends = zenity: GNOME splash dialog support
optdepends = python-kivy: splash dialog support (big picture mode)
@@ -22,6 +38,7 @@ pkgbase = proton-ge-custom-bin
optdepends = winetricks: protonfixes backend - highly recommended
optdepends = wine: support for 32bit prefixes
optdepends = xboxdrv: gamepad driver service
+ optdepends = lib32-libusb: wine usb support
provides = proton
provides = proton-ge-custom=7.3.GE_1
conflicts = proton-ge-custom-legacy-bin
diff --git a/PKGBUILD b/PKGBUILD
index e87320260acf..9e70013271fd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,8 +12,26 @@ license=('BSD' 'LGPL' 'zlib' 'MIT' 'MPL' 'custom')
changelog=changelog
provides=('proton' "proton-ge-custom=${pkgver/_/.}")
conflicts=('proton-ge-custom-legacy-bin' 'proton-ge-custom')
+
+## dependencies
+makedepends=('patch')
depends=('python'
- 'vulkan-icd-loader')
+ 'vulkan-icd-loader'
+ 'lib32-v4l-utils'
+ 'lib32-flac'
+ 'lib32-speex'
+ 'lib32-gst-plugins-base-libs'
+ 'lib32-jack2'
+ 'lib32-libgudev'
+ 'lib32-mpg123'
+ 'lib32-libtheora'
+ 'ffmpeg4.4'
+ 'lib32-sdl2'
+ 'lib32-openal'
+ 'lib32-libva'
+ 'lib32-libjpeg6-turbo'
+ 'libjpeg6-turbo'
+ 'gst-plugins-bad-libs')
optdepends=('kdialog: KDE splash dialog support'
'zenity: GNOME splash dialog support'
'python-kivy: splash dialog support (big picture mode)'
@@ -22,7 +40,8 @@ optdepends=('kdialog: KDE splash dialog support'
'vulkan-driver: actually have a vulkan driver installed'
'winetricks: protonfixes backend - highly recommended'
'wine: support for 32bit prefixes'
- 'xboxdrv: gamepad driver service')
+ 'xboxdrv: gamepad driver service'
+ 'lib32-libusb: wine usb support')
## makepkg options
options=('!strip')