summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJaja2022-02-27 22:57:08 +0100
committerJaja2022-02-27 22:57:08 +0100
commit8a89e227b551fded7424ac90222335d81669a619 (patch)
tree73a1969ab9540cacd295459109a175399b1d67fb
parent3cb94e838f7f540ccc1033f07c63e0d836fdaac7 (diff)
downloadaur-8a89e227b551fded7424ac90222335d81669a619.tar.gz
possibly prefix brakeing update
- naming changed - packet base is now proton experimental - expect quite some trouble ahead..
-rw-r--r--.SRCINFO39
-rw-r--r--PKGBUILD69
-rw-r--r--changelog.md (renamed from changelog)33
-rw-r--r--supplementary.tar.zstbin13091 -> 15643 bytes
4 files changed, 85 insertions, 56 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9e51a32a8d87..11a19a19fc4c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,10 @@
pkgbase = proton-ge-custom-bin
pkgdesc = A fancy custom distribution of Valves Proton with various patches
- pkgver = 7.3_GE_1
- pkgrel = 2
+ pkgver = GE_Proton7_1
+ pkgrel = 1
+ epoch = 1
url = https://github.com/GloriousEggroll/proton-ge-custom
- changelog = changelog
+ changelog = changelog.md
arch = x86_64
license = BSD
license = LGPL
@@ -14,40 +15,40 @@ pkgbase = proton-ge-custom-bin
makedepends = patch
depends = python
depends = vulkan-icd-loader
+ depends = lib32-libusb
+ depends = lib32-openal
+ depends = lib32-sdl2
depends = lib32-v4l-utils
- depends = lib32-flac
+ depends = lib32-jack
+ depends = lib32-libva
+ depends = ffmpeg4.4
depends = lib32-speex
+ depends = lib32-libtheora
+ depends = gst-plugins-bad-libs
depends = lib32-gst-plugins-base-libs
- depends = lib32-jack
+ depends = libjpeg6-turbo
+ depends = lib32-libjpeg6-turbo
depends = lib32-libgudev
+ depends = lib32-flac
depends = lib32-mpg123
- depends = lib32-libtheora
- depends = ffmpeg4.4
- depends = lib32-sdl2
- depends = lib32-openal
- depends = lib32-libva
- depends = lib32-libjpeg6-turbo
- depends = libjpeg6-turbo
- depends = gst-plugins-bad-libs
optdepends = kdialog: KDE splash dialog support
optdepends = zenity: GNOME splash dialog support
optdepends = python-kivy: splash dialog support (big picture mode)
optdepends = steam: use proton with steam like intended
optdepends = lib32-vulkan-icd-loader: dxvk dependency for 32bit prefixes
- optdepends = vulkan-driver: actually have a vulkan driver installed
+ optdepends = vulkan-driver: driver to be used by dxvk
optdepends = winetricks: protonfixes backend - highly recommended
optdepends = wine: support for 32bit prefixes
optdepends = xboxdrv: gamepad driver service
- optdepends = lib32-libusb: wine usb support
provides = proton
- provides = proton-ge-custom=7.3.GE_1
+ provides = proton-ge-custom=GE.Proton7_1
conflicts = proton-ge-custom-legacy-bin
conflicts = proton-ge-custom
options = !strip
backup = usr/share/steam/compatibilitytools.d/proton-ge-custom/user_settings.py
- source = proton-ge-custom-7.3-GE-1_2.tar.gz::https://github.com/GloriousEggroll/proton-ge-custom/releases/download/7.3-GE-1/Proton-7.3-GE-1.tar.gz
+ source = proton-ge-custom-GE-Proton7-1_1.tar.gz::https://github.com/GloriousEggroll/proton-ge-custom/releases/download/GE-Proton7-1/GE-Proton7-1.tar.gz
source = supplementary.tar.zst
- sha512sums = a6cff92e0182ee3ce410be8958507e47758f6028c392343150b00a8f57c447e3011b1a3739f31233bb0aa83515982f4dd45c2dc53d33eb739868b2d0ce6e6893
- sha512sums = 403f011e4299e3b2f7dc18b5c61729d500d07052aa9974d541fb5bce40dc59f8cd341fc77551668fc416d24f71de42b3ad39040f277cba7529b5361b548de051
+ sha512sums = e41efb3b1ad9014a6b23a62b9372623e456db4b4546c44966b867d5ce0bbc5367d4c17046ed108179b69d27c2ee8e323a8e57698683e4ca807a23a9a5b16db41
+ sha512sums = a5cacb0d5a619fbdcf89840ad818185d123dc9627592330435f9bdde45b9ae6b740e6d72e1af1c5267687055fb04c49bef2a940b4d80cae57170ebe692fb8523
pkgname = proton-ge-custom-bin
diff --git a/PKGBUILD b/PKGBUILD
index 1abac7f2ef2c..81f23b7b498c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,11 +5,14 @@
## pkginfo
pkgdesc="A fancy custom distribution of Valves Proton with various patches"
pkgname=proton-ge-custom-bin
-pkgver=7.3_GE_1
-pkgrel=2
+pkgver=GE_Proton7_1
+pkgrel=1
+# remove epoch after some time, maybe 3 month or so
+# we need to do this since upstream naming has changed :(
+epoch=1
arch=('x86_64')
license=('BSD' 'LGPL' 'zlib' 'MIT' 'MPL' 'custom')
-changelog=changelog
+changelog=changelog.md
provides=('proton' "proton-ge-custom=${pkgver/_/.}")
conflicts=('proton-ge-custom-legacy-bin' 'proton-ge-custom')
@@ -17,31 +20,31 @@ conflicts=('proton-ge-custom-legacy-bin' 'proton-ge-custom')
makedepends=('patch')
depends=('python'
'vulkan-icd-loader'
+ 'lib32-libusb'
+ 'lib32-openal'
+ 'lib32-sdl2'
'lib32-v4l-utils'
- 'lib32-flac'
- 'lib32-speex'
- 'lib32-gst-plugins-base-libs'
'lib32-jack'
- 'lib32-libgudev'
- 'lib32-mpg123'
- 'lib32-libtheora'
- 'ffmpeg4.4'
- 'lib32-sdl2'
- 'lib32-openal'
'lib32-libva'
- 'lib32-libjpeg6-turbo'
+ 'ffmpeg4.4'
+ 'lib32-speex'
+ 'lib32-libtheora'
+ 'gst-plugins-bad-libs'
+ 'lib32-gst-plugins-base-libs'
'libjpeg6-turbo'
- 'gst-plugins-bad-libs')
+ 'lib32-libjpeg6-turbo'
+ 'lib32-libgudev'
+ 'lib32-flac'
+ 'lib32-mpg123')
optdepends=('kdialog: KDE splash dialog support'
'zenity: GNOME splash dialog support'
'python-kivy: splash dialog support (big picture mode)'
'steam: use proton with steam like intended'
'lib32-vulkan-icd-loader: dxvk dependency for 32bit prefixes'
- 'vulkan-driver: actually have a vulkan driver installed'
+ 'vulkan-driver: driver to be used by dxvk'
'winetricks: protonfixes backend - highly recommended'
'wine: support for 32bit prefixes'
- 'xboxdrv: gamepad driver service'
- 'lib32-libusb: wine usb support')
+ 'xboxdrv: gamepad driver service')
## makepkg options
options=('!strip')
@@ -49,11 +52,11 @@ options=('!strip')
## fix naming conventions, matching upstream
_pkgname=${pkgname//-bin/}
_pkgver=${pkgver//_/-}
-_srcdir=Proton-${_pkgver}
+_srcdir=${_pkgver}
## paths and files
_protondir=usr/share/steam/compatibilitytools.d/${_pkgname}
-_licensedir=usr/share/licenses/${_pkgname}
+_licensedir=usr/share/licenses/${pkgname}
_execfile=usr/bin/proton
_protoncfg=${_protondir}/user_settings.py
@@ -62,24 +65,21 @@ backup=("${_protoncfg}")
## sources
url='https://github.com/GloriousEggroll/proton-ge-custom'
-source=(${_pkgname}-${_pkgver}_${pkgrel}.tar.gz::"${url}/releases/download/${_pkgver}/${_srcdir}.tar.gz"
+source=(${_pkgname}-${_pkgver}_${pkgrel}.tar.gz::"${url}/releases/download/${_pkgver}/${_pkgver}.tar.gz"
"supplementary.tar.zst")
-sha512sums=('a6cff92e0182ee3ce410be8958507e47758f6028c392343150b00a8f57c447e3011b1a3739f31233bb0aa83515982f4dd45c2dc53d33eb739868b2d0ce6e6893'
- '403f011e4299e3b2f7dc18b5c61729d500d07052aa9974d541fb5bce40dc59f8cd341fc77551668fc416d24f71de42b3ad39040f277cba7529b5361b548de051')
+sha512sums=('e41efb3b1ad9014a6b23a62b9372623e456db4b4546c44966b867d5ce0bbc5367d4c17046ed108179b69d27c2ee8e323a8e57698683e4ca807a23a9a5b16db41'
+ 'a5cacb0d5a619fbdcf89840ad818185d123dc9627592330435f9bdde45b9ae6b740e6d72e1af1c5267687055fb04c49bef2a940b4d80cae57170ebe692fb8523')
build() {
-## remove unused: dist_lock, cleanup_legacy_dist(), need_tarball_extraction(), extract_tarball()
-patch "${_srcdir}"/proton patches/distlock-extract-defaultpfx.patch
-## use newest dist
-rm -rf "${_srcdir}/dist"/*
-bsdtar -xf "${_srcdir}"/proton_dist.tar.gz -C "${_srcdir}"/dist
+## patches
+install --mode=0755 ${srcdir}/patches/tracked_files ${_srcdir}/proton_ge_tracked_files
+sed -i "s|_proton=echo|_proton=/${_protondir}/proton|" ${srcdir}/launchers/proton.sh
+sed -i -r 's|"GE-Proton.*"|"Proton-GE"|' ${_srcdir}/compatibilitytool.vdf
## remove artifacts
-rm "${_srcdir}"/proton_dist.tar.gz
rm "${_srcdir}"/protonfixes/*.tar.xz
-## setup paths
-sed -i "s|_proton=echo|_proton=/${_protondir}/proton|" ${srcdir}/launchers/proton.sh
-## setup naming that appears in steam compat tool list
-sed -i -r 's|"Proton-.*"|"Proton-GE"|' ${srcdir}/Proton-${_pkgver}/compatibilitytool.vdf
+## fixes from namcap inspection
+chmod -R a+r "${_srcdir}"/protonfixes/gamefixes
+strip --preserve-dates --strip-unneeded "${_srcdir}"/dist/bin/wine*
}
package() {
@@ -97,9 +97,4 @@ install --mode=0775 --group=50 ${srcdir}/configs/user_settings.py ${pkgdir}/${_p
## executables
mv ${_srcdir}/* ${pkgdir}/${_protondir}
install --mode=0755 ${srcdir}/launchers/proton.sh ${pkgdir}/${_execfile}
-## patches
-# Setup replacement tracked_files. If used without steam, we never get this file? Used by launcher script.
-# Update from your ~/.steam/steam/steamapps/compatdata/0/tracked_files please. It gets created as soon as you start steam.
-# Check first ~/.steam/steam/steamapps/compatdata/0/version if it is the correct version of GE, though!
-install --mode=0755 ${srcdir}/patches/tracked_files ${pkgdir}/${_protondir}/proton_ge_tracked_files
}
diff --git a/changelog b/changelog.md
index aca9ee33e40f..5c47a29ba8f1 100644
--- a/changelog
+++ b/changelog.md
@@ -1,3 +1,36 @@
+## GE-Proton7-1 Released
+
+Why the new naming scheme?
+
+As discussed here:
+
+https://www.patreon.com/posts/63101415
+
+The base for WINE was changed from wine upstream to Proton experimental, and staging currently is not used in this new build. There are several reasons this was done, which are explained in detail in the post above.
+
+I needed a way to express that the base is all Proton7 and to reset the minor versions. Additionally, from previous discussions I've had with some other devs on official proton, they requested that I modify the name so that the GE versions were easier to differentiate, which is why the GE prefix has been moved to the front of the name.
+
+### What exactly has changed?
+
+WINE upstream repo has been changed to Proton experimental bleeding edge.
+Wine-staging is no longer used, but we keep it within the repository in case it is discovered that patches are needed from it later on.
+
+### What has remained the same from previous Proton-GE builds?
+
+mfplat implementation and continued work
+gstreamer and ffmpeg implementation
+protonfixes implementation and continued work
+Various game patches which are not included in either upstream wine or proton and continuation to add such patches
+dxvk-git and adding new patches or pending PRs as they become available
+dxvk is still patched with async
+vkd3d-proton-git and adding new patches or pending PRs as they become available
+
+### What's actually fixed in this release compared to the last one?
+
+Elden Ring EAC now works
+The crash in various Unity games is resolved
+Since we are now using proton's bleeding-edge experimental, we now have -all- of the controller and gamescope related patches. So if something is broken there -- it's an upstream proton bug.
+Fixed doubled size issue caused by both dist folder and dist tarball being included. The dist tarball is not necessary and has been removed, returning the build to its original size instead of double.
## Proton-7.3-GE-1 Released
diff --git a/supplementary.tar.zst b/supplementary.tar.zst
index 05bfd1245d2e..710f00e64847 100644
--- a/supplementary.tar.zst
+++ b/supplementary.tar.zst
Binary files differ