summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHenri Puchta2020-03-17 16:49:04 +0100
committerHenri Puchta2020-03-17 16:49:04 +0100
commitad125abb9fc5dac4c3a81e039a5fa1dba0281bbd (patch)
tree9ebabe7c590dc95acda3cddf089e39f413007dce
downloadaur-ad125abb9fc5dac4c3a81e039a5fa1dba0281bbd.tar.gz
initial
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD68
-rw-r--r--supplementary.tar.zstbin0 -> 1673 bytes
3 files changed, 93 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0b336f1648ef
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = proton-ge-custom-legacy-bin
+ pkgdesc = A fancy custom distribution of Valves Proton with various patches - legacy branch
+ pkgver = 4.21_GE_2
+ pkgrel = 1
+ url = https://github.com/GloriousEggroll/proton-ge-custom
+ arch = x86_64
+ license = BSD
+ license = LGPL
+ license = zlib
+ license = MIT
+ license = MPL
+ license = custom
+ depends = python
+ optdepends = winetricks: protonfixes backend
+ optdepends = wine-staging: 32bit prefixes
+ optdepends = python-cef: splash dialog support
+ optdepends = zenity: splash dialog support
+ optdepends = steam: use proton with steam like intended
+ source = proton-ge-custom-legacy-4.21-GE-2.tar.gz::https://github.com/GloriousEggroll/proton-ge-custom/releases/download/4.21-GE-2/Proton-4.21-GE-2.tar.gz
+ source = supplementary.tar.zst
+ md5sums = 19c4163bad6d868ce7990f258369a4c6
+ md5sums = 07c5abd3c7d734661ac9d889918a5cf3
+
+pkgname = proton-ge-custom-legacy-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9901a10aa2ec
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,68 @@
+## Maintainer: barfin <barfin@protonmail.com>
+## Co-Maintainer: Jaja <jaja@mailbox.org>
+
+## pkginfo
+pkgdesc="A fancy custom distribution of Valves Proton with various patches - legacy branch"
+pkgname=proton-ge-custom-legacy-bin
+pkgver=4.21_GE_2
+pkgrel=1
+arch=('x86_64')
+license=('BSD' 'LGPL' 'zlib' 'MIT' 'MPL' 'custom')
+depends=('python')
+optdepends=('winetricks: protonfixes backend'
+ 'wine-staging: 32bit prefixes'
+ 'python-cef: splash dialog support'
+ 'zenity: splash dialog support'
+ 'steam: use proton with steam like intended')
+
+## fix naming conventions, matching upstream
+_pkgname=${pkgname//-bin/}
+_pkgver=${pkgver//_/-}
+_srcdir=Proton-${_pkgver}
+
+## paths and files
+_protondir=usr/share/steam/compatibilitytools.d/${_pkgver}
+_licensedir=usr/share/licenses/${_pkgname}
+_pfxdir=var/games/pfx_${_pkgver}
+#_configfile=usr/local/etc/proton/user_settings.py
+#backup=("${_configfile}")
+
+## sources
+url='https://github.com/GloriousEggroll/proton-ge-custom'
+source=(${_pkgname}-${_pkgver}.tar.gz::"${url}/releases/download/${_pkgver}/${_srcdir}.tar.gz"
+ "supplementary.tar.zst")
+md5sums=('19c4163bad6d868ce7990f258369a4c6'
+ '07c5abd3c7d734661ac9d889918a5cf3')
+
+prepare() {
+## unpack wine
+install -d ${_srcdir}/dist
+#bsdtar -xf ${_srcdir}/proton_dist.tar.gz -C ${_srcdir}/dist/
+#rm ${_srcdir}/proton_dist.tar.gz
+}
+
+build() {
+## remove unused: dist_lock, extract_tarball(), make_default_prefix()
+patch ${_srcdir}/proton patches/distlock-extract-defaultpfx.patch
+## setup paths
+#sed -i "s|self.path(\"user_settings.py\")|\"/${_configfile}\"|" ${_srcdir}/proton
+sed -i "s|self.path(\"dist/share/default_pfx/\")|\"/${_pfxdir}/\"|" ${_srcdir}/proton
+}
+
+package() {
+## create paths
+install -d ${pkgdir}/${_protondir}/
+install -d ${pkgdir}/${_licensedir}/
+install -d --mode=2775 --group=games ${pkgdir}/${_pfxdir}/
+chmod 0775 ${pkgdir}/${_pfxdir}/..
+#install -d ${pkgdir}/$(dirname ${_configfile})/
+## licenses
+mv ${_srcdir}/LICENSE ${pkgdir}/${_licensedir}/license
+## config files
+#install --mode=0775 --group=games ${srcdir}/configs/user_settings.py ${pkgdir}/${_configfile}
+## default pfx
+mv ${_srcdir}/dist/share/default_pfx/* ${pkgdir}/${_pfxdir}
+chown -R :games ${pkgdir}/${_pfxdir}
+## executables
+mv ${_srcdir}/* ${pkgdir}/${_protondir}
+}
diff --git a/supplementary.tar.zst b/supplementary.tar.zst
new file mode 100644
index 000000000000..763d2dc18df6
--- /dev/null
+++ b/supplementary.tar.zst
Binary files differ