summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBarfin2020-06-10 05:38:26 +0430
committerBarfin2020-06-10 05:38:26 +0430
commitec6db6608d8ad8e185e48b975219df25916c9a07 (patch)
tree2d9a5281137e9d38263360f29f1e1dc85fc30a03
downloadaur-ec6db6608d8ad8e185e48b975219df25916c9a07.tar.gz
initial commit
-rw-r--r--.SRCINFO39
-rw-r--r--PKGBUILD82
-rw-r--r--changelog285
-rw-r--r--supplementary.tar.zstbin0 -> 3237 bytes
4 files changed, 406 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d17c42c6b929
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,39 @@
+pkgbase = proton-ge-custom-stable-bin
+ pkgdesc = A fancy custom distribution of Valves Proton with various patches(Stable Branch)
+ pkgver = 5.8_GE_2_MF
+ pkgrel = 1
+ url = https://github.com/GloriousEggroll/proton-ge-custom
+ changelog = changelog
+ arch = x86_64
+ license = BSD
+ license = LGPL
+ license = zlib
+ license = MIT
+ license = MPL
+ license = custom
+ depends = python
+ depends = vulkan-icd-loader
+ optdepends = kdialog: KDE splash dialog support
+ optdepends = zenity: GNOME splash dialog support
+ optdepends = python-kivy: splash dialog support (big picture mode)
+ optdepends = steam: use proton with steam like intended
+ optdepends = lib32-vulkan-icd-loader: dxvk dependency for 32bit prefixes
+ optdepends = vulkan-driver: actually have a vulkan driver installed
+ optdepends = linux-fsync: a kernel with futex-wait-multiple support
+ optdepends = linux-zen: a kernel with futex-wait-multiple support
+ optdepends = linux-pf: a kernel with futex-wait-multiple support
+ optdepends = winetricks: protonfixes backend - highly recommended
+ optdepends = wine: support for 32bit prefixes
+ optdepends = xboxdrv: gamepad driver service
+ optdepends = python-cef: generic splash dialog support
+ provides = proton
+ conflicts = proton-ge-custom-bin
+ options = !strip
+ backup = usr/share/steam/compatibilitytools.d/proton-ge-custom-stable/user_settings.py
+ source = proton-ge-custom-stable-5.8-GE-2-MF.tar.gz::https://github.com/GloriousEggroll/proton-ge-custom/releases/download/5.8-GE-2-MF/Proton-5.8-GE-2-MF.tar.gz
+ source = supplementary.tar.zst
+ md5sums = 7a1f5d052f99c396323f813515ba0e55
+ md5sums = 3ae457f1acc34660244975884b2e0f68
+
+pkgname = proton-ge-custom-stable-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5f0fa4799f51
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,82 @@
+## Maintainer: barfin <barfin@protonmail.com>
+## Co-Maintainer: Jaja <jaja@mailbox.org>
+
+## pkginfo
+pkgdesc="A fancy custom distribution of Valves Proton with various patches(Stable Branch)"
+pkgname=proton-ge-custom-stable-bin
+pkgver=5.8_GE_2_MF
+pkgrel=1
+arch=('x86_64')
+license=('BSD' 'LGPL' 'zlib' 'MIT' 'MPL' 'custom')
+changelog=changelog
+provides=('proton')
+conflicts=('proton-ge-custom-bin')
+depends=('python'
+ 'vulkan-icd-loader')
+optdepends=('kdialog: KDE splash dialog support'
+ 'zenity: GNOME splash dialog support'
+ 'python-kivy: splash dialog support (big picture mode)'
+ 'steam: use proton with steam like intended'
+ 'lib32-vulkan-icd-loader: dxvk dependency for 32bit prefixes'
+ 'vulkan-driver: actually have a vulkan driver installed'
+ 'linux-fsync: a kernel with futex-wait-multiple support'
+ 'linux-zen: a kernel with futex-wait-multiple support'
+ 'linux-pf: a kernel with futex-wait-multiple support'
+ 'winetricks: protonfixes backend - highly recommended'
+ 'wine: support for 32bit prefixes'
+ 'xboxdrv: gamepad driver service'
+ 'python-cef: generic splash dialog support')
+
+## makepkg options
+options=('!strip')
+
+## fix naming conventions, matching upstream
+_pkgname=${pkgname//-bin/}
+_pkgver=${pkgver//_/-}
+_srcdir=Proton-${_pkgver}
+
+## paths and files
+_protondir=usr/share/steam/compatibilitytools.d/${_pkgname}
+_licensedir=usr/share/licenses/${_pkgname}
+_pfxdir=var/games/pfx_${_pkgname}
+_execfile=usr/local/bin/proton
+_protoncfg=${_protondir}/user_settings.py
+
+## user edited files to backup
+backup=("${_protoncfg}")
+
+## sources
+url='https://github.com/GloriousEggroll/proton-ge-custom'
+source=(${_pkgname}-${_pkgver}.tar.gz::"${url}/releases/download/${_pkgver}/${_srcdir}.tar.gz"
+ "supplementary.tar.zst")
+md5sums=('7a1f5d052f99c396323f813515ba0e55'
+ '3ae457f1acc34660244975884b2e0f68')
+
+build() {
+## remove unused: dist_lock, extract_tarball(), make_default_prefix()
+patch ${_srcdir}/proton patches/distlock-extract-defaultpfx.patch
+## setup paths
+sed -i "s|_proton=echo|_proton=/${_protondir}/proton|" ${srcdir}/launchers/proton.sh
+sed -i "s|self.path(\"dist/share/default_pfx/\")|\"/${_pfxdir}/\"|" ${_srcdir}/proton
+}
+
+package() {
+## create paths
+install -d ${pkgdir}/${_protondir}/
+install -d ${pkgdir}/${_licensedir}/
+install -d --mode=2775 --group=games ${pkgdir}/${_pfxdir}/
+chmod 0775 ${pkgdir}/${_pfxdir}/..
+install -d ${pkgdir}/$(dirname ${_execfile})/
+## licenses
+mv ${_srcdir}/LICENSE ${pkgdir}/${_licensedir}/license
+mv ${_srcdir}/LICENSE.OFL ${pkgdir}/${_licensedir}/license_OFL
+mv ${_srcdir}/protonfixes/LICENSE ${pkgdir}/${_licensedir}/license_protonfixes
+## config files
+install --mode=0775 --group=games ${srcdir}/configs/user_settings.py ${pkgdir}/${_protoncfg}
+## default pfx
+mv ${_srcdir}/dist/share/default_pfx/* ${pkgdir}/${_pfxdir}
+chown -R :games ${pkgdir}/${_pfxdir}
+## executables
+mv ${_srcdir}/* ${pkgdir}/${_protondir}
+install --mode=0755 ${srcdir}/launchers/proton.sh ${pkgdir}/${_execfile}
+}
diff --git a/changelog b/changelog
new file mode 100644
index 000000000000..e0b8c3650833
--- /dev/null
+++ b/changelog
@@ -0,0 +1,285 @@
+Proton-5.8-GE-2-MF
+
+This is an update to 5.8-GE-1 in regards to media foundation work:
+
+Completed:
+-RE3: Bathroom scene fixed
+-Dangonronpa v3 fixed
+-Power Rangers Battle for the grid chipmunk voices fixed
+-Monster Hunter World tutorial movies fixed
+-Super Lucky's Tale -- Fixed an issue with bink videos not playing in GE builds which work in proton
+
+Proton-5.8-GE-1-MF
+
+GloriousEggroll released this May 10, 2020
+
+Overall fixes:
+-Fix for ValveSoftware#2929 added, fixes crash in Dark Souls 3, Sekiro, Nier: Automata
+-GTA IV should be fully playable now, patches imported from upstream proton
+-Street Fighter V should be fully playable now, patches imported from upstream proton
+-HideWineExports=Y registration added for FFXIV, fixes license issue
+-Homeworld Remastered Collection should be playable without custom launcher necessary
+-Updated steep patch for wine 5.8
+-fixed proton controller patch issues -- should now have full proton controller patchset and functionality to match upstream proton
+-patch added that fixes overwatch breakage in 5.7
+-patch added that fixes star citizen breakage in 5.7
+-patch added that fixes Path of Exile flicker in 5.7
+-FFXV patch is now working again, game should be playable
+-Monster Hunter World patches added which enable DX12 mode with vkd3d
+MF (Media Foundation) specific fixes:
+-Resident Evil 2 videos fixed, should now be fully playable, also works in DX12/vkd3d
+-Spyro Reignited Trilogy videos fixed, should now be fully playable
+-Remnant: From the Ashes videos fixed, should now be fully playable
+-Soul Calibur VI videos fixed, should now be fully playable
+-Street Fighter V videos fixed, should now be fully playable
+-Deep Rock Galactic videos fixed, should now be fully playable
+-BlazBlue Centralfiction videos fixed, should now be fully playable
+-Bloodstained: Ritual of the night intro videos fixed, should now be fully playable
+-Crazy Machines 3 videos fixed, should now be fully playable
+
+
+Proton-5.6-GE-2
+
+GloriousEggroll released this Apr 14, 2020
+
+-This is a hotfix that reverts the fullscreen hack changes, as they introduced a regression with mouse stutter on movement after a period of time. What this means:
+-Fullscreen hack is still enabled, it's just using proton's version, not customized for staging
+-Staging's winex11.drv-mouse-coorrds and rawinput patchsets have been disabled
+-Proton's rawinput patchset has been re-enabled.
+
+Normally I'd wait to release smaller changes like this, but the regression made some games basically unplayable. This should allow games to be played at least without the mouse stutter.
+
+
+Proton-5.6-GE-1
+
+GloriousEggroll released this Apr 13, 2020
+
+This is a pre-release continuation of the mfplat work done by Guy1524 (Derek) along with some additional fixes.
+
+Wine + Wine-staging:
+-Update to 5.6 release
+
+mfplat:
+-Add partial WMV playback support (Should allow RE2 and RE3 movies to play)
+-Add gst-plugins-ugly and wmv playback patch to build
+
+protonfixes:
+-Add dxgi=n override for Darksiders Warmastered Edition, game seems to crash with wine's dxgi when using dxvk
+-Add Divinity Original Sin 2 symlink fix update - fixes black screen on first launch
+-Add SECCOMP override for RE3, needed by Denuvo
+-Add SECCOMP override for DOOM Eternal, needed by Denuvo
+
+proton:
+-Add Proton 5.0.6 alpha patches
+-Add Proton 5.0.6 alpha DOOM Eternal Audio patches
+-fixed build system to include dist folder directly instead of tarball. This fixes the issue with sometimes having to hit the play button twice, or some issues people have on their system where the dist tarball never extracts.
+-fullscreen hack patches modified to work with staging's winex11.drv-mouse-coorrds and rawinput patch sets
+
+Notes:
+-Spyro is still broken
+-MHW Tutorials are still broken
+-BL3 usually wants to set Direct12, which crashes. This generally leads to a popup asking you to restore default settings (confirm/hit yes). You will then need to relaunch the game and go in the games settings and change it to DirectX11 manually. After that DirectX11 should stick as the default mode.
+-RE2 Crashes in DX12 with vkd3d at main menu, you'll need to set DirectX11 in re2_config.ini for DX11 with DXVK
+-RE3 Seems to work with DX12 and vkd3d with minor interface graphical glitches. Can set DirectX11 in re3_config.ini for DX11 with DXVK
+-FFXV seems to be working again
+
+Again, I must note that 'pre-release' builds are basically alpha-testing builds. While they may contain a lot of fixes, some things may also be broken that normally are not.
+
+Specifically in this regard - proton normally disables 'mfplay' which allows media foundation movies in many games (WMV and MP4) to just be skipped automatically. Since we enable this without full functionality, some games, such as Spyro or MHW, may hang when a movie tries to play.
+
+If you wish to re-disable media foundation to use this version with your other games, you can use WINEDLLOVERRIDES=mfplay=n %command% in the game's launch options.
+
+
+Proton-5.5-GE-1
+
+GloriousEggroll released this Apr 5, 2020
+
+So I'd like to preface that this is a pre-release that has a massive amount of media foundation/mfplat wine patches. A huge thank you goes to Derek Lesho (Guy1524: https://github.com/Guy1524/wine) as well as Nikolay Sivov and Sergio Gómez Del Real all from CodeWeavers for getting this stuff working and taking the time to help me get it working with the correct dependencies in proton.
+
+What this does is allows mp4 playback in MANY titles, including UE4 -and- Unity engine games. This fixes a lot (not all, but a lot) of issues surrounding media foundation/mfplat without the need for the 'mf-install' workaround that has legal issues and limitations, and is much safer for us to ship.
+
+Tested fixes:
+-Fixed borderlands 3 lilith in-head videos and 'watch the monitor' video bug
+-Fixes Remnant: From the Ashes intro videos, intro menu, character menu
+-Fixes intro video on Bloodstained: Ritual of the Night
+-Fixes mp4 playback issues related to Crazy Machines 3
+
+Still broken:
+-Borderlands 3 intro narrative with Marcus's voice on new game does not play
+-Spyro is still broken
+-Probably some other mp4 related titles
+
+Additional updates:
+-A small patch has been added that should fix sunset overdrive from crashing on launch: https://source.winehq.org/patches/data/182631
+-Two warframe launcher regressions have been fixed
+-Mouse input fix patches which were added to wine-staging for Mount & Blade II: Bannerlord: https://bugs.winehq.org/show_bug.cgi?id=36873
+-Lots of gstreamer plugin related work has been done/added in order to get media foundation stuff working. This was also cleared with aeikum and kisak from Valve personally, and deemed -ok- to include in my repository. This means it is safe to continue to link in Valve's issue trackers, unlike the 'mf-install' workaround. HURRAY!
+
+Additional notes:
+-Not -all- mp4s are fixed. There are still some that have problematic formats that are being worked on.
+-Also coming down the pipe soon will be WMV playback fixes. This is to be handled after the mp4 issues are sorted.
+
+Enjoy!
+
+
+Proton-5.4-GE-3
+
+GloriousEggroll released this Mar 25, 2020
+
+-wine 5.4 updated to latest git which includes some fixes/updates winevulkan to 1.2.134. DOOM Eternal seems to work fine with it when not blocked by Denuvo.
+-Added ValveSoftware/wine#86 for more winevulkan compatibility
+-Added https://source.winehq.org/patches/data/181826 for more winevulkan compatibility
+-FAudio reverted to 20.03 stable release as some audio issues were reported
+-Warframe controller patch updated to strictly only take effect when warframe is running, since the issue doesn't seem to affect other games.
+-proton controller patches have been disabled (again) in favor of standard wine+wine-staging's, after reports of 'ghost' input and/or periodic input loss. SDL patches are still in applied.
+
+
+Proton-5.4-GE-2
+
+GloriousEggroll released this Mar 22, 2020
+
+This is more of a clean-up release although some new stuff/fixes have been added, mainly for DOOM Eternal
+
+-Updated wine + staging to 5.4-git/upstream for DOOM Eternal
+-Added ValveSoftware/wine#85 VK_KHR_get_surface_capabilities2 and fake support for VK_EXT_full_screen_exclusive for DOOM Eternal
+-Added ValveSoftware/wine#83 which fixes some crashes in DARK SOULS III (374320), Nier: Automata (524220), Sekiro: Shadows Die Twice (814380)
+-Added some missing registry entries that prevented Batman: Arkham Knight from starting on a clean prefix
+-Cleaned up/removed unused mf_install verb in protonfixes in preparation for newer mfplat alpha patches (coming soon)
+-Removed '-wolcen lords of mayhem 'blob head' fix' as the game devs fixed it internally per update 1.0.10.0
+-Removed 'plasma systray fix' as it didn't really benefit anything, and actually interfered with some games.
+-Removed Detroit:Become Human patch as it's already been upstreamed
+-Cleaned up some duplicate patches and updated our current patches to work with latest wine-git+staging/git
+-Updated vkd3d
+-Updated dxvk
+-Updated FAudio
+
+Notes on DOOM Eternal:
+
+ DOOM Eternal currently requires vulkan-loader/vulkan-icd-loader 1.2.135
+ For AMD also requires mesa-git .
+ ACO did not work for me with DOOM Eternal when I tried it, but llvm worked fine.
+ To get rid of pre-launch GPU notices such as (HDR not supported), open DOOMEternal/launcherData/launcher.cfg and change all of these to 0:
+
+rgl_showAMDStartupWarning 0
+rgl_showIntelStartupWarning 0
+rgl_showNvidiaStartupWarning 0
+
+
+Proton-5.4-GE-1
+
+GloriousEggroll released this Mar 16, 2020
+
+-controller fix for warframe - allows controller profiles to be loaded only if a controller is plugged in. fixes crash if no controller plugged in after 5 min.
+-vkd3d updated, allows WoW to be played using proton via lutris (disable dxvk in lutris)
+-more metro exodus vkd3d fixes
+-wolcen lords of mayhem 'blob head' fix
+-detroit: become human patch added
+-need for speed world launcher patch added
+-wine+ wine-staging updated to 5.4
+-dxvk updated to latest git
+-faudio updated to latest git
+-fixes from Proton 5.0.4 imported
+
+Known issues:
+
+-MHW broken since last patch.
+-MK11 broken since wine 5.0
+-Injustice 2 broken since wine 5.0 (did not work here, but have had it reported working in 4.21)
+-Borderlands 3 does not work with vkd3d yet
+
+
+Proton-5.2-GE-2
+
+GloriousEggroll released this Feb 23, 2020
+
+This is a pre-release to fix Fallout New Vegas from crashing on main menu.
+-fixes a missing portion of the fullscreen hack
+-dxvk updated
+-more metro exodus vkd3d fixes
+-wine 5.2 updated to latest git
+
+
+Proton-5.2-GE-1
+
+GloriousEggroll released this Feb 19, 2020
+
+This is a pre-release to fix the Warframe Launcher bug introduced in 2/18's update.
+
+
+Proton-5.1-GE-2
+
+GloriousEggroll released this Feb 17, 2020
+
+This is mainly a hotfix + feature release build.
+
+Hotfix:
+-Fixed warframe requiring a controller to be plugged in. That's right, you no longer need xboxdrv! I spent the weekend debugging it and was finally able to come up with a bit of a hacky workaround, but it works for now until valve addresses the issue (it has to do with the way lsteamclient handles controllers)
+
+Feature:
+-vkd3d branch is latest from codeweavers + DXIL changes by Hans Kristian (who has been doing a lot of vkd3d submissions) + metro exodus commits that both Hans and Doitsujin (creator of dxvk) have been working on together. The previous release had Hans's DXIL changes, this just adds the Metro changes on top of it. With that being said, expect some minor graphical glitches in vkd3d with Metro Exodus
+
+Additions:
+-This commit: ValveSoftware#3518 has been merged. This was a previous open PR from Guy1542, but it had a bug that would cause clustertruck and a few others not to launch. The new PR is by joshie (d9vk dev) and works now
+
+-dxvk update to latest git
+-faudio updated to latest git
+
+Known issues:
+-Just Cause 3 not able to save
+-Batman Arkham Knight grappling hook not working
+-MK11 hanging at launch (again)
+
+
+Proton-5.1-GE-1
+
+GloriousEggroll released this Feb 10, 2020
+
+-added fullscreen hack rebase from proton 5
+-added updated steamclient rebase from proton 5 so that jc3 and batman AK denuvo problems work
+-added updated monster hunter world patch that limits the changes to monster hunter world
+-added proton patch that sets prefixes to win10 by default
+-added dsound surround sound patches from proton 5
+-proton dxvk wine integration patches added so that vkd3d works ootb without PROTON_USE_WINED3D
+-reenabled proton's gamepad changes in favor over staging's (for now. let me know in discord if issues occur)
+-updated to include proton's gstreamer and glib integration work
+-added plasma systray patch
+-fixed proton compatibility for staging patchset winex11.drv-mouse-coorrds
+-disabled winex11-_NET_ACTIVE_WINDOW temporarily (not working correctly)
+-disabled winex11-WM_WINDOWPOSCHANGING temporarily (depends on winex11-_NET_ACTIVE_WINDOW)
+-updated dxvk to 1.5.4 official
+-updated FAudio
+-updated vkd3d
+
+Known issues:
+-Just Cause 3 not able to save
+-Please note, vkd3d is very new and still does not work for DirectX 12 on all games.
+
+
+Proton-5.0-GE-1
+
+GloriousEggroll released this Jan 30, 2020
+
+-fixed issue with uplay games not recognizing they were being launched from steam
+-fixed issue with farcry 5 hanging at launch
+-fixed issue with stuttering in various games introduced by staging's ntdll-ForceBottomUpAlloc patches (darksiders 3, farcry 5)
+-raw input patches finally fixed and enabled
+-fixed issue with the MK11/skyrim skyui patch trying to allocate 119t virtual memory
+-added patches that allow For Honor and steep to launch and work in single-player mode
+-added patch that fixes battlenet beta crashing with win10 set in winecfg
+-added patch that fixes fullscreen mode in steep
+-added patch that fixes performance regression in Monster Hunter World caused by Iceborn DLC release.
+-fixed proton compatibility for staging patchset winex11-MWM_Decorations (fixes https://bugs.winehq.org/show_bug.cgi?id=42117 which affects battlenet)
+-fixed proton compatibility for staging patchset winex11-_NET_ACTIVE_WINDOW (fixes https://bugs.winehq.org/show_bug.cgi?id=2155 which affects some older games and apps)
+-added proton's internal wined3d dxvk integration changes
+-updated dxvk
+-updated faudio
+-changed vkd3d repository to one regularly worked on.
+
+Edit:
+-added fix for loading hang for endless legend
+-added black ops 2 launch crash fix
+-added winex11-WM_WINDOWPOSCHANGING patch from staging
+-fixed an issue with proton not using d3d9 override (whoopsie)
+
+Disabled the following for now, has an issue that causes windows to open and immediately close:
+-proton compatibility for staging patchset winex11.drv-mouse-coorrds (fixes https://bugs.winehq.org/show_bug.cgi?id=46309 which affects origin)
diff --git a/supplementary.tar.zst b/supplementary.tar.zst
new file mode 100644
index 000000000000..9a9a41481121
--- /dev/null
+++ b/supplementary.tar.zst
Binary files differ