summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbtd13372020-05-14 21:02:28 -0300
committerbtd13372020-05-14 21:02:28 -0300
commit75f041e9ac7bbb8fa7c69e56a8096a70f064a224 (patch)
treeca354af8f57fd4f56d47ece41aa869fa4f423bd4
parent993ac412ff27e74febc96696f1fc06bea1c39f11 (diff)
downloadaur-75f041e9ac7bbb8fa7c69e56a8096a70f064a224.tar.gz
Add submodules
-rwxr-xr-x.SRCINFO11
-rwxr-xr-xPKGBUILD36
2 files changed, 41 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 12469ae10b7c..a736f356833e 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = proton-ide-git
pkgdesc = A new IDE made with Vala.
- pkgver = r182.e6b754e
+ pkgver = v0.3.1.r0.ge6b754e
pkgrel = 1
url = https://gitlab.com/raggesilver-proton/proton
arch = i686
@@ -11,6 +11,7 @@ pkgbase = proton-ide-git
makedepends = vala
depends = gtk3
depends = granite
+ depends = editorconfig-core-c
depends = glib2
depends = gtksourceview4
depends = json-glib
@@ -22,6 +23,14 @@ pkgbase = proton-ide-git
provides = proton-ide-git
conflicts = proton-ide
source = git+https://gitlab.com/raggesilver-proton/proton.git
+ source = git+https://gitlab.com/raggesilver-proton/proton-runner-plugin.git
+ source = git+https://gitlab.com/raggesilver-proton/proton-editorconfig-plugin.git
+ source = git+https://gitlab.com/raggesilver-proton/proton-autobracket-plugin.git
+ source = git+https://gitlab.com/raggesilver-proton/proton-templates.git
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
md5sums = SKIP
pkgname = proton-ide-git
diff --git a/PKGBUILD b/PKGBUILD
index 91853df377c1..c772f403cf16 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,20 +5,27 @@ _gitname=proton
_author=raggesilver-proton
_pkg=("${_gitname}-ide")
pkgname=("${_pkg}-git")
-pkgver=r182.e6b754e
+pkgver=v0.3.1.r0.ge6b754e
pkgrel=1
pkgdesc="A new IDE made with Vala."
arch=('i686' 'x86_64')
url="https://gitlab.com/${_author}/${_gitname}"
+submodulesurl="https://gitlab.com/${_author}/proton"
license=('GPL3')
-depends=('gtk3' 'granite' 'glib2' 'gtksourceview4' 'json-glib' 'libdazzle'
- 'marble-gtk' 'vte3')
+depends=('gtk3' 'granite' 'editorconfig-core-c' 'glib2' 'gtksourceview4' 'json-glib'
+ 'libdazzle' 'marble-gtk' 'vte3')
optdepends=('')
makedepends=('git' 'meson>=0.50.0' 'vala')
provides=("${_pkg}" "${pkgname}")
conflicts=("${_pkg}")
-source=("git+${url}.git")
-md5sums=('SKIP')
+source=(
+ "git+${url}.git"
+ "git+${submodulesurl}-runner-plugin.git"
+ "git+${submodulesurl}-editorconfig-plugin.git"
+ "git+${submodulesurl}-autobracket-plugin.git"
+ "git+${submodulesurl}-templates.git"
+)
+md5sums=('SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP')
pkgver() {
cd "${_gitname}"
@@ -28,6 +35,25 @@ pkgver() {
)
}
+prepare() {
+ cd "${_gitname}/"
+ git submodule init
+ git config submodule.proton-runner-plugin.url $srcdir/plugins/runner
+ git submodule update
+
+ git submodule init
+ git config submodule.proton-editorconfig-plugin.url $srcdir/plugins/editorconfig
+ git submodule update
+
+ git submodule init
+ git config submodule.proton-autobracket-plugin.url $srcdir/plugins/autobracket
+ git submodule update
+
+ git submodule init
+ git config submodule.proton-templates.url data/templates
+ git submodule update
+}
+
build() {
cd "${_gitname}/"
meson . _build --prefix=/usr