summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStelios Tsampas2019-12-16 21:33:47 +0200
committerStelios Tsampas2019-12-16 21:33:47 +0200
commit35b4d519216df3115672c2cb146b0dfd56b1be04 (patch)
treed6529a3071a5a97c9091f793d2536215ea6cbab2
parent46cefcd73649e69fff86f2f43a19c473fbd0e1c5 (diff)
downloadaur-35b4d519216df3115672c2cb146b0dfd56b1be04.tar.gz
Adjust for and require dxvk v1.5
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD22
2 files changed, 11 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3205ec8a1ca0..2574ffabbedc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = proton-native
pkgdesc = Compatibility tool for Steam Play based on Wine and additional components. Monolithic distribution
pkgver = 4.11.10
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/ValveSoftware/Proton
arch = x86_64
license = GPL
@@ -96,8 +96,7 @@ pkgbase = proton-native
makedepends = steam-native-runtime
makedepends = wine_gecko=2.47
makedepends = wine-mono-bin=4.9.4
- makedepends = dxvk
- makedepends = d9vk
+ makedepends = dxvk>=1.5
depends = fontconfig
depends = lib32-fontconfig
depends = lcms2
@@ -131,8 +130,7 @@ pkgbase = proton-native
depends = steam-native-runtime
depends = wine_gecko=2.47
depends = wine-mono-bin=4.9.4
- depends = dxvk
- depends = d9vk
+ depends = dxvk>=1.5
optdepends = giflib
optdepends = lib32-giflib
optdepends = libpng
@@ -195,7 +193,7 @@ pkgbase = proton-native
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
- sha256sums = SKIP
+ sha256sums = d2ac28b6a409b2f8ae93b9d27ba462bb0823a22852bc9cf9c72f3f90caf17efd
sha256sums = 7418f1ceca081e1b68d933ea6dd5da0351c7cc26e41667e3b3bc49c030504782
pkgname = proton-native
diff --git a/PKGBUILD b/PKGBUILD
index c2224da6c347..30595d154843 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,8 @@ _pkgver=4.11-10
pkgver=${_pkgver//-/.}
_geckover=2.47
_monover=4.9.4
-pkgrel=1
+_dxvkver=1.5
+pkgrel=2
pkgdesc="Compatibility tool for Steam Play based on Wine and additional components. Monolithic distribution"
arch=(x86_64)
url="https://github.com/ValveSoftware/Proton"
@@ -28,10 +29,9 @@ depends=(
desktop-file-utils
python
steam-native-runtime
- wine_gecko=$_geckover
- wine-mono-bin=$_monover
- dxvk
- d9vk
+ "wine_gecko=$_geckover"
+ "wine-mono-bin=$_monover"
+ "dxvk>=$_dxvkver"
)
makedepends=(autoconf ncurses bison perl fontforge flex
'gcc>=4.5.0-2'
@@ -120,7 +120,7 @@ sha256sums=(
SKIP
SKIP
SKIP
- SKIP #'956ad6f7f734254f4860b69024c8ec6e0669a2c34fba48dc1afad75f3e6514df'
+ 'd2ac28b6a409b2f8ae93b9d27ba462bb0823a22852bc9cf9c72f3f90caf17efd'
'7418f1ceca081e1b68d933ea6dd5da0351c7cc26e41667e3b3bc49c030504782'
)
@@ -191,19 +191,11 @@ package() {
ln -s /usr/share/wine/mono "$pkgdir/usr/share/steam/compatibilitytools.d/${pkgname%-git}"/dist/share/wine/mono
ln -s /usr/share/wine/gecko "$pkgdir/usr/share/steam/compatibilitytools.d/${pkgname%-git}"/dist/share/wine/gecko
- for i in d3d10_1.dll d3d10core.dll d3d10.dll d3d11.dll dxgi.dll
+ for i in d3d9.dll d3d10_1.dll d3d10core.dll d3d10.dll d3d11.dll dxgi.dll
do
ln -s "/usr/share/dxvk/x32/$i" \
"$pkgdir/usr/share/steam/compatibilitytools.d/${pkgname%-git}"/dist/lib/wine/dxvk/
ln -s "/usr/share/dxvk/x64/$i" \
"$pkgdir/usr/share/steam/compatibilitytools.d/${pkgname%-git}"/dist/lib64/wine/dxvk/
done
-
- for i in d3d9.dll
- do
- ln -s "/usr/share/d9vk/x32/$i" \
- "$pkgdir/usr/share/steam/compatibilitytools.d/${pkgname%-git}"/dist/lib/wine/dxvk/
- ln -s "/usr/share/d9vk/x64/$i" \
- "$pkgdir/usr/share/steam/compatibilitytools.d/${pkgname%-git}"/dist/lib64/wine/dxvk/
- done
}