summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStelios Tsampas2020-11-20 01:33:48 +0200
committerStelios Tsampas2020-11-20 01:33:48 +0200
commit6c84753c493c259c9a676b4b5b87c7d25e35c7b2 (patch)
treecd39d875500eb326f40a9921b38a21aaa419cbcb
parented1728461b3bf82c70b3be35a66d46dab6ea16b7 (diff)
downloadaur-6c84753c493c259c9a676b4b5b87c7d25e35c7b2.tar.gz
Disable wine's built-in vkd3d
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD4
-rw-r--r--proton-unfuck_makefile.patch16
3 files changed, 17 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f3f95815bed5..85f319301d94 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = proton-native
pkgdesc = Compatibility tool for Steam Play based on Wine and additional components. Monolithic distribution
pkgver = 5.13.2
- pkgrel = 3
+ pkgrel = 4
epoch = 1
url = https://github.com/ValveSoftware/Proton
arch = x86_64
@@ -103,7 +103,8 @@ pkgbase = proton-native
makedepends = desktop-file-utils
makedepends = python
makedepends = steam-native-runtime
- makedepends = wine-gecko-bin>=2.47.1
+ makedepends = wine-gecko-bin=2.47.1
+ makedepends = wine-mono-bin=5.1.1
depends = fontconfig
depends = lib32-fontconfig
depends = lcms2
@@ -137,7 +138,8 @@ pkgbase = proton-native
depends = desktop-file-utils
depends = python
depends = steam-native-runtime
- depends = wine-gecko-bin>=2.47.1
+ depends = wine-gecko-bin=2.47.1
+ depends = wine-mono-bin=5.1.1
optdepends = giflib
optdepends = lib32-giflib
optdepends = libpng
@@ -209,7 +211,7 @@ pkgbase = proton-native
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
- sha256sums = 37ca48c0b64b94155e0af1ae06921e120db05817f3dcb6c44d4c55c03a28d595
+ sha256sums = a112c6a16d8a53a6be4719d44b91a017170a26c328176dbab6c926ffccb442c6
sha256sums = 8263a3ffb7f8e7a5d81bfbffe1843d6f84502d3443fe40f065bcae02b36ba954
sha256sums = 20f7cd3e70fad6f48d2f1a26a485906a36acf30903bf0eefbf82a7c400e248f3
sha256sums = bc17f1ef1e246db44c0fa3874290ad0a5852b0b3fe75902b39834913e3811d98
diff --git a/PKGBUILD b/PKGBUILD
index da39cc9a4c7b..1f5d4705f941 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ _commit=
pkgver=${_srctag//-/.}
_geckover=2.47.1
_monover=5.1.1
-pkgrel=3
+pkgrel=4
epoch=1
pkgdesc="Compatibility tool for Steam Play based on Wine and additional components. Monolithic distribution"
arch=(x86_64)
@@ -270,7 +270,7 @@ sha256sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
- '37ca48c0b64b94155e0af1ae06921e120db05817f3dcb6c44d4c55c03a28d595'
+ 'a112c6a16d8a53a6be4719d44b91a017170a26c328176dbab6c926ffccb442c6'
'8263a3ffb7f8e7a5d81bfbffe1843d6f84502d3443fe40f065bcae02b36ba954'
'20f7cd3e70fad6f48d2f1a26a485906a36acf30903bf0eefbf82a7c400e248f3'
'bc17f1ef1e246db44c0fa3874290ad0a5852b0b3fe75902b39834913e3811d98'
diff --git a/proton-unfuck_makefile.patch b/proton-unfuck_makefile.patch
index 7e4c003e70bf..b0f0c3fe51a7 100644
--- a/proton-unfuck_makefile.patch
+++ b/proton-unfuck_makefile.patch
@@ -1,5 +1,5 @@
diff --git a/build/makefile_base.mak b/build/makefile_base.mak
-index 6acce47..1ad6278 100644
+index 6acce47..22aeab4 100644
--- a/build/makefile_base.mak
+++ b/build/makefile_base.mak
@@ -68,7 +68,7 @@ endif
@@ -196,7 +196,7 @@ index 6acce47..1ad6278 100644
cmake $(abspath $(FAUDIO)) \
-DCMAKE_INSTALL_PREFIX="$(abspath $(TOOLS_DIR32))" \
$(FAUDIO_CMAKE_FLAGS)
-@@ -1132,7 +1151,12 @@ $(WINE_CONFIGURE_FILES64): SHELL = $(CONTAINER_SHELL64)
+@@ -1132,7 +1151,13 @@ $(WINE_CONFIGURE_FILES64): SHELL = $(CONTAINER_SHELL64)
$(WINE_CONFIGURE_FILES64): $(MAKEFILE_DEP) | faudio64 jxrlib64 gst_base64 $(WINE_OBJ64)
cd $(dir $@) && \
../$(WINE)/configure \
@@ -204,12 +204,13 @@ index 6acce47..1ad6278 100644
+ --with-gstreamer \
+ --with-faudio \
--without-curses \
++ --without-vkd3d \
+ --without-oss \
+ --disable-win16 \
--enable-win64 \
--disable-tests \
--prefix=$(abspath $(DST_DIR)) \
-@@ -1152,7 +1176,12 @@ $(WINE_CONFIGURE_FILES32): SHELL = $(CONTAINER_SHELL32)
+@@ -1152,7 +1177,13 @@ $(WINE_CONFIGURE_FILES32): SHELL = $(CONTAINER_SHELL32)
$(WINE_CONFIGURE_FILES32): $(MAKEFILE_DEP) | faudio32 jxrlib32 gst_base32 $(WINE_OBJ32)
cd $(dir $@) && \
../$(WINE)/configure \
@@ -217,12 +218,13 @@ index 6acce47..1ad6278 100644
+ --with-gstreamer \
+ --with-faudio \
--without-curses \
++ --without-vkd3d \
+ --without-oss \
+ --disable-win16 \
--disable-tests \
--prefix=$(abspath $(WINE_DST32)) \
LD_LIBRARY_PATH=$(abspath $(TOOLS_DIR32))/lib \
-@@ -1356,7 +1385,7 @@ dxvk_configure32: $(DXVK_CONFIGURE_FILES32)
+@@ -1356,7 +1387,7 @@ dxvk_configure32: $(DXVK_CONFIGURE_FILES32)
dxvk: dxvk32 dxvk64
dxvk64: $(DXVK_CONFIGURE_FILES64)
@@ -231,7 +233,7 @@ index 6acce47..1ad6278 100644
mkdir -p "$(DST_DIR)/lib64/wine/dxvk"
cp -f "$(DXVK_OBJ64)"/bin/dxgi.dll "$(DST_DIR)"/lib64/wine/dxvk
cp -f "$(DXVK_OBJ64)"/bin/d3d11.dll "$(DST_DIR)"/lib64/wine/dxvk
-@@ -1369,7 +1398,7 @@ dxvk64: $(DXVK_CONFIGURE_FILES64)
+@@ -1369,7 +1400,7 @@ dxvk64: $(DXVK_CONFIGURE_FILES64)
dxvk32: $(DXVK_CONFIGURE_FILES32)
@@ -240,7 +242,7 @@ index 6acce47..1ad6278 100644
mkdir -p "$(DST_DIR)"/lib/wine/dxvk
cp -f "$(DXVK_OBJ32)"/bin/dxgi.dll "$(DST_DIR)"/lib/wine/dxvk/
cp -f "$(DXVK_OBJ32)"/bin/d3d11.dll "$(DST_DIR)"/lib/wine/dxvk/
-@@ -1399,7 +1428,7 @@ $(VKD3D_CONFIGURE_FILES32): $(VKD3D)/meson.build $(VKD3D)/build-win32.txt | $(VK
+@@ -1399,7 +1430,7 @@ $(VKD3D_CONFIGURE_FILES32): $(VKD3D)/meson.build $(VKD3D)/build-win32.txt | $(VK
vkd3d32: SHELL = $(CONTAINER_SHELL32)
vkd3d32: $(VKD3D_CONFIGURE_FILES32)
@@ -249,7 +251,7 @@ index 6acce47..1ad6278 100644
mkdir -p "$(DST_DIR)"/lib/wine/vkd3d-proton
cp -af "$(VKD3D_OBJ32)/bin/d3d12.dll" "$(DST_DIR)"/lib/wine/vkd3d-proton/
rm -f "$(DST_DIR)"/lib/wine/vkd3d-proton/version && if test -e $(SRCDIR)/.git; then ( cd $(SRCDIR) && git submodule status -- vkd3d-proton ) > "$(DST_DIR)"/lib/wine/vkd3d-proton/version; fi
-@@ -1416,7 +1445,7 @@ $(VKD3D_CONFIGURE_FILES64): $(VKD3D)/meson.build $(VKD3D)/build-win64.txt | $(VK
+@@ -1416,7 +1447,7 @@ $(VKD3D_CONFIGURE_FILES64): $(VKD3D)/meson.build $(VKD3D)/build-win64.txt | $(VK
vkd3d64: SHELL = $(CONTAINER_SHELL64)
vkd3d64: $(VKD3D_CONFIGURE_FILES64)