summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStelios Tsampas2021-08-11 21:23:18 +0300
committerStelios Tsampas2021-08-11 21:23:18 +0300
commit77095a8d452865f4af58fafbdef0e80a875559c0 (patch)
tree2e2d9e12592fbfe503c89d0cb7447f288078bba7
parenta0254ac378513bf9a812b69b6603210810ffae56 (diff)
downloadaur-77095a8d452865f4af58fafbdef0e80a875559c0.tar.gz
Fix d3d12.dll static linking
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--proton-unfuck_makefile.patch37
3 files changed, 23 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2c0f0fc3b366..263040549c35 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = proton-native
pkgdesc = Compatibility tool for Steam Play based on Wine and additional components. Monolithic distribution
pkgver = 6.3.5
- pkgrel = 1
+ pkgrel = 2
epoch = 1
url = https://github.com/ValveSoftware/Proton
arch = x86_64
@@ -237,7 +237,7 @@ pkgbase = proton-native
sha256sums = 8fab46ea2110b2b0beed414e3ebb4e038a3da04900e7a28492ca3c3ccf9fea94
sha256sums = b4476706a4c3f23461da98bed34f355ff623c5d2bb2da1e2fa0c6a310bc33014
sha256sums = 463efcae9aec82e2ae51adbafe542f2a0674e1a1d0899d732077211f5c62d182
- sha256sums = 2473fc498d9727c4ed4fc77ca703077d2e081225548d1c8086690e0f62ba1f13
+ sha256sums = 812b2b73bc7b6a88de480f6410970c2454866bb123c3baefd990679c9dd3ef98
sha256sums = 8263a3ffb7f8e7a5d81bfbffe1843d6f84502d3443fe40f065bcae02b36ba954
sha256sums = 20f7cd3e70fad6f48d2f1a26a485906a36acf30903bf0eefbf82a7c400e248f3
sha256sums = 36aaba6847e4577df4a496d88c11b4b7049773f1f2b90aa4545093e16d5c6066
diff --git a/PKGBUILD b/PKGBUILD
index a6f525fa0d99..eb14e125a137 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ _commit=
pkgver=${_srctag//-/.}
_geckover=2.47.2
_monover=6.1.2
-pkgrel=1
+pkgrel=2
epoch=1
pkgdesc="Compatibility tool for Steam Play based on Wine and additional components. Monolithic distribution"
url="https://github.com/ValveSoftware/Proton"
@@ -298,7 +298,7 @@ sha256sums=('SKIP'
'8fab46ea2110b2b0beed414e3ebb4e038a3da04900e7a28492ca3c3ccf9fea94'
'b4476706a4c3f23461da98bed34f355ff623c5d2bb2da1e2fa0c6a310bc33014'
'463efcae9aec82e2ae51adbafe542f2a0674e1a1d0899d732077211f5c62d182'
- '2473fc498d9727c4ed4fc77ca703077d2e081225548d1c8086690e0f62ba1f13'
+ '812b2b73bc7b6a88de480f6410970c2454866bb123c3baefd990679c9dd3ef98'
'8263a3ffb7f8e7a5d81bfbffe1843d6f84502d3443fe40f065bcae02b36ba954'
'20f7cd3e70fad6f48d2f1a26a485906a36acf30903bf0eefbf82a7c400e248f3'
'36aaba6847e4577df4a496d88c11b4b7049773f1f2b90aa4545093e16d5c6066'
diff --git a/proton-unfuck_makefile.patch b/proton-unfuck_makefile.patch
index e41a1b174d7a..d89db9d92baa 100644
--- a/proton-unfuck_makefile.patch
+++ b/proton-unfuck_makefile.patch
@@ -1,5 +1,5 @@
diff --git a/build/makefile_base.mak b/build/makefile_base.mak
-index c9f14bc..a6637c5 100644
+index c9f14bc..b5d8063 100644
--- a/build/makefile_base.mak
+++ b/build/makefile_base.mak
@@ -60,7 +60,6 @@ ifeq ($(ENABLE_CCACHE),1)
@@ -31,16 +31,17 @@ index c9f14bc..a6637c5 100644
rm -rf $(abspath $(DIST_PREFIX))
python3 $(SRCDIR)/default_pfx.py $(abspath $(DIST_PREFIX)) $(abspath $(DST_DIR)) $(STEAM_RUNTIME_RUNSH)
-@@ -404,6 +404,8 @@ endif # ifeq ($(CONTAINER),)
+@@ -404,6 +404,9 @@ endif # ifeq ($(CONTAINER),)
##
GST_COMMON_MESON_ARGS := \
+ -Db_lto=true \
+ -Db_pie=true \
++ -Ddoc=disabled \
-Dexamples=disabled \
-Dtests=disabled \
-Dgtk_doc=disabled \
-@@ -416,6 +418,7 @@ GST_COMMON_MESON_ARGS := \
+@@ -416,6 +419,7 @@ GST_COMMON_MESON_ARGS := \
GST_ORC_MESON_ARGS := \
-Dorc-test=disabled \
@@ -48,7 +49,7 @@ index c9f14bc..a6637c5 100644
$(GST_COMMON_MESON_ARGS)
$(eval $(call rules-source,gst_orc,$(SRCDIR)/gst-orc))
-@@ -432,6 +435,9 @@ GSTREAMER_MESON_ARGS := \
+@@ -432,6 +436,9 @@ GSTREAMER_MESON_ARGS := \
-Dbenchmarks=disabled \
-Dtools=disabled \
-Dbash-completion=disabled \
@@ -58,7 +59,7 @@ index c9f14bc..a6637c5 100644
$(GST_COMMON_MESON_ARGS)
GSTREAMER_DEPENDS = gst_orc
-@@ -470,6 +476,7 @@ GST_BASE_MESON_ARGS := \
+@@ -470,6 +477,7 @@ GST_BASE_MESON_ARGS := \
-Dxshm=disabled \
-Dxvideo=disabled \
-Dtools=disabled \
@@ -66,7 +67,7 @@ index c9f14bc..a6637c5 100644
$(GST_COMMON_MESON_ARGS)
GST_BASE_DEPENDS = gst_orc gstreamer
-@@ -531,6 +538,7 @@ GST_GOOD_MESON_ARGS := \
+@@ -531,6 +539,7 @@ GST_GOOD_MESON_ARGS := \
-Dximagesrc=disabled \
-Dy4m=disabled \
-Dtools=disabled \
@@ -74,7 +75,7 @@ index c9f14bc..a6637c5 100644
$(GST_COMMON_MESON_ARGS)
GST_GOOD_DEPENDS = gst_orc gstreamer gst_base
-@@ -651,8 +659,14 @@ WINE_SOURCE_ARGS = \
+@@ -651,8 +660,14 @@ WINE_SOURCE_ARGS = \
--exclude include/config.h.in \
WINE_CONFIGURE_ARGS = \
@@ -89,7 +90,7 @@ index c9f14bc..a6637c5 100644
--disable-tests
WINE_CONFIGURE_ARGS64 = --enable-win64
-@@ -745,7 +759,7 @@ VKD3D_PROTON_SOURCE_ARGS = \
+@@ -745,7 +760,7 @@ VKD3D_PROTON_SOURCE_ARGS = \
--exclude vkd3d_build.h.in \
--exclude vkd3d_version.h.in \
@@ -192,19 +193,19 @@ index 916df8b..044f705 100644
LD_LIBRARY_PATH="$$(call list-join,:,$$(foreach d,$$($(2)_DEPS$(3)),$$($$(d)_LIBDIR$(3))),,:)$$$$LD_LIBRARY_PATH" \
PKG_CONFIG_PATH="$$(call list-join,:,$$(foreach d,$$($(2)_DEPS$(3)),$$($$(d)_LIBDIR$(3))/pkgconfig))" \
diff --git a/make/rules-meson.mk b/make/rules-meson.mk
-index 7b982fa..d91bf87 100644
+index 7b982fa..8e08128 100644
--- a/make/rules-meson.mk
+++ b/make/rules-meson.mk
-@@ -14,14 +14,15 @@ $$(OBJ)/.$(1)-configure$(3): $$($(2)_SRC)/meson.build
- grep -s -v -e c_args -e cpp_args -e link_args "$$($(2)_SRC)/build-win$(3).txt" | \
+@@ -11,7 +11,7 @@ $$(OBJ)/.$(1)-configure$(3): $$($(2)_SRC)/meson.build
+ @echo ":: configuring $(3)bit $(1)..." >&2
+ rm -rf "$$($(2)_OBJ$(3))/meson-private/coredata.dat"
+
+- grep -s -v -e c_args -e cpp_args -e link_args "$$($(2)_SRC)/build-win$(3).txt" | \
++ grep -s -v -e c_args -e cpp_args "$$($(2)_SRC)/build-win$(3).txt" | \
sed -e "s:\[properties\]:[properties]\nc_args = [$$(call list-quote,$$(COMMON_FLAGS))]:" \
-e "s:\[properties\]:[properties]\ncpp_args = [$$(call list-quote,$$(COMMON_FLAGS))]:" \
-- -e "s:\[properties\]:[properties]\nlink_args = [$$(call list-quote,$$(CROSSLDFLAGS))]:" \
-+ -e "s:\[properties\]:[properties]\nc_link_args = [$$(call list-quote,$$(LDFLAGS) $$(CROSSLDFLAGS))]:" \
-+ -e "s:\[properties\]:[properties]\ncpp_link_args = [$$(call list-quote,$$(LDFLAGS) $$(CROSSLDFLAGS))]:" \
- > "$$($(2)_OBJ$(3))/build-win$(3).txt"
-
- env $$($(2)_ENV$(3)) \
+ -e "s:\[properties\]:[properties]\nlink_args = [$$(call list-quote,$$(CROSSLDFLAGS))]:" \
+@@ -21,7 +21,7 @@ $$(OBJ)/.$(1)-configure$(3): $$($(2)_SRC)/meson.build
meson "$$($(2)_OBJ$(3))" "$$($(2)_SRC)" \
--prefix="$$($(2)_DST$(3))" \
--libdir="lib$(subst 32,,$(3))" \
@@ -213,7 +214,7 @@ index 7b982fa..d91bf87 100644
$$($(2)_MESON_ARGS) \
$$($(2)_MESON_ARGS$(3)) \
$$(MESON_STRIP_ARG)
-@@ -31,7 +32,7 @@ $$(OBJ)/.$(1)-configure$(3): $$($(2)_SRC)/meson.build
+@@ -31,7 +31,7 @@ $$(OBJ)/.$(1)-configure$(3): $$($(2)_SRC)/meson.build
$$(OBJ)/.$(1)-build$(3):
@echo ":: building $(3)bit $(1)..." >&2
env $$($(2)_ENV$(3)) \