summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStelios Tsampas2020-03-23 23:50:45 +0200
committerStelios Tsampas2020-03-23 23:50:45 +0200
commit9a2082c748b40dee0957a97abff2f0ed35008568 (patch)
treeaa8a8cece0ed7aef38af9426506f19e25a10aa0e
parent2a0836cb0d31e303a3617a69da56bef44f37a389 (diff)
downloadaur-9a2082c748b40dee0957a97abff2f0ed35008568.tar.gz
version 5.0.5b
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
-rw-r--r--proton-user_compat_data.patch20
3 files changed, 18 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 86a934e125b6..a8e189cab320 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = proton-native
pkgdesc = Compatibility tool for Steam Play based on Wine and additional components. Monolithic distribution
pkgver = 5.0.5
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/ValveSoftware/Proton
arch = x86_64
license = custom
@@ -170,7 +170,7 @@ pkgbase = proton-native
optdepends = cups
optdepends = samba
optdepends = dosbox
- source = proton::git+https://github.com/ValveSoftware/Proton.git#tag=proton-5.0-5
+ source = proton::git+https://github.com/ValveSoftware/Proton.git#tag=proton-5.0-5b
source = wine-valve::git+https://github.com/ValveSoftware/wine.git
source = vkd3d-valve::git+https://github.com/ValveSoftware/vkd3d.git
source = dxvk-valve::git+https://github.com/ValveSoftware/dxvk.git
@@ -196,7 +196,7 @@ pkgbase = proton-native
sha256sums = SKIP
sha256sums = b9e8443c3f1949cc8b0d311594aa46cbfb79da48c3f00e95c97e87656368dd49
sha256sums = f12df8e1e2dcb6bcced6fdccfdf044b2dc55714712efd577fd5d92abfad0f5c5
- sha256sums = 375015b1582e3c606122d4dd6dc9919f6df1ca7223855908600e1e8fae762c51
+ sha256sums = 20f7cd3e70fad6f48d2f1a26a485906a36acf30903bf0eefbf82a7c400e248f3
sha256sums = 15fc8d8a4465ffc69897f0264ecb08d95f4b0fb00ec45dc8cb542f14c8808ef3
pkgname = proton-native
diff --git a/PKGBUILD b/PKGBUILD
index f8a94300f2ea..8b47c99f3992 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,11 +2,11 @@
pkgname=proton-native
pkgver=5.0.5
-_srctag=${pkgver%.*}-${pkgver##*.}
+_srctag=${pkgver%.*}-${pkgver##*.}b
_geckover=2.47.1
_monover=4.9.4
#_dxvkver=1.5
-pkgrel=1
+pkgrel=2
pkgdesc="Compatibility tool for Steam Play based on Wine and additional components. Monolithic distribution"
arch=(x86_64)
url="https://github.com/ValveSoftware/Proton"
@@ -134,7 +134,7 @@ sha256sums=(
# SKIP
'b9e8443c3f1949cc8b0d311594aa46cbfb79da48c3f00e95c97e87656368dd49'
'f12df8e1e2dcb6bcced6fdccfdf044b2dc55714712efd577fd5d92abfad0f5c5'
- '375015b1582e3c606122d4dd6dc9919f6df1ca7223855908600e1e8fae762c51'
+ '20f7cd3e70fad6f48d2f1a26a485906a36acf30903bf0eefbf82a7c400e248f3'
'15fc8d8a4465ffc69897f0264ecb08d95f4b0fb00ec45dc8cb542f14c8808ef3'
)
diff --git a/proton-user_compat_data.patch b/proton-user_compat_data.patch
index 996bdc6b86c9..e9d6e18c910b 100644
--- a/proton-user_compat_data.patch
+++ b/proton-user_compat_data.patch
@@ -1,16 +1,20 @@
diff --git a/proton b/proton
-index 59b2b0c..8a797e9 100755
+index d4a49ab..9928e21 100755
--- a/proton
+++ b/proton
-@@ -633,6 +633,11 @@ class Session:
-
+@@ -656,6 +656,15 @@ if __name__ == "__main__":
+ log("No compat data path?")
+ sys.exit(1)
- if __name__ == "__main__":
+ if "PROTON_USER_COMPAT_DATA" in os.environ:
+ if nonzero(os.environ["PROTON_USER_COMPAT_DATA"]):
-+ os.environ["STEAM_COMPAT_DATA_PATH"] = os.environ["STEAM_COMPAT_CLIENT_INSTALL_PATH"] + "/steamapps/compatdata/" + os.environ["SteamGameId"]
++ compatpath = os.environ["STEAM_COMPAT_DATA_PATH"].split('/')
++ os.environ["STEAM_COMPAT_DATA_PATH"] = "{}/{}/{}/{}".format(
++ os.environ["STEAM_COMPAT_CLIENT_INSTALL_PATH"],
++ compatpath[-3], compatpath[-2], compatpath[-1])
+ if not os.path.exists(os.environ["STEAM_COMPAT_DATA_PATH"]):
+ os.makedirs(os.environ["STEAM_COMPAT_DATA_PATH"])
- if not "STEAM_COMPAT_DATA_PATH" in os.environ:
- log("No compat data path?")
- sys.exit(1)
++
+ g_proton = Proton(os.path.dirname(sys.argv[0]))
+
+ g_proton.extract_tarball()