summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGiacomo Vercesi2020-04-14 07:46:56 +0200
committerGiacomo Vercesi2020-04-14 07:46:56 +0200
commit11724a1e02ef6ccc7e7a72b0d3556d88504e65e6 (patch)
tree8ab0a1ed40ad258371da9f9b16a0469ca2c43788
parentb7fb09b8b8094ed3f11ec35faf2a5f64387f5be4 (diff)
downloadaur-11724a1e02ef6ccc7e7a72b0d3556d88504e65e6.tar.gz
PKGBUILD fixup
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD19
2 files changed, 18 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 621853bc35f0..f65103a097d3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,18 @@
pkgbase = protonfixes-git
- pkgdesc = A module for applying fixes at runtime to unsupported games with Steam Proton without changing game installation files
- pkgver = r167.bf49d41
- pkgrel = 2
+ pkgdesc = A module for applying fixes at runtime to unsupported games with Steam Proton without changing game installation files - git version
+ pkgver = r241.203b4c2
+ pkgrel = 1
url = https://github.com/simons-public/protonfixes
arch = any
license = BSD
+ makedepends = git
makedepends = python-setuptools
optdepends = wine: win32 proton prefix support
optdepends = winetricks: winetricks support
- optdepends = cefpython3: splash dialog support
- optdepends = zenity: splash dialog support
+ optdepends = python-cef: splash progress dialog - deprecated
+ optdepends = python-kivy: splash progress dialog
+ optdepends = kdialog: splash progress dialog
+ optdepends = zenity: splash progress dialog
source = protonfixes-git::git+https://github.com/simons-public/protonfixes#branch=master
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index c4a6f318b550..ca1fd91610b4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,20 @@
-# Maintainer: Chris Simons < chris at simonsmail dot net >
+# Maintainer: Giacomo Vercesi <mrjackv@hotmail.it>
+# Contributor: Chris Simons < chris at simonsmail dot net >
pkgname=("protonfixes-git")
-pkgver=r167.bf49d41
-pkgrel=2
-pkgdesc="A module for applying fixes at runtime to unsupported games with Steam Proton without changing game installation files"
+pkgver=r241.203b4c2
+pkgrel=1
+pkgdesc="A module for applying fixes at runtime to unsupported games with Steam Proton without changing game installation files - git version"
arch=("any")
url="https://github.com/simons-public/protonfixes"
license=("BSD")
-makedepends=("python-setuptools")
+makedepends=("git" "python-setuptools")
optdepends=('wine: win32 proton prefix support'
'winetricks: winetricks support'
- 'cefpython3: splash dialog support'
- 'zenity: splash dialog support')
+ 'python-cef: splash progress dialog - deprecated'
+ 'python-kivy: splash progress dialog'
+ 'kdialog: splash progress dialog'
+ 'zenity: splash progress dialog')
source=("${pkgname}::git+https://github.com/simons-public/protonfixes#branch=master")
md5sums=('SKIP')
@@ -28,6 +31,4 @@ build() {
package() {
cd "${srcdir}/${pkgname}"
python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
- mv ${pkgdir}/usr/static ${pkgdir}/usr/lib/python*/site-packages/protonfixes/
- rm -r ${pkgdir}/usr/lib/python*/site-packages/tests
}