summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrederik “Freso” S. Olesen2022-10-15 18:38:36 +0200
committerFrederik “Freso” S. Olesen2022-10-15 18:38:36 +0200
commit14c5395248c96ee17627740136e68be8e2f6a4df (patch)
tree7d8e22ea08e794594e8dbc55215b0c1943ea4bb9
parent464b1c3b8627257fe0932838203dad9f363181db (diff)
downloadaur-14c5395248c96ee17627740136e68be8e2f6a4df.tar.gz
Turn PKGBUILD into non-VCS version
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD10
2 files changed, 9 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 487d4d9c819a..355a9a5a69b0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -6,7 +6,8 @@ pkgbase = protonhax
arch = x86_64
license = BSD
makedepends = tcc
- source = git+https://github.com/jcnils/protonhax.git
- md5sums = SKIP
+ conflicts = protonhax-git
+ source = protonhax-1.0.4.tar.gz::https://github.com/jcnils/protonhax/archive/refs/tags/1.0.4.tar.gz
+ sha256sums = da4104a16265a4cf482510d41d7c2ad02679ff3f6b70b2a2675958af08f72a49
pkgname = protonhax
diff --git a/PKGBUILD b/PKGBUILD
index 93351e83cbfe..47dfd4992913 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,22 +2,24 @@
# Contributor: Xaryphon <xaryphon at tuta dot io>
pkgname=protonhax
pkgver=1.0.4
+_pkgfile=$pkgname-$pkgver
pkgrel=1
pkgdesc="Program to help executing outside programs in proton"
arch=('x86_64')
url="https://github.com/jcnils/protonhax"
license=('BSD')
makedepends=('tcc')
-source=('git+https://github.com/jcnils/protonhax.git')
-md5sums=('SKIP')
+conflicts=("$pkgname-git")
+source=("$_pkgfile.tar.gz"::"https://github.com/jcnils/$pkgname/archive/refs/tags/$pkgver.tar.gz")
+sha256sums=('da4104a16265a4cf482510d41d7c2ad02679ff3f6b70b2a2675958af08f72a49')
build() {
- cd $pkgname
+ cd $_pkgfile
make
}
package() {
- cd $pkgname
+ cd $_pkgfile
install -d -m755 $pkgdir/usr/share/licenses/$pkgname
install -m644 LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE