summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkausban2020-04-21 16:24:43 +0200
committerkausban2020-04-21 16:24:43 +0200
commit9ae99d34b5b75d67ee559f1853367d12b7e3c35c (patch)
treee06b8bc90cb9a577bd33d6a122da27f22d571dde
parent31f1ee9b63ccc43a46b138e13cb11f2b97dff08a (diff)
downloadaur-9ae99d34b5b75d67ee559f1853367d12b7e3c35c.tar.gz
noninteractive bridge.service. Removed screen as dependency.
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD16
-rw-r--r--bridge.service8
3 files changed, 19 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4bf679576bd4..0f2a63e78977 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,13 @@
pkgbase = protonmail-bridge-nogui
pkgdesc = Integrate ProtonMail paid account with any program that supports IMAP and SMTP
pkgver = 1.2.6
- pkgrel = 3
+ pkgrel = 4
url = https://www.protonmail.com/bridge
arch = x86_64
license = GPL3
makedepends = go
makedepends = gcc
depends = libsecret
- depends = screen
optdepends = gnome-keyring: supported password manager (password manager is required)
optdepends = pass: supported password manager (password manager is required)
conflicts = protonmail-bridge-bin
@@ -18,7 +17,7 @@ pkgbase = protonmail-bridge-nogui
source = git://github.com/ProtonMail/proton-bridge.git
source = bridge.service
sha256sums = SKIP
- sha256sums = 07cc30765dd43307a995ac4f3aed5dee4d6af7e2bc32a21a1201d888a39603c0
+ sha256sums = 6b2fd1e042b55dc6d0ffe5eb44e82ffd233452b4571ef571132600e7ec0d5d82
pkgname = protonmail-bridge-nogui
diff --git a/PKGBUILD b/PKGBUILD
index cca9b339bae5..b3b3ee523824 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,18 +6,24 @@
# Minimal fork of https://aur.archlinux.org/packages/protonmail-bridge/
# Compiled with 'nogui' option
# Included is a user systemd service. Try: systemctl status --user bridge.service
-# You can login and register accounts using the interactive cli
-# Named screen session accessible as: screen -R -S bridgedaemon
+# You can login and register accounts using the interactive cli: protonmail-bridge --cli
+# Once you have everything configured and automated. You can enable and use bridge.service to run bridge in background.
+
+# The following is an alternative way to run the bridge in interactive cli mode encapsulated within a named screen session.
+# Can be added to bridge.service
+# ExecStart=/usr/bin/screen -Dm -S bridgedaemon sh -c "sleep 5; protonmail-bridge -c"
+# ExecStop=/usr/bin/screen -X -S bridgedaemon quit
+
pkgname=protonmail-bridge-nogui
pkgver=1.2.6
-pkgrel=3
+pkgrel=4
pkgdesc="Integrate ProtonMail paid account with any program that supports IMAP and SMTP"
arch=('x86_64')
url="https://www.protonmail.com/bridge"
license=('GPL3')
makedepends=('go' 'gcc')
-depends=('libsecret' 'screen')
+depends=('libsecret')
optdepends=(
'gnome-keyring: supported password manager (password manager is required)'
'pass: supported password manager (password manager is required)'
@@ -27,7 +33,7 @@ options=('!emptydirs' '!strip')
source=("git://github.com/ProtonMail/proton-bridge.git"
"bridge.service")
sha256sums=('SKIP'
- '07cc30765dd43307a995ac4f3aed5dee4d6af7e2bc32a21a1201d888a39603c0')
+ '6b2fd1e042b55dc6d0ffe5eb44e82ffd233452b4571ef571132600e7ec0d5d82')
prepare() {
cd "${srcdir}"/proton-bridge/
diff --git a/bridge.service b/bridge.service
index 66f9bcccb530..db395c64c7e9 100644
--- a/bridge.service
+++ b/bridge.service
@@ -3,10 +3,14 @@ Description=Desktop-Bridge: Protonmail Bridge - ProtonMail IMAP and SMTP Bridge
[Service]
Type=simple
-ExecStart=/usr/bin/screen -Dm -S bridgedaemon sh -c "sleep 5; protonmail-bridge -c"
+ExecStart=/usr/bin/protonmail-bridge --noninteractive
Restart=always
-ExecStop=/usr/bin/screen -X -S bridgedaemon quit
KillMode=process
+# The following is an alternative way to run the bridge in interactive cli mode encapsulated within a named screen session.
+# Can be added to bridge.service
+# ExecStart=/usr/bin/screen -Dm -S bridgedaemon sh -c "sleep 5; protonmail-bridge -c"
+# ExecStop=/usr/bin/screen -X -S bridgedaemon quit
+
[Install]
WantedBy=default.target