summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJason Stryker2019-02-04 09:35:57 -0500
committerJason Stryker2019-02-04 09:35:57 -0500
commit0e7ee5d903f95e5425d97d2d64efdb748af2e64f (patch)
tree5ce7f3876568804f1358d6d671293eccfe04e846
downloadaur-0e7ee5d903f95e5425d97d2d64efdb748af2e64f.tar.gz
create package
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD32
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..76617687fb81
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = protontricks
+ pkgdesc = A simple wrapper that does winetricks things for Proton enabled games.
+ pkgver = 1.1.1
+ pkgrel = 1
+ url = https://github.com/Matoking/protontricks
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = python
+ depends = python-vdf>=2.4
+ depends = winetricks
+ optdepends = zenity: GUI for GNOME desktop
+ provides = protontricks
+ conflicts = protontricks-git
+ source = https://github.com/Matoking/protontricks/archive/1.1.1.tar.gz
+ sha512sums = 261e85f4faed20c9daeb539c7b5cfc80bfad20627c937b737c617b9732cc5f62741253adbf1045792160227b29637f2cd9012d409ea4f9af09d4e4497ed4d5d8
+
+pkgname = protontricks
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4fdf70f21bb3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Jason Stryker <public at jasonstryker dot com>
+
+pkgname=protontricks
+pkgver=1.1.1
+pkgrel=1
+pkgdesc="A simple wrapper that does winetricks things for Proton enabled games."
+arch=('any')
+url="https://github.com/Matoking/protontricks"
+license=('GPL3')
+depends=('python' 'python-vdf>=2.4' 'winetricks')
+optdepends=('zenity: GUI for GNOME desktop')
+makedepends=('git')
+provides=("protontricks")
+conflicts=('protontricks-git')
+source=("${url}/archive/${pkgver}.tar.gz")
+sha512sums=('261e85f4faed20c9daeb539c7b5cfc80bfad20627c937b737c617b9732cc5f62741253adbf1045792160227b29637f2cd9012d409ea4f9af09d4e4497ed4d5d8')
+
+build() {
+ cd "${srcdir}/protontricks-${pkgver}"
+
+ python3 setup.py build
+}
+
+package() {
+ cd "${srcdir}/protontricks-${pkgver}"
+
+ python3 setup.py install --root="$pkgdir" --optimize=1 || return 1
+
+ install -D -m 0644 README.md "${pkgdir}/usr/share/doc/${pkgname}/README.md"
+}
+
+# vim:set ts=2 sw=2 et: