summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKonstantin Liberty2023-09-20 19:04:04 +0300
committerKonstantin Liberty2023-09-20 19:04:04 +0300
commitc9b19baa8286064aef29635c78bafa2d3dd624ae (patch)
tree94b937da29a5eacd32c35af20a678b75379ecabc
parent3a83edb80e80251537e2c2d40c7f6cf1645a06f8 (diff)
downloadaur-c9b19baa8286064aef29635c78bafa2d3dd624ae.tar.gz
update to version 1.10.5
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD11
2 files changed, 12 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index de1a70a5bce8..c0ffd606c6eb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,25 @@
pkgbase = protontricks
pkgdesc = A simple wrapper that does winetricks things for Proton enabled games.
- pkgver = 1.10.3
+ pkgver = 1.10.5
pkgrel = 1
url = https://github.com/Matoking/protontricks
arch = any
license = GPL3
makedepends = git
makedepends = python-setuptools-scm
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
depends = python
depends = python-vdf
depends = winetricks
depends = python-setuptools
+ depends = python-pillow
optdepends = yad: GUI for game selection,
optdepends = zenity: GUI for winetricks
provides = protontricks
conflicts = protontricks-git
- source = git+https://github.com/Matoking/protontricks.git#tag=1.10.3
+ source = git+https://github.com/Matoking/protontricks.git#tag=1.10.5
sha512sums = SKIP
pkgname = protontricks
diff --git a/PKGBUILD b/PKGBUILD
index ea153276a05c..fea93a4c6d65 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,19 @@
# Maintainer: Jason Stryker <public at jasonstryker dot com>
+# Maintainer: Konstantin Liberty <jon909 at gmail dot com>
pkgname=protontricks
-pkgver=1.10.3
+pkgver=1.10.5
pkgrel=1
pkgdesc="A simple wrapper that does winetricks things for Proton enabled games."
arch=('any')
url="https://github.com/Matoking/protontricks"
license=('GPL3')
-depends=('python' 'python-vdf' 'winetricks' 'python-setuptools')
+depends=('python' 'python-vdf' 'winetricks' 'python-setuptools' 'python-pillow')
optdepends=(
'yad: GUI for game selection',
'zenity: GUI for winetricks'
)
-makedepends=('git' 'python-setuptools-scm')
+makedepends=('git' 'python-setuptools-scm' 'python-build' 'python-installer' 'python-wheel')
provides=("protontricks")
conflicts=('protontricks-git')
source=("git+${url}.git#tag=${pkgver}")
@@ -21,13 +22,13 @@ sha512sums=('SKIP')
build() {
cd "${srcdir}/${pkgname}"
- python3 setup.py build
+ python -m build --wheel
}
package() {
cd "${srcdir}/${pkgname}"
- python3 setup.py install --root="$pkgdir" --optimize=1 || return 1
+ python -m installer --destdir="$pkgdir" dist/*.whl
install -D -m 0644 README.md "${pkgdir}/usr/share/doc/${pkgname}/README.md"
}