summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2024-02-22 11:32:45 -0700
committerMark Wagie2024-02-22 11:32:45 -0700
commit9d22ff087a1a384ce03b5399e55b34d9a96f26ac (patch)
tree8abb9721ac4a3a4d9c8dc0a0841e669de7eebf69
parentb19faaf4aff694bc69c1717ed1565f70467b8172 (diff)
downloadaur-9d22ff087a1a384ce03b5399e55b34d9a96f26ac.tar.gz
add tests
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD10
2 files changed, 12 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 256e214eef85..13fae8988df5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,12 @@
pkgbase = protontricks-git
pkgdesc = A simple wrapper that does winetricks things for Proton enabled games.
- pkgver = 1.10.5.r11.g68f965f
+ pkgver = 1.11.1.r2.g1dabf82
pkgrel = 1
url = https://github.com/Matoking/protontricks
arch = any
license = GPL-3.0-or-later
+ checkdepends = appstream
+ checkdepends = desktop-file-utils
makedepends = git
makedepends = python-build
makedepends = python-installer
diff --git a/PKGBUILD b/PKGBUILD
index fff44b281f8a..c9fc9a3b7fcc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Mark Wagie <mark dot wagie at proton dot me>
# Contributor: Jason Stryker <public at jasonstryker dot com>
pkgname=protontricks-git
-pkgver=1.10.5.r11.g68f965f
+pkgver=1.11.1.r2.g1dabf82
pkgrel=1
pkgdesc="A simple wrapper that does winetricks things for Proton enabled games."
arch=('any')
@@ -10,6 +10,7 @@ license=('GPL-3.0-or-later')
depends=('python-pillow' 'python-setuptools' 'python-vdf' 'winetricks')
makedepends=('git' 'python-build' 'python-installer' 'python-setuptools-scm'
'python-wheel')
+checkdepends=('appstream' 'desktop-file-utils')
optdepends=('yad: for GUI'
'zenity: fallback for GUI')
provides=("${pkgname%-git}")
@@ -27,6 +28,13 @@ build() {
python -m build --wheel --no-isolation
}
+check() {
+ cd "${pkgname%-git}"
+ desktop-file-validate "src/${pkgname%-git}/data/share/applications/${pkgname%-git}.desktop"
+ desktop-file-validate "src/${pkgname%-git}/data/share/applications/${pkgname%-git}-launch.desktop"
+ appstreamcli validate "data/com.github.Matoking.${pkgname%-git}.metainfo.xml"
+}
+
package() {
cd "${pkgname%-git}"
python -m installer --destdir="$pkgdir" dist/*.whl