summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJason Stryker2022-07-01 15:02:25 -0400
committerJason Stryker2022-07-01 15:02:25 -0400
commita1f2466033c421768cbce97e3a57e157277991c1 (patch)
tree581462a7f546a643bf41dd0eb8c95a7d094fd3a2
parent54ae7719806c4a279a7886791bd731925762cbfd (diff)
downloadaur-a1f2466033c421768cbce97e3a57e157277991c1.tar.gz
use tags for versioning instead of setup.py
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD4
2 files changed, 3 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dbe6ab251b6e..30d160d03234 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = protontricks-git
pkgdesc = A simple wrapper that does winetricks things for Proton enabled games. (Git Version)
- pkgver = 1.8.2.dev3+gbe3805b
+ pkgver = 1.8.3.dev3+g8bed483
pkgrel = 1
url = https://github.com/Matoking/protontricks
arch = any
diff --git a/PKGBUILD b/PKGBUILD
index b695f6a019f6..4b894d6831b3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Jason Stryker <public at jasonstryker dot com>
pkgname=protontricks-git
-pkgver=1.8.2.dev3+gbe3805b
+pkgver=1.8.2.r3.8bed483
pkgrel=1
pkgdesc="A simple wrapper that does winetricks things for Proton enabled games. (Git Version)"
arch=('any')
@@ -20,7 +20,7 @@ sha512sums=('SKIP')
pkgver() {
cd "$srcdir/${pkgname%-git}"
- python3 setup.py --version
+ printf "%s" "$(git describe --long --tags | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
}
build() {