summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2024-01-21 11:03:59 -0700
committerMark Wagie2024-01-21 11:03:59 -0700
commitb19faaf4aff694bc69c1717ed1565f70467b8172 (patch)
tree1528203e5b5870d14d7f08f5d31cd1bb8ffe7cbb
parent81b06468b2b04926c3936cbc4298d66dc9adbd3e (diff)
downloadaur-b19faaf4aff694bc69c1717ed1565f70467b8172.tar.gz
use SPDX license identifier
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD8
2 files changed, 5 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a11b0c61147a..256e214eef85 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -4,7 +4,7 @@ pkgbase = protontricks-git
pkgrel = 1
url = https://github.com/Matoking/protontricks
arch = any
- license = GPL3
+ license = GPL-3.0-or-later
makedepends = git
makedepends = python-build
makedepends = python-installer
diff --git a/PKGBUILD b/PKGBUILD
index f64b87601271..fff44b281f8a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ pkgrel=1
pkgdesc="A simple wrapper that does winetricks things for Proton enabled games."
arch=('any')
url="https://github.com/Matoking/protontricks"
-license=('GPL3')
+license=('GPL-3.0-or-later')
depends=('python-pillow' 'python-setuptools' 'python-vdf' 'winetricks')
makedepends=('git' 'python-build' 'python-installer' 'python-setuptools-scm'
'python-wheel')
@@ -18,17 +18,17 @@ source=('git+https://github.com/Matoking/protontricks.git')
sha256sums=('SKIP')
pkgver() {
- cd "$srcdir/${pkgname%-git}"
+ cd "${pkgname%-git}"
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cd "$srcdir/${pkgname%-git}"
+ cd "${pkgname%-git}"
python -m build --wheel --no-isolation
}
package() {
- cd "$srcdir/${pkgname%-git}"
+ cd "${pkgname%-git}"
python -m installer --destdir="$pkgdir" dist/*.whl
# Remove protontricks-desktop-install, since we already install