summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2024-01-21 11:05:09 -0700
committerMark Wagie2024-01-21 11:05:09 -0700
commit2a65f8a3f555061c70c83c895994dbcfeee83423 (patch)
tree626de75b6f75f205934c482db6981c5101a2a3d5
parent7d844379f220078e56689ea6a8c987127dffbccb (diff)
downloadaur-protonup-git.tar.gz
use SPDX license identifier
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD10
2 files changed, 6 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9935cacd7148..e64d52360dc0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -4,7 +4,7 @@ pkgbase = protonup-git
pkgrel = 1
url = https://github.com/AUNaseef/protonup
arch = any
- license = GPL3
+ license = GPL-3.0-or-later
makedepends = git
makedepends = python-build
makedepends = python-installer
diff --git a/PKGBUILD b/PKGBUILD
index 508ce2ef88b4..c9407c75cdd3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
# Maintainer: Tobias Frisch <thejackimonster@gmail.com>
-# Co-Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
+# Co-Maintainer: Mark Wagie <mark dot wagie at proton dot me>
pkgname=protonup-git
pkgver=0.1.5.r0.g54bcad9
@@ -7,7 +7,7 @@ pkgrel=1
pkgdesc="Install and Update Proton-GE"
arch=('any')
url="https://github.com/AUNaseef/protonup"
-license=('GPL3')
+license=('GPL-3.0-or-later')
depends=('python' 'python-requests')
makedepends=('git' 'python-build' 'python-installer' 'python-setuptools' 'python-wheel')
provides=("${pkgname%-git}")
@@ -16,16 +16,16 @@ source=('git+https://github.com/AUNaseef/protonup.git')
sha256sums=('SKIP')
pkgver() {
- cd "$srcdir/${pkgname%-git}"
+ cd "${pkgname%-git}"
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cd "$srcdir/${pkgname%-git}"
+ cd "${pkgname%-git}"
python -m build --wheel --no-isolation
}
package() {
- cd "$srcdir/${pkgname%-git}"
+ cd "${pkgname%-git}"
python -m installer --destdir="$pkgdir" dist/*.whl
}