summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTheJackiMonster2021-08-02 20:34:52 +0200
committerTheJackiMonster2021-08-02 20:34:52 +0200
commit0e8d85d63361b8909beef3f263e9a96e511cc18c (patch)
tree8b0cf062c65875ad20a3156f585bea962f6ed6d5
downloadaur-0e8d85d63361b8909beef3f263e9a96e511cc18c.tar.gz
Initial commit
Signed-off-by: TheJackiMonster <thejackimonster@gmail.com>
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD26
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..924928555da2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = protonup-git
+ pkgdesc = Install and Update Proton-GE
+ pkgver = 0.1.3
+ pkgrel = 1
+ url = https://github.com/AUNaseef/protonup
+ arch = any
+ license = GPL
+ makedepends = python-setuptools
+ makedepends = git
+ depends = python
+ provides = protonup
+ options = !emptydirs
+ source = git+https://github.com/AUNaseef/protonup.git
+ sha256sums = SKIP
+
+pkgname = protonup-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..de453040a6a9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Tobias Frisch <thejackimonster@gmail.com>
+
+pkgname=protonup-git
+_realname=protonup
+pkgver=0.1.3
+pkgrel=1
+pkgdesc="Install and Update Proton-GE"
+arch=('any')
+url="https://github.com/AUNaseef/protonup"
+license=('GPL')
+depends=('python')
+makedepends=('python-setuptools' 'git')
+options=(!emptydirs)
+source=("git+https://github.com/AUNaseef/$_realname.git")
+sha256sums=('SKIP')
+provides=('protonup')
+
+pkgver() {
+ cd "$srcdir/$_realname"
+ cat setup.cfg | grep 'version = ' | awk '{print $3}'
+}
+
+package() {
+ cd "$srcdir/$_realname"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}