summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordataprolet2023-02-08 19:07:52 +0100
committerdataprolet2023-02-08 19:07:52 +0100
commita980aa17f1272d9acaf35935e0e3c00c559572eb (patch)
treec46d4f8ee0f6397d86a8b015d641caa73766a46a
downloadaur-a980aa17f1272d9acaf35935e0e3c00c559572eb.tar.gz
Initial submission.
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD16
2 files changed, 27 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..75addaaa0301
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,11 @@
+pkgbase = protonup-rs-bin
+ pkgdesc = Install and Update Proton-GE, rewritten in Rust
+ pkgver = 0.3.0
+ pkgrel = 1
+ url = https://github.com/auyer/Protonup-rs
+ arch = any
+ license = Apache
+ source = https://github.com/auyer/Protonup-rs/releases/download/v0.3.0/protonup-rs-linux-amd64.zip
+ sha256sums = b846d89626ebd4166b6d83ed60d9bfb851cbc13e60d5535ac67cfb52985f4ca0
+
+pkgname = protonup-rs-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..91cd63e4f90a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,16 @@
+# Maintainer: Arne BrĂ¼cher <archlinux@arne-bruecher.de>
+
+pkgname=protonup-rs-bin
+pkgver=0.3.0
+pkgrel=1
+pkgdesc="Install and Update Proton-GE, rewritten in Rust"
+url="https://github.com/auyer/Protonup-rs"
+license=("Apache")
+arch=('any')
+source=(https://github.com/auyer/Protonup-rs/releases/download/v$pkgver/protonup-rs-linux-amd64.zip)
+
+sha256sums=('b846d89626ebd4166b6d83ed60d9bfb851cbc13e60d5535ac67cfb52985f4ca0')
+
+package() {
+ install -D protonup-rs "$pkgdir"/usr/bin/protonup-rs
+}