summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYurii Kolesnykov2020-02-08 11:26:11 +0200
committerYurii Kolesnykov2020-02-08 11:26:11 +0200
commitbc6518f3a4de31f791be712256eae26c8f812c98 (patch)
treecf3a3ca68badc5d76f9348aaae03ad0456553a7c
downloadaur-bc6518f3a4de31f791be712256eae26c8f812c98.tar.gz
init
Signed-off-by: Yurii Kolesnykov <root@yurikoles.com>
-rw-r--r--.SRCINFO22
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD25
3 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d1d3e9dae549
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = protonvpn-cli-ng-git
+ pkgdesc = ProtonVPN CLI tool for protonvpn.com
+ pkgver = 2.2.1
+ pkgrel = 1
+ url = https://github.com/ProtonVPN/protonvpn-cli-ng
+ arch = any
+ license = GPLv3
+ depends = openvpn
+ depends = python
+ depends = dialog
+ depends = python-pythondialog
+ depends = python-setuptools
+ depends = python-docopt
+ depends = python-requests
+ provides = protonvpn-cli-ng
+ conflicts = protonvpn-cli-ng
+ replaces = protonvpn-cli
+ source = git+https://github.com/ProtonVPN/protonvpn-cli-ng
+ md5sums = SKIP
+
+pkgname = protonvpn-cli-ng-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..b18e875031f4
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+src/
+pkg/
+*.pkg.*
+protonvpn-cli-ng/ \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6103ea78fe7c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Yurii Kolesnykov <root@yurikoles.com>
+# Contributor: exprez135 <exprezdev at pm dot me>
+
+pkgname=protonvpn-cli-ng-git
+_src_name=protonvpn-cli-ng
+pkgver=2.2.1
+pkgrel=1
+pkgdesc="ProtonVPN CLI tool for protonvpn.com"
+arch=("any")
+url="https://github.com/ProtonVPN/protonvpn-cli-ng"
+license=("GPLv3")
+depends=("openvpn" "python" "dialog" "python-pythondialog" "python-setuptools" "python-docopt" "python-requests")
+replaces=("protonvpn-cli")
+conflicts=("${_src_name}")
+provides=("${_src_name}")
+source=("git+https://github.com/ProtonVPN/protonvpn-cli-ng")
+md5sums=("SKIP")
+
+package() {
+ # Install protonvpn-cli-ng package
+ cd "${_src_name}"
+ python setup.py install --optimize=1 --root="$pkgdir"
+
+ install -Dm644 ./LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}