summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTomasz Pakuła2023-11-08 05:18:00 +0100
committerTomasz Pakuła2023-11-08 05:18:00 +0100
commit2b7c2e206c754c5406a36001d6cad383334116da (patch)
treeafebcbb51ba55cb9d4f38ee0233f8e0bc8e8dd64
downloadaur-2b7c2e206c754c5406a36001d6cad383334116da.tar.gz
Initial release
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD31
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2175471ec87c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = protopedal
+ pkgdesc = Compatibility tool for sim racing pedals and force feedback steering wheels
+ pkgver = 2.3
+ pkgrel = 1
+ url = https://gitlab.com/openirseny/protopedal/
+ arch = x86_64
+ license = EUPL
+ makedepends = gcc
+ makedepends = glibc
+ source = git+https://gitlab.com/openirseny/protopedal
+ sha256sums = SKIP
+
+pkgname = protopedal
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..624f1dbd569a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Tomasz Pakula <forest10pl@gmail.com>
+pkgname=protopedal
+pkgver=2.3
+pkgrel=1
+pkgdesc="Compatibility tool for sim racing pedals and force feedback steering wheels"
+arch=('x86_64')
+url="https://gitlab.com/openirseny/protopedal/"
+license=('EUPL')
+depends=()
+makedepends=(
+ gcc
+ glibc
+)
+source=(git+https://gitlab.com/openirseny/protopedal)
+sha256sums=('SKIP')
+
+prepare() {
+ cd "$srcdir/$pkgname"
+ git checkout "release-$pkgver"
+}
+
+build() {
+ cd "$srcdir/$pkgname"
+ make build protopedal
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ mkdir -p "$pkgdir/usr/bin"
+ mv protopedal "$pkgdir/usr/bin/"
+}