summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Arndt2018-08-21 18:27:58 +0200
committerChristopher Arndt2018-08-21 18:27:58 +0200
commit754475b9712e6efe23c8ee795b9ea9739755195a (patch)
treee6cf0808961c8051aadf19be67b870292aaca9a8
downloadaur-protoplug.tar.gz
Add new package 'protoplug'
Signed-off-by: Christopher Arndt <chris@chrisarndt.de>
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD47
3 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..82c425881e2a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = protoplug
+ pkgdesc = A VST plugin which runs Lua scripts as audio and MIDI effects and instruments
+ pkgver = 1.4.0
+ pkgrel = 1
+ url = http://www.osar.fr/protoplug/
+ arch = i686
+ arch = x86_64
+ groups = vst-plugins
+ license = MIT
+ depends = curl
+ depends = gtk3
+ depends = luajit
+ optdepends = fftw: FFTW support for protoplug Lua scripts
+ source = protoplug-1.4.0.tar.gz::https://github.com/pac-dev/protoplug/archive/v1.4.0.tar.gz
+ sha256sums = 69fd7a581d2371b6776209fa199e7c7109e248b97605d34593de3cd1ed91c886
+
+pkgname = protoplug
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..c2c9bac0fa3a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+src/
+pkg/
+protoplug-*.tar.gz
+protoplug-*.tar.xz
+protoplug-*.src.tar.gz
+.AURINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..21d3bc9e9341
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: Christopher Arndt <aur -at- chrisarndt -dot- de>
+
+pkgname=protoplug
+pkgver=1.4.0
+pkgrel=1
+pkgdesc="A VST plugin which runs Lua scripts as audio and MIDI effects and instruments"
+arch=('i686' 'x86_64')
+url="http://www.osar.fr/protoplug/"
+license=("MIT")
+groups=('vst-plugins')
+depends=('curl' 'gtk3' 'luajit')
+optdepends=('fftw: FFTW support for protoplug Lua scripts')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/pac-dev/${pkgname}/archive/v${pkgver}.tar.gz")
+sha256sums=('69fd7a581d2371b6776209fa199e7c7109e248b97605d34593de3cd1ed91c886')
+
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}/Builds/multi/Linux/"
+
+ make CONFIG=Release
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ # plug-in binaries
+ install -Dm755 Bin/linux/*.so -t "${pkgdir}/usr/lib/vst"
+ # license
+ install -Dm644 license.txt -t "${pkgdir}/usr/share/licenses/${pkgname}"
+
+ # support files
+ cd ProtoplugFiles
+ install -dm755 "${pkgdir}/usr/share/ProtoplugFiles"
+ for file in effects generators include themes *.xml; do
+ cp -r $file "${pkgdir}/usr/share/ProtoplugFiles"
+ done
+
+ # documentation
+ cd doc
+ install -dm755 "${pkgdir}/usr/share/doc/${pkgname}"
+ for file in classes examples modules *.html *.css; do
+ cp -r $file "${pkgdir}/usr/share/doc/${pkgname}"
+ done
+ ln -s ../doc/${pkgname} "${pkgdir}/usr/share/ProtoplugFiles/doc"
+}
+
+# vim:set ts=2 sw=2 et: