summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVinson Chuong2016-01-17 20:19:37 -0800
committerVinson Chuong2016-01-17 20:19:37 -0800
commitd646afcbdbfec0c1fc5997446f7b3ecdced091f9 (patch)
tree5a09768ef814152abf297f24748ab7de93cb80cf
parent1ee88a9925eb37bf9410e44fb38067e2135c5663 (diff)
downloadaur-d646afcbdbfec0c1fc5997446f7b3ecdced091f9.tar.gz
v0.0.3-1
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD60
2 files changed, 40 insertions, 35 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0e2c9fd3dc31..3afd4e02023f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,25 @@
# Generated by mksrcinfo v8
-# Fri Jan 1 05:02:41 UTC 2016
+# Mon Jan 18 04:19:37 UTC 2016
pkgbase = prototypical
- pkgdesc = A\ starting\ point\ for\ a\ project
- pkgver = 0.0.2
+ pkgdesc = A starting point for a project
+ pkgver = 0.0.3
pkgrel = 1
url = https://github.com/vinsonchuong/prototypical
arch = any
license = MIT
checkdepends = bats-git
- makedepends = clidoc
+ makedepends = bats-git
+ makedepends = git
+ depends = bash-common-environment
depends = bash-common-parse-options
+ depends = postgresql
depends = perl
depends = ruby
depends = nodejs
depends = npm
optdepends = hub
- source = https://github.com/vinsonchuong/prototypical/archive/v0.0.2-1.tar.gz
- md5sums = bf18b04995be26df2d52e7486ce29ba1
+ source = https://github.com/vinsonchuong/prototypical/archive/v0.0.3-1.tar.gz
+ md5sums = 6050e566342d250aa8aec016e742176b
pkgname = prototypical
diff --git a/PKGBUILD b/PKGBUILD
index eca70fe00e5c..5a2c4cee7c47 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,44 +1,46 @@
# Maintainer: Vinson Chuong <vinsonchuong@gmail.com>
-pkgname="prototypical"
-pkgver="0.0.2"
-pkgrel="1"
-pkgdesc="A\ starting\ point\ for\ a\ project"
-arch=("any")
-url="https://github.com/vinsonchuong/prototypical"
-license=("MIT")
+pkgname=prototypical
+pkgver=0.0.3
+pkgrel=1
+pkgdesc=A\ starting\ point\ for\ a\ project
+arch=(any)
+url=https://github.com/vinsonchuong/prototypical
+license=(MIT)
depends=(
- "bash-common-parse-options"
- "perl"
- "ruby"
- "nodejs"
- "npm"
+ bash-common-environment
+ bash-common-parse-options
+ postgresql
+ perl
+ ruby
+ nodejs
+ npm
)
-optdepends=("hub")
-makedepends=("clidoc")
-checkdepends=("bats-git")
-source=("https://github.com/vinsonchuong/prototypical/archive/v0.0.2-1.tar.gz")
-md5sums=('bf18b04995be26df2d52e7486ce29ba1')
+optdepends=(hub)
+makedepends=(
+ bats-git
+ git
+)
+checkdepends=(bats-git)
+source=(https://github.com/vinsonchuong/prototypical/archive/v0.0.3-1.tar.gz)
+md5sums=('6050e566342d250aa8aec016e742176b')
build ()
{
cd "${srcdir}/${pkgname}-${pkgver}-${pkgrel}";
- if [ -d 'doc' ]; then
- clidoc doc/*.md;
- fi
+ clidoc doc/*.md
}
check ()
{
cd "${srcdir}/${pkgname}-${pkgver}-${pkgrel}";
- if [ -d 'spec' ]; then
- bats spec;
- fi
+ PATH="${PWD}/bin:${PATH}" bats spec
}
package ()
{
cd "${srcdir}/${pkgname}-${pkgver}-${pkgrel}";
- [ -d 'bin' ] && install -Dm755 -t "${pkgdir}/usr/bin" bin/*;
- [ -d 'help' ] && install -Dm644 -t "${pkgdir}/usr/share/${pkgname}/help" help/*;
- [ -f 'README.md' ] && install -Dm644 -t "${pkgdir}/usr/share/doc/${pkgname}" 'README.md';
- [ -d 'doc' ] && install -Dm644 -t "${pkgdir}/usr/share/doc/${pkgname}/doc" doc/*.md;
- [ -f 'LICENSE' ] && install -Dm644 -t "${pkgdir}/usr/share/licenses/${pkgname}" 'LICENSE';
- [ -d 'man' ] && install -Dm644 -t "${pkgdir}/usr/share/man/man1" man/*
+ [[ -d 'bin' ]] && install -Dm755 -t "${pkgdir}/usr/bin" bin/*;
+ [[ -d 'lib' ]] && install -Dm755 -t "${pkgdir}/usr/lib/${pkgname}" lib/*;
+ [[ -d 'help' ]] && install -Dm644 -t "${pkgdir}/usr/share/${pkgname}/help" help/*;
+ [[ -f 'README.md' ]] && install -Dm644 -t "${pkgdir}/usr/share/doc/${pkgname}" 'README.md';
+ [[ -d 'doc' ]] && install -Dm644 -t "${pkgdir}/usr/share/doc/${pkgname}/doc" doc/*.md;
+ [[ -f 'LICENSE' ]] && install -Dm644 -t "${pkgdir}/usr/share/licenses/${pkgname}" 'LICENSE';
+ [[ -d 'man' ]] && install -Dm644 -t "${pkgdir}/usr/share/man/man1" man/*
}