summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHolden Salomon2015-12-16 20:41:26 -0500
committerHolden Salomon2015-12-16 20:41:26 -0500
commit681640eae4bff076922a95c157373b26beb5c87c (patch)
treeb9d113609630ce34e3e2df2dfeb4d12c18f8e967
downloadaur-681640eae4bff076922a95c157373b26beb5c87c.tar.gz
first commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD30
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..12315cb61f08
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Thu Dec 17 01:40:51 UTC 2015
+pkgbase = proxmark3-flasher
+ pkgdesc = Offical proxmark3 flasher
+ pkgver = r1382.2c79288
+ pkgrel = 1
+ url = https://github.com/Proxmark/proxmark3/
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = make
+ makedepends = arm-none-eabi-gcc
+ makedepends = arm-none-eabi-newlib
+ depends = devkitarm
+ source = git+https://github.com/Proxmark/proxmark3.git
+ sha256sums = SKIP
+
+pkgname = proxmark3-flasher
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4df75e77f272
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Holden Salomon <holden@cryptolab.net>
+
+pkgname=proxmark3-flasher
+pkgver=r1382.2c79288
+pkgrel=1
+pkgdesc="Offical proxmark3 flasher"
+url="https://github.com/Proxmark/proxmark3/"
+arch=('i686' 'x86_64')
+license=('GPL3')
+makedepends=(git make arm-none-eabi-gcc arm-none-eabi-newlib)
+#depends=(devkitarm)
+depends=(devkitarm)
+source=('git+https://github.com/Proxmark/proxmark3.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/proxmark3/client"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/proxmark3/client"
+ make
+}
+
+package() {
+ cd "$srcdir/proxmark3/client"
+ mkdir -p $pkgdir/usr/bin
+ install flasher $pkgdir/usr/bin/proxmark3-flasher
+}