summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHuang-Huang Bao2019-01-12 23:01:54 +0800
committerHuang-Huang Bao2019-01-12 23:08:28 +0800
commitab56d3e490445b32cfd01e53ab65c46908f5dff8 (patch)
tree7d2b80d032ddcc289b21624e9d76c74259a9b8a9
downloadaur-ab56d3e490445b32cfd01e53ab65c46908f5dff8.tar.gz
Initial Commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD42
2 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a08cf1102d48
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = proxychains-ng-git
+ pkgdesc = A hook preloader that allows to redirect TCP traffic of existing dynamically linked programs through one or more SOCKS or HTTP proxies
+ pkgver = 4.13.r10.g1198857
+ pkgrel = 1
+ url = https://github.com/rofl0r/proxychains
+ arch = x86_64
+ license = GPL
+ depends = glibc
+ provides = proxychains
+ conflicts = proxychains
+ replaces = proxychains
+ backup = etc/proxychains.conf
+ source = git+https://github.com/rofl0r/proxychains-ng.git
+ sha512sums = SKIP
+
+pkgname = proxychains-ng-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..021624c5bb0f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Huang-Huang Bao <eh5@sokka.cn>
+# Maintainer: Felix Yan <felixonmars@archlinux.org>
+# Contributor: Cedric Girard <girard.cedric@gmail.com>
+
+_pkgname=proxychains-ng
+pkgname=$_pkgname-git
+pkgver=4.13.r10.g1198857
+pkgrel=1
+pkgdesc="A hook preloader that allows to redirect TCP traffic of existing dynamically linked programs through one or more SOCKS or HTTP proxies"
+arch=('x86_64')
+url="https://github.com/rofl0r/proxychains"
+license=('GPL')
+provides=('proxychains')
+replaces=('proxychains')
+conflicts=('proxychains')
+depends=('glibc')
+backup=('etc/proxychains.conf')
+source=("git+https://github.com/rofl0r/$_pkgname.git")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd $_pkgname
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+
+build() {
+ cd $_pkgname
+ ./configure --prefix=/usr --sysconfdir=/etc
+ make
+}
+
+package() {
+ cd $_pkgname
+ make DESTDIR="$pkgdir/" install
+ make DESTDIR="$pkgdir/" install-config
+ ln -s proxychains4 "$pkgdir/usr/bin/proxychains"
+}
+
+# vim:set ts=2 sw=2 et:
+
+