summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLászló Várady2019-03-26 20:47:01 +0100
committerLászló Várady2019-03-26 20:47:01 +0100
commit3fbd8a7a0f66a0058276fd1ae9673bb24b2cb8bf (patch)
tree2255a010593163e925b8b75d3f743259146a35c3
parentc7a2a6f6ef043fda3c1fd78bc8976b80d32ef78a (diff)
downloadaur-3fbd8a7a0f66a0058276fd1ae9673bb24b2cb8bf.tar.gz
v2019.03.25.00
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD39
2 files changed, 24 insertions, 34 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6867602dac12..05b0924e7912 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,25 @@
pkgbase = proxygen
pkgdesc = A collection of C++ HTTP libraries including an easy to use HTTP server.
- pkgver = 2019.03.18.00
+ pkgver = 2019.03.25.00
pkgrel = 1
url = https://github.com/facebook/proxygen
arch = x86_64
license = BSD
- makedepends = autoconf-archive
- makedepends = wget
- makedepends = ruby
+ makedepends = cmake
+ makedepends = python
makedepends = gperf
makedepends = gperftools
- makedepends = wangle
- makedepends = python
- makedepends = unzip
depends = folly
depends = fbthrift
+ depends = wangle
+ depends = zstd
+ depends = fizz
+ depends = openssl
+ depends = zlib
depends = libcap
conflicts = proxygen-git
- source = https://github.com/facebook/proxygen/archive/v2019.03.18.00.tar.gz
- sha256sums = b697bc6c2d3f564461a597a323272c0473b5ad624925ff5612525dba7d976850
+ source = https://github.com/facebook/proxygen/archive/v2019.03.25.00.tar.gz
+ sha256sums = cf849f27cd7780fbfa8ae7dce3518d15b13650da2ba8ca3c16cc6613f7d423a5
pkgname = proxygen
diff --git a/PKGBUILD b/PKGBUILD
index 77fe83d9955b..42961758ec4d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,45 +3,34 @@
# Contributor: Daichi Shinozaki <dsdseg@gmail.com>
pkgname=proxygen
-pkgver=2019.03.18.00
+pkgver=2019.03.25.00
pkgrel=1
pkgdesc="A collection of C++ HTTP libraries including an easy to use HTTP server."
arch=('x86_64')
url="https://github.com/facebook/proxygen"
license=('BSD')
-depends=('folly' 'fbthrift' 'libcap')
-makedepends=('autoconf-archive' 'wget' 'ruby' 'gperf' 'gperftools' 'wangle' 'python' 'unzip')
+depends=('folly' 'fbthrift' 'wangle' 'zstd' 'fizz' 'openssl' 'zlib' 'libcap')
+makedepends=('cmake' 'python' 'gperf' 'gperftools')
conflicts=('proxygen-git')
source=("$url/archive/v$pkgver.tar.gz")
-sha256sums=('b697bc6c2d3f564461a597a323272c0473b5ad624925ff5612525dba7d976850')
-
-prepare() {
- cd "$pkgname-$pkgver/$pkgname"
- autoreconf -ivf
-}
+sha256sums=('cf849f27cd7780fbfa8ae7dce3518d15b13650da2ba8ca3c16cc6613f7d423a5')
build() {
- cd "$pkgname-$pkgver/$pkgname"
- ./configure --prefix=/usr \
- --with-sysconfdir=/etc \
- --with-sysroot=/usr \
- --with-gnu-ld=yes
- make
+ cd "$pkgname-$pkgver"
+ cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr -B _build .
+ cmake --build _build
}
check() {
- cd "$pkgname-$pkgver/$pkgname"
- make check
+ cd "$pkgname-$pkgver"
+ # cmake --build _build --target test
}
package() {
- cd "$pkgname-$pkgver/$pkgname"
- make DESTDIR="$pkgdir/" install
-
- install -Dm644 ../LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ cd "$pkgname-$pkgver"
+ cmake --build _build --target install -- DESTDIR="$pkgdir/"
- # By default, 'make install' skips 'external' directory
- for i in http_parser_cpp.cpp http_parser.{c,h}; do
- install -Dm644 external/http_parser/$i $pkgdir/usr/include/external/http_parser/$i
- done
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 "$pkgname/external/http_parser/http_parser.h" \
+ "$pkgdir/usr/include/$pkgname/external/http_parser/http_parser.h"
}