summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLászló Várady2019-08-03 23:54:23 +0200
committerLászló Várady2019-08-03 23:54:23 +0200
commit44d5831f58e6f83e3f191f63d2277955798d9d16 (patch)
treea6ab515658d88c35795e157a3eadb42cff1c9dff
parent1efa86336cbd3056a1ecd625cf8a8d631ba3c232 (diff)
downloadaur-44d5831f58e6f83e3f191f63d2277955798d9d16.tar.gz
v2019.07.29.00
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD22
2 files changed, 22 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 96066718c264..d9d7db115d28 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = proxygen
- pkgdesc = A collection of C++ HTTP libraries including an easy to use HTTP server.
- pkgver = 2019.04.01.00
+ pkgdesc = A collection of C++ HTTP libraries including an easy to use HTTP server
+ pkgver = 2019.07.29.00
pkgrel = 1
url = https://github.com/facebook/proxygen
arch = x86_64
@@ -9,17 +9,22 @@ pkgbase = proxygen
makedepends = python
makedepends = gperf
makedepends = gperftools
+ makedepends = gtest
+ makedepends = gmock
+ depends = boost
+ depends = boost-libs
depends = folly
+ depends = fizz
depends = wangle
depends = zstd
- depends = fizz
- depends = boost
depends = openssl
depends = zlib
depends = libcap
+ depends = google-glog
+ depends = gflags
conflicts = proxygen-git
- source = https://github.com/facebook/proxygen/archive/v2019.04.01.00.tar.gz
- sha256sums = d377d23e8fd3621b40fab7143013d8aac142f5d295320456e78b0ab7b1824839
+ source = https://github.com/facebook/proxygen/archive/v2019.07.29.00.tar.gz
+ sha256sums = f1dcd12a0d20752e03767f56eae63d7610df8ef4f9602625c7cebef596a00b3f
pkgname = proxygen
diff --git a/PKGBUILD b/PKGBUILD
index aa6cb244959d..dd593b0fb363 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,34 +3,34 @@
# Contributor: Daichi Shinozaki <dsdseg@gmail.com>
pkgname=proxygen
-pkgver=2019.04.01.00
+pkgver=2019.07.29.00
pkgrel=1
-pkgdesc="A collection of C++ HTTP libraries including an easy to use HTTP server."
+pkgdesc="A collection of C++ HTTP libraries including an easy to use HTTP server"
arch=('x86_64')
url="https://github.com/facebook/proxygen"
license=('BSD')
-depends=('folly' 'wangle' 'zstd' 'fizz' 'boost' 'openssl' 'zlib' 'libcap')
-makedepends=('cmake' 'python' 'gperf' 'gperftools')
+depends=('boost' 'boost-libs' 'folly' 'fizz' 'wangle' 'zstd' 'openssl' 'zlib' 'libcap' 'google-glog' 'gflags')
+makedepends=('cmake' 'python' 'gperf' 'gperftools' 'gtest' 'gmock')
conflicts=('proxygen-git')
-source=("$url/archive/v$pkgver.tar.gz")
-sha256sums=('d377d23e8fd3621b40fab7143013d8aac142f5d295320456e78b0ab7b1824839')
+source=("${url}/archive/v${pkgver}.tar.gz")
+sha256sums=('f1dcd12a0d20752e03767f56eae63d7610df8ef4f9602625c7cebef596a00b3f')
build() {
cd "$pkgname-$pkgver"
- cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr -B _build .
+ cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr -S . -B _build
cmake --build _build
}
check() {
cd "$pkgname-$pkgver"
- # cmake --build _build --target test
+ cmake --build _build --target test
}
package() {
cd "$pkgname-$pkgver"
cmake --build _build --target install -- DESTDIR="$pkgdir/"
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
- install -Dm644 "$pkgname/external/http_parser/http_parser.h" \
- "$pkgdir/usr/include/$pkgname/external/http_parser/http_parser.h"
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm644 "${pkgname}/external/http_parser/http_parser.h" \
+ "${pkgdir}/usr/include/${pkgname}/external/http_parser/http_parser.h"
}