summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthew McGinn2017-10-26 07:36:47 -0400
committerMatthew McGinn2017-10-26 07:36:47 -0400
commit3c12268fb610d352e052deb3396c1260f195259e (patch)
treed5bce15010ea93cc0406a83f8e73d9d2ee03add0
downloadaur-3c12268fb610d352e052deb3396c1260f195259e.tar.gz
initial commit
-rw-r--r--.SRCINFO24
-rw-r--r--.gitignore11
-rw-r--r--PKGBUILD26
3 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..26940e695522
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+# Generated by mksrcinfo v8
+# Thu Oct 26 11:36:38 UTC 2017
+pkgbase = proxysql
+ pkgdesc = High-performance MySQL proxy with a GPL license
+ pkgver = 1.4.3
+ pkgrel = 1
+ url = http://proxysql.com
+ arch = any
+ license = GPL
+ makedepends = cmake
+ makedepends = automake
+ makedepends = bzip2
+ makedepends = make
+ makedepends = gcc
+ makedepends = git
+ makedepends = openssl
+ makedepends = patch
+ depends = cmake
+ provides = proxysql
+ source = https://github.com/sysown/proxysql/archive/v1.4.3.tar.gz
+ md5sums = a31ce0c80ba710e57eb64ffbb4ab7751
+
+pkgname = proxysql
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..26ea83fd2ca2
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,11 @@
+*
+!PKGBUILD
+!LICENSE
+!.SRCINFO
+!*.patch
+!*.desktop
+!*.install
+!*.service
+!*.sh
+!*.conf
+!.gitignore
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5d3390422385
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Matthew McGinn <mamcgi@gmail.com>
+pkgname=proxysql
+pkgver=1.4.3
+pkgrel=1
+pkgdesc="High-performance MySQL proxy with a GPL license"
+arch=('any')
+url="http://proxysql.com"
+license=('GPL')
+depends=('cmake')
+makedepends=('cmake' 'automake' 'bzip2' 'make' 'gcc' 'git' 'openssl' 'patch')
+provides=('proxysql')
+source=("https://github.com/sysown/${pkgname}/archive/v${pkgver}.tar.gz")
+md5sums=('a31ce0c80ba710e57eb64ffbb4ab7751')
+
+build() {
+ cd "${pkgname}-${pkgver}"
+ make
+}
+
+package() {
+ echo "${srcdir}"
+ install -Dm 0755 "${srcdir}/${pkgname}-${pkgver}/src/${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
+ install -Dm 0600 "${srcdir}/${pkgname}-${pkgver}/etc/${pkgname}.cnf" "${pkgdir}/etc/${pkgname}.cnf"
+ mkdir -p "${pkgdir}/var/lib/${pkgname}"
+ install -Dm 0644 "${srcdir}/${pkgname}-${pkgver}/systemd/${pkgname}.service" "${pkgdir}/usr/lib/systemd/system/${pkgname}.service"
+}