summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRsplwe2023-05-04 00:20:23 +0800
committerRsplwe2023-05-04 00:20:23 +0800
commit06ff6a682ea7d5d7f9e3c0faec9e4deecd9f2052 (patch)
treeefe733ad372425d097bff933085514e9a29f296d
parentefe581986f9b004d3e03cc3944840bce674632a1 (diff)
downloadaur-06ff6a682ea7d5d7f9e3c0faec9e4deecd9f2052.tar.gz
update
-rw-r--r--PKGBUILD32
1 files changed, 9 insertions, 23 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f8e1fbb535f4..a6d2a08c8428 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,37 +1,23 @@
# Maintainer: Rsplwe <i@rsplwe.com>
pkgname=prpr
-pkgver=kira_1
+pkgver=1.0.0
pkgrel=1
-epoch=
pkgdesc="pe~ ro~ pe~ ro~"
arch=('any')
url="https://github.com/Rsplwe/prpr"
license=('WTFPL')
-groups=()
depends=()
-makedepends=('git')
-checkdepends=()
-optdepends=()
-provides=("${pkgname}")
-conflicts=("${pkgname}")
-replaces=()
-backup=()
-options=()
-install=
-changelog=
-source=("${pkgname}::git+https://github.com/Rsplwe/prpr.git")
-noextract=()
-md5sums=('SKIP')
-validpgpkeys=()
+source=("$pkgname-$pkgver.tar.gz::https://github.com/Rsplwe/prpr/archive/$pkgver.tar.gz")
+sha512sums=('51959b5117bb088c4e6570521e8f422b365240614f56c4c5cecd7b5c3dab0f57fcf0dd63be45c7776a24adea11508982333f38c68c60a6303a0c46bdfe15f5d1')
build() {
- cd "${pkgname}"
- rm -rf "${pkgname}"
- gcc -O3 main.c -o "${pkgname}"
+ cd "prpr-$pkgver"
+ make
}
package() {
- cd "${pkgname}"
- install -D -m 755 "${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
- install -D -m 644 'LICENCE' "${pkgdir}/usr/share/licenses/${pkgname}/LICENCE"
+ cd "prpr-$pkgver"
+
+ install -D -m 755 prpr "$pkgdir/usr/bin/prpr"
+ install -D -m 644 LICENCE "$pkgdir/usr/share/licenses/$pkgname/LICENCE"
}