summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRsplwe2021-06-27 22:43:44 +0800
committerRsplwe2021-06-27 22:43:44 +0800
commitefe581986f9b004d3e03cc3944840bce674632a1 (patch)
tree4ceb194af11552c5d0881120d444ea6e70c69e89
downloadaur-efe581986f9b004d3e03cc3944840bce674632a1.tar.gz
prpr ver 0.1
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD37
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b2b35b123269
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = prpr
+ pkgdesc = pe~ ro~ pe~ ro~
+ pkgver = kira_1
+ pkgrel = 1
+ url = https://github.com/Rsplwe/prpr
+ arch = any
+ license = WTFPL
+ makedepends = git
+ provides = prpr
+ conflicts = prpr
+ source = prpr::git+https://github.com/Rsplwe/prpr.git
+ md5sums = SKIP
+
+pkgname = prpr
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f8e1fbb535f4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Rsplwe <i@rsplwe.com>
+pkgname=prpr
+pkgver=kira_1
+pkgrel=1
+epoch=
+pkgdesc="pe~ ro~ pe~ ro~"
+arch=('any')
+url="https://github.com/Rsplwe/prpr"
+license=('WTFPL')
+groups=()
+depends=()
+makedepends=('git')
+checkdepends=()
+optdepends=()
+provides=("${pkgname}")
+conflicts=("${pkgname}")
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("${pkgname}::git+https://github.com/Rsplwe/prpr.git")
+noextract=()
+md5sums=('SKIP')
+validpgpkeys=()
+
+build() {
+ cd "${pkgname}"
+ rm -rf "${pkgname}"
+ gcc -O3 main.c -o "${pkgname}"
+}
+
+package() {
+ cd "${pkgname}"
+ install -D -m 755 "${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
+ install -D -m 644 'LICENCE' "${pkgdir}/usr/share/licenses/${pkgname}/LICENCE"
+}