summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortimvisee2021-04-12 10:49:38 +0200
committertimvisee2021-04-12 10:49:38 +0200
commit17b488a5b785eae1c045141e9e8679f45e1881dc (patch)
tree32b981d5e2be63002dc7fb40b8eae77f4855b127
parent83ad18c46c0c5a54fa568a8749c309fcbc1807e2 (diff)
downloadaur-17b488a5b785eae1c045141e9e8679f45e1881dc.tar.gz
Only build prs binary, remove gtk3 dependency, support any architecture
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD10
2 files changed, 7 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ba1e2dec4020..8d344ea2800a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,15 @@
pkgbase = prs-git
pkgdesc = Secure, fast & convenient password manager CLI using GPG and git to sync (git)
pkgver = 0.2.7.r1.g0b90393
- pkgrel = 1
+ pkgrel = 2
url = https://gitlab.com/timvisee/prs
- arch = x86_64
+ arch = any
license = GPL3
makedepends = rust
makedepends = python
makedepends = git
depends = gpgme
depends = dbus
- depends = gtk3
provides = prs
conflicts = prs
source = git+https://gitlab.com/timvisee/prs
diff --git a/PKGBUILD b/PKGBUILD
index a42e0ec481e0..393c141742a7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,12 +4,12 @@
pkgname=prs-git
pkgver=0.2.7.r1.g0b90393
-pkgrel=1
+pkgrel=2
pkgdesc="Secure, fast & convenient password manager CLI using GPG and git to sync (git)"
-arch=('x86_64')
+arch=('any')
url="https://gitlab.com/timvisee/prs"
license=('GPL3')
-depends=('gpgme' 'dbus' 'gtk3')
+depends=('gpgme' 'dbus')
makedepends=('rust' 'python' 'git')
conflicts=("${pkgname%-git}")
provides=("${pkgname%-git}")
@@ -23,12 +23,12 @@ pkgver() {
build() {
cd "${pkgname%-git}"
- cargo build --release --locked
+ cargo build --package prs-cli --release --locked
}
check() {
cd "${pkgname%-git}"
- cargo test --release --locked
+ cargo test --package prs-cli --release --locked
}
package() {